Newbie experiencing multiple problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Newbie experiencing multiple problems

Postby stevegreen22 » 01. September 2013 16:06

Hi guys,

I've been wanting to set up a home web server for some time now and finally got around to working my way through a few tutorials. However I'm having several problems.

The steps I took:

Installed XAMPP
Registered with FreeDNS and changed the name servers.
Opened relevant ports on router and set the IP address to be static

-
After a bit of mess it was all working fine but I couldn't access the Admin part.
I had changed the conf file to tell it the site was located elsewhere.

I then added a virtual host in the hosts file and update the hosts file in sys 32 to say that I could either go to website.localhost.com for my site or admin.localhost.com for the XAMPP Admin.

Again, all seemed to be working well.

I now have several problems.

The website.localhost.com when accessed from the server returns access forbidden. The website itself steve-t-green.com when accessed by anyone else also shows this error. My laptop still displays it fine which is odd but I suspect there's a cache issue somewhere that's allowing me to view it.

My other problem is that I can't access steve-t-green.com from the sever, I get an error message.

the www prefix doesn't work.

When the site was working, if I uploaded any files to it via FTP, the files would show on the server but wouldn't be visible on the website, they could only be viewed on the server machine.

Any help with any of these issues is greatly appreciated. Obviously I'd love to have the site live first :)
stevegreen22
 
Posts: 1
Joined: 01. September 2013 15:28
XAMPP Version: 5.5.19
Operating System: win xp

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests