Wartezeit im Browser?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wartezeit im Browser?

Postby Cobra427 » 22. September 2012 17:55

Hallo
Ich verwende die 1.7.7 weil die 1.8 nach der Installation (USB Light) keine control im Verzeichnis /xampp hat.
Per Sufu habe ich jetzt viel und wenig gefunden, leider bisher keine Lösung für mich.
Ich sehe das der Browser bei jedem Ladevorgang schreibt: warten auf localhost
das gehts so ca. 3-5s und dann wird erst geladen
zum Entwickeln meiner Joomla Site ist das sehr blockierend und es stört mich jetzt so weit das ich eine Lösung suche!
das mit dem localhost im php, hosts und Änderungen in der my.ini sind drin, aber keine Änderung... :?:
Wir hatten vor Jahren schon mal das selbe Problem wo wir dann in einer ini irgend welche Zeiten geändert hatten, leider habe ich die alten Zugangsdaten zum Forum nicht mehr und musste jetzt neu anmelden, somit habe ich meine alten posts nicht mehr :evil:
am Joomla kanns nur gering liegen, auf meinem NAS läuft das alles viel schneller, es ist die USB-Installtion xampp die def. langsamer ist... ?
Danke für jede Hilfe! :D
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 05:44

Niemand? :shock:

In welcher Datei von xampp befinden sich die Wartezeiten usw. ?
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Altrea » 25. September 2012 10:57

Hallo Cobra427,

Cobra427 wrote:Niemand? :shock:

Nun, soviele Helferlein gibt es hier leider nicht mehr, die deutsche Beiträge beantworten.
Ich habe bisher nicht darauf geantwortet, weil auch ich derzeit nicht weiß, wo der Fehler bei dir liegen kann.

Cobra427 wrote:In welcher Datei von xampp befinden sich die Wartezeiten usw. ?

Eine Einstellung für Wartezeiten gibt es natürlich nicht. Es würde auch garkeinen Sinn machen irgendwo eine Zeit einstellen zu können die Apache oder PHP erstmal abwartet, bevor es die Anfrage beantwortet.
Es gibt verschiedene Stellschräubchen sowohl in der MySQL my.ini, als auch der Apache httpd.conf, die einen Geschwindigkeitsgewinn bringen könnten, indem dann mehr Übertragungsrate/RAM/CPU Last erzeugt wird. Doch inwieweit das eine Besserung deines Problems herbeiführt, ist offen. Es könnte genauso gut ein Problem mit der Namensauflösung oder dem IP-Stack sein, und da ist dann dein Betriebssystem im Fokus. Oder es ist ein Problem mit Sicherheitssoftware die jeden Aufruf vorher scant. Oder es ist ein Problem der durch einen Virus verursacht wurde. Die Möglichkeiten sind vielfältig.

Ein paar Dinge die du probieren könntest:
viewtopic.php?f=16&t=47453&p=192011&hilit=slow#p192011
viewtopic.php?f=16&t=51152&p=197529&hilit=mysqli#p197529
viewtopic.php?f=16&t=51374&p=198026&hilit=slow#p197915

Du kannst den Windows Socket und den Windows IP Stack mit folgenden Kommandozeilenparametern zurücksetzen (die Eingabeaufforderung muss dafür mit erweiterten Administrativen Rechten ausgeführt werden):
Code: Select all
netsh int ip reset

Code: Select all
netsh winsock reset


Du kannst und solltest Verzeichnisse, Prozesse und Kommunikationskanäle der XAMPP Komponenten als Ausnahmen zu deinen Sicherheitssoftwareprodukten hinzufügen.

Du könntest MySQL ein wenig tunen, indem du vor Allem dessen buffer size Einstellungen etwas hochschraubst. Vergleiche hierzu mal das Template \xampp\mysql\my-large.ini mit deinen jetzigen Einstellungen in der my.ini.
Du könntest verschiedene Einstellungen probieren Apache zu tunen: http://httpd.apache.org/docs/2.2/misc/perf-tuning.html

Alle Tuningmaßnahmen müssen immer im Hinblick auf deine verfügbaren Ressourcen geschehen und können bei Übertreibung auch ins Negative umschlagen.
Übder jede Konfigurationsänderung die du vornimmst, solltest du doppelt nachdenken und dich informieren, was diese Einstellung überhaupt tut.
Jede Einstellung sollte vor Allem bei Apache in allen jeweiligen Konfigurationsdateien gesucht werden, ob sie nicht vielleicht schon existiert.

Dir sollte klar sein, dass es für dieses Forum schon jetzt kaum möglich ist, dein Problem genau einzukreisen (solch eine genaue Analyse wo bei dir der Flaschenhals liegt kann nur vor Ort an dem jeweiligen Rechner geschehen, das kann dieses Forum hier nicht leisten). Probleme die aus nun folgenden Konfigurationsänderungen geschehen sind noch schwieriger einzukreisen und könnten in einer kompletten Neuinstallation von XAMPP enden.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 12:29

Hallo Altrea
vielen Dank für die zahlreichen Infos!
die Unterschiede meiner my.ini sind:
http://www.file-upload.net/download-4822834/Zwischenablage-1.jpg.html
http://www.file-upload.net/download-4822836/Zwischenablage-2.jpg.html

ich habe da auch eine Fehlermeldung mit max. Time Limit
Fatal error: Maximum execution time of 30 seconds exceeded in S:\xampp\htdocs\libraries\joomla\filesystem\file.php on line 523
kannst du mir sagen wo diese 30s Beschränkung zu finden ist?

vielen Dank!!!!!
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Altrea » 25. September 2012 12:56


Die Unterschiede musst du schon selbst analysieren, vor Allem auch da du der einzige bist, der dein System kennt.
Ich kann dir keine Empfehlung geben, welchen Wert du wie hoch stellen kannst. Zum einen hängt das von unterschiedlichsten Faktoren ab (nicht zuletzt auch davon, wieviel deiner Systemressourcen schon von anderen Programmen und Prozessen verwendet werden und ggf. gebraucht werden), zum anderen sind das alles Erfahrungswerte die jeder für sich selbst sammeln sollte. Performance-Tuning geht auch ein wenig darüber hinaus, was das Forum hier leisten kann und möchte.

Cobra427 wrote:ich habe da auch eine Fehlermeldung mit max. Time Limit
Fatal error: Maximum execution time of 30 seconds exceeded in S:\xampp\htdocs\libraries\joomla\filesystem\file.php on line 523
kannst du mir sagen wo diese 30s Beschränkung zu finden ist?

Siehe dein anderer Beitrag...
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Wartezeit im Browser?

Postby Nobbie » 25. September 2012 13:36

Setze in der Konfiguration den Wert von "EnableSendilfe" auf "off" (Default ist "on"). Starte Apache danach neu.

Siehe: http://httpd.apache.org/docs/2.2/de/mod ... lesendfile
Nobbie
 
Posts: 7141
Joined: 09. March 2008 13:04

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 13:37

JA! die php.ini haben wir damals verändert, kann mich noch erinnern auf error logging auf off, mehr aber dann auch wieder nicht...
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 13:41

Nobbie wrote:Setze in der Konfiguration den Wert von "EnableSendilfe" auf "off" (Default ist "on"). Starte Apache danach neu.

Siehe: http://httpd.apache.org/docs/2.2/de/mod/core.html#enablesendfile


natürlich in derh httpd.conf
war mit # auskommentiert
direkt dabei ist auch noch:
EnableMMAP off
sollte ich dieses auch auskommentieren?
Danke!!!

habe ich jetzt auch im Link von Altrea nach gelesen, diese Win-Einstellung möchte ich mal nciht auf dem Fa.Lappi machen...?

zum letzten Link: Ich gehe davon aus das mein Heimnetz Viren-Frei ist. Ich betreibe hier wirklich hohen Aufwand mit diversen Viruskiller und Spybots. Jede Woche! seit gut einem halben Jahr wurde ncihts mehr gefunden.. :mrgreen:
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Altrea » 25. September 2012 14:41

Cobra427 wrote:direkt dabei ist auch noch:
EnableMMAP off
sollte ich dieses auch auskommentieren?

Das hängt ganz von deinem System ab, entscheide selbst:
http://httpd.apache.org/docs/2.2/mod/co ... enablemmap

Cobra427 wrote:diese Win-Einstellung möchte ich mal nciht auf dem Fa.Lappi machen...?

Auch dies kannst nur du allein (beziehungsweise dein zuständiger Administrator) entscheiden.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 14:46

OK, Danke!
ich muss dann mal sehen was bei mir so hilft...
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Altrea » 25. September 2012 15:01

Lass uns wissen, ob und was geholfen hat.

Unter Umständen enthält dein \xampp\apache\logs\error.log noch weitere Hinweise für mögliche Ursachen
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 15:58

hat mal alles nix geholfen bisher...
das log vom appache:
http://www.file-upload.net/download-4823503/error.log.html
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 16:06

Log nach Aufruf ein paar Seiten
http://www.file-upload.net/download-482 ... r.log.html

mysql
http://www.file-upload.net/download-482 ... r.log.html

php logs bleibt leer

ich sehe da drin nichts ?
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Cobra427 » 25. September 2012 20:06

hab grad meine aktuelle Installation auf den NAS übertragen und dort läuft es fast ohne Verzögerung (ca.1s)
am Stick mit xampp ca.7-10s... das ist schon heftig :(
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP

Re: Wartezeit im Browser?

Postby Cobra427 » 26. September 2012 06:29

also !! was es jetzt richtig gebracht hat war die my.ini auf die large umzustellen!
jetzt bin ich unter 2s!
Cobra427
 
Posts: 13
Joined: 22. September 2012 12:25
XAMPP Version: 1.8.3-3
Operating System: XP


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests