problem starting phpmyadmin

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

problem starting phpmyadmin

Postby degras » 26. April 2009 18:01

I get an error when trying to start phpMyAdmin:
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

Here is the error log:

[Sun Apr 26 16:04:41 2009] [notice] Apache/2.2.4 (Win32) PHP/5.2.3 configured -- resuming normal operations
[Sun Apr 26 16:04:41 2009] [notice] Server built: Jan 9 2007 23:17:20
[Sun Apr 26 16:04:41 2009] [notice] Parent: Created child process 4160
[Sun Apr 26 16:04:42 2009] [warn] module rewrite_module is already loaded, skipping
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program Files\\PHP\\ext\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Sun Apr 26 16:04:43 2009] [notice] Child 4160: Child process is running
[Sun Apr 26 16:04:43 2009] [notice] Child 4160: Acquired the start mutex.
[Sun Apr 26 16:04:43 2009] [notice] Child 4160: Starting 250 worker threads.
[Sun Apr 26 16:04:43 2009] [notice] Child 4160: Starting thread to listen on port 80.
[Sun Apr 26 16:11:35 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/phpMyAdmin/libraries/
[Sun Apr 26 16:11:40 2009] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\Daniel\\LOCALS~1\\Temp\\php\\session\\sess_lailoekhmu4p7k9e6mfkhs2ek1, O_RDWR) failed: No such file or directory (2) in C:\\Program Files\\Apache Software Foundation\\Apache2.2\\htdocs\\phpMyAdmin\\libraries\\session.inc.php on line 89, referer: http://127.0.0.1/phpmyadmin/
[Sun Apr 26 16:11:40 2009] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\Daniel\\LOCALS~1\\Temp\\php\\session\\sess_lailoekhmu4p7k9e6mfkhs2ek1, O_RDWR) failed: No such file or directory (2) in Unknown on line 0, referer: http://127.0.0.1/phpmyadmin/
[Sun Apr 26 16:11:40 2009] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\Daniel\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0, referer: http://127.0.0.1/phpmyadmin/

Here is the access log:

[Sun Apr 26 15:59:41 2009] [warn] module rewrite_module is already loaded, skipping
[Sun Apr 26 16:04:42 2009] [warn] module rewrite_module is already loaded, skipping
127.0.0.1 - - [26/Apr/2009:16:11:34 +0100] "GET /phpmyadmin HTTP/1.1" 301 236
127.0.0.1 - - [26/Apr/2009:16:11:34 +0100] "GET /phpmyadmin/ HTTP/1.1" 200 5064
127.0.0.1 - - [26/Apr/2009:16:11:40 +0100] "GET /phpmyadmin/index.php HTTP/1.1" 302 433
127.0.0.1 - - [26/Apr/2009:16:11:40 +0100] "GET /phpmyadmin/error.php?lang=en&dir=ltr&type=Error&error=Cannot+start+session+without+errors%2C+please+check+errors+given+in+your+PHP+and%2For+webserver+log+file+and+configure+your+PHP+installation+properly. HTTP/1.1" 200 1209


Help appreciated, thanks.
degras
 
Posts: 1
Joined: 26. April 2009 15:38

Re: problem starting phpmyadmin

Postby Sharley » 26. April 2009 22:50

If you are using XAMPP then maybe it is is using the wrong php.ini file.

Search your PC for all php.ini files and either delete or rename those you find that are not in your xampp installation folder.

XAMPP uses the php.ini file in the xampp\apache\bin folder in versions 1.7.0 and below and in xampp\php folder in the latest version 1.7.1

http://localhost/xampp/phpinfo.php will tell you which php.ini file is currently being used by XAMPP in the line Loaded Configuration File.


If you are not using XAMPP (which it would appear so) then perhaps you should as this is an XAMPP forum.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problem starting phpmyadmin

Postby AgusDiaz » 23. February 2010 22:16

Hi all,

I have the same problem with phpmyadmin. My Xampp is 1.7.3a and the only php.ini file on my Pc is

/opt/lampp/etc/php.ini

Any advice will be welcome!

Saludos!
AgusDiaz
 
Posts: 1
Joined: 23. February 2010 22:07

Re: problem starting phpmyadmin

Postby turner23x » 15. December 2010 17:59

Thanks for the solution Sharley! i had the same problem but this solved it for me
turner23x
 
Posts: 1
Joined: 15. December 2010 17:54

Re: problem starting phpmyadmin

Postby zhosting.solutions » 18. March 2011 16:38

I'm having the same problem. The path to my php.ini is W:\xampp\php\php.ini.

What variables should I change in order to get it working and being able to log in? Thanks.
zhosting.solutions
 
Posts: 4
Joined: 28. February 2011 19:13

Re: problem starting phpmyadmin

Postby Sharley » 19. March 2011 01:49

zhosting.solutions wrote:I'm having the same problem. The path to my php.ini is W:\xampp\php\php.ini.

What variables should I change in order to get it working and being able to log in? Thanks.
What error message is returned when you try and login to phpMyAdmin?

How exactly are you trying to login from http://localhost/phpmyadmin ?

On a default installation and without adding a password for user root in the security section of the Welcome Demo Page, then you would only need to type in the user box root and skip the password then click on Go.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problem starting phpmyadmin

Postby zhosting.solutions » 19. March 2011 22:24

Sharley wrote:
zhosting.solutions wrote:I'm having the same problem. The path to my php.ini is W:\xampp\php\php.ini.

What variables should I change in order to get it working and being able to log in? Thanks.
What error message is returned when you try and login to phpMyAdmin?

How exactly are you trying to login from http://localhost/phpmyadmin ?

On a default installation and without adding a password for user root in the security section of the Welcome Demo Page, then you would only need to type in the user box root and skip the password then click on Go.


Hi.

Ok. So, what I did after I installed Xampp is to go to http://localhost/security/index.php and create my root password and htaccess username and password.

To log into my PhpMyAdmin, I'm trying my htaccess password that it takes for me to log into the server and I get the following "Wrong username/password. Access denied." Should I go ahead and use Root as the login and use my root password that I created, or how do I access my PhpMyAdmin?

Also, did you read my post I created called "Control Panel Setup Help Needed?"
zhosting.solutions
 
Posts: 4
Joined: 28. February 2011 19:13

Re: problem starting phpmyadmin

Postby fabscarf » 31. March 2011 16:20

Hi
I have a very unusual problem:
Some info: I am developing few joomla websites (5.22) over a XAMPP for Windows Version 1.7.1
1) I can access phpmyadmin but all my databases have dissapered from the the left panel. Obviously i am not allowed to create privileges for any of the databases. However all my databases are still tehre in c:\xampp\mysql\data\site_directory\
2) My access to the administrator in joomla works.
3) Tryed to change password in config.inc.php to root. No luck in this case i can't access phpmyadmin
Can someone help?
Fab
fabscarf
 
Posts: 1
Joined: 31. March 2011 15:57


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 6 guests