apache authentication failing

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

apache authentication failing

Postby pw44 » 10. July 2020 13:13

Moin Zusammen,

meine Apache Konfiguration schaft nicht nach Anwender und Kennwort anzufordern bei awstats. Bei Netdata geht es, aber bei Awstats nicht.

Könnte jemand dabei helfen raus zu finden woran es liegt?

Code: Select all
<VirtualHost *:443>
    ServerName www.example.br
    ServerAdmin webmaster@example.br
    DocumentRoot /var/www/html/public
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    SSLEngine on
    SSLCACertificateFile   /etc/ssl/certs/PSign_TrustCenter_Root_CA-I.pem
    SSLCertificateKeyFile  /etc/ssl/private/server.key
    SSLCertificateFile     /etc/ssl/private/server.crt
    <IfModule maxminddb_module>
            MaxMindDBEnable On
            MaxMindDBFile CITY_DB /usr/share/GeoIP/GeoLite2-City.mmdb
            MaxMindDBFile COUNTRY_DB /usr/share/GeoIP/GeoLite2-Country.mmdb
            MaxMindDBEnv MM_CONTINENT_CODE          COUNTRY_DB/continent/code
            MaxMindDBEnv MM_CONTINENT_NAME          COUNTRY_DB/continent/names/en
            MaxMindDBEnv MM_COUNTRY_CODE            COUNTRY_DB/country/iso_code
            MaxMindDBEnv MM_COUNTRY_NAME            COUNTRY_DB/country/names/en
            #SetEnvIf MM_COUNTRY_CODE ^(CN|EU) BlockCountry
            SetEnvIf MM_COUNTRY_CODE ^(CN|RU|UA|AL) BlockCountry
            <Location />
                    <RequireAll>
                    Require all granted
                    Require not env BlockCountry
                    </RequireAll>
            </Location>
    </IfModule>
    <IfModule mod_headers.c>
            Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; nosniff; SAMEORIGIN"
    </IfModule>
   
  # netdata

   RewriteEngine on
   ProxyRequests Off
   <proxy>
     Order deny,allow
     Allow from all
   </proxy>
   ProxyPass "/netdata/" "http://192.168.80.4:19999/" connectiontimeout=5 timeout=30
   ProxyPassReverse "/netdata/" "http://192.168.80.4:19999/"
   <location /netdata/>
         AuthType Basic
         AuthName "Netdata User Access Required"
         AuthUserFile /etc/apache2/.htpasswd
         Require valid-user
         Order deny,allow
         Allow from all
   </location>

  # awstats

   Alias /awstatsclasses "/usr/share/awstats/lib/"
   Alias /awstats-icon/ "/usr/share/awstats/icon/"
   Alias /awstatscss "/usr/share/doc/awstats/examples/css"
   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   ScriptAlias /awstats/ /usr/lib/cgi-bin/
   Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
   <Directory "/usr/lib/cgi-bin/">
         <Files awstats.pl>
             AuthUserFile /etc/apache2/.htpasswd
             AuthName "Awstats login"
             AuthType Basic
             Require valid-user
         </Files>
   </Directory>

</VirtualHost>


Vielen Dank!
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby Nobbie » 10. July 2020 18:35

Trotz der katastrophalen Beschreibung würde ich raten, dass Apache nicht die Datei /etc/apache2/.htpasswd lesen kann.

P.S.: Welches Xampp hast Du installiert? Das Forum heißt ja "Xampp für Linux". Und das ist durchaus auch so gemeint.
Nobbie
 
Posts: 11776
Joined: 09. March 2008 13:04

Re: apache authentication failing

Postby pw44 » 10. July 2020 20:59

XAMPP 7.2.31 (Apache 2.4.43)

katastrophalen Beschreibung. Kannst Du helfen oder nicht? Und ja, habe eine auf English und eine auf Deutsch.

Meine Apache Konfiguration kann Benutzer und Kennwort für den Abschnitt awstats nicht anfordern. Für den Abschnitt netdata funktioniert es wie erwartet. Hätte jemand eine Lösung?
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby Nobbie » 10. July 2020 21:43

pw44 wrote:XAMPP 7.2.31 (Apache 2.4.43)

katastrophalen Beschreibung. Kannst Du helfen oder nicht?


Da Du nicht einmal lesen kannst, ist es sinnlos. Ich habe oben eine Vermutung geäussert und nach genauer Durchsicht Deiner Konfiguration ist das auch der Grund.

Wieso hast Du alle Pfade geändert? Xampp ist in /opt/lampp installiert, aber bei Dir ist da überhaupt nichts installliert.
Nobbie
 
Posts: 11776
Joined: 09. March 2008 13:04

Re: apache authentication failing

Postby pw44 » 10. July 2020 22:53

Nobbie wrote:
pw44 wrote:XAMPP 7.2.31 (Apache 2.4.43)

katastrophalen Beschreibung. Kannst Du helfen oder nicht?


Da Du nicht einmal lesen kannst, ist es sinnlos. Ich habe oben eine Vermutung geäussert und nach genauer Durchsicht Deiner Konfiguration ist das auch der Grund.

Wieso hast Du alle Pfade geändert? Xampp ist in /opt/lampp installiert, aber bei Dir ist da überhaupt nichts installliert.


Tja, lesen kann ich schon. Das meine Konfiguration der Grund ist weiß ich auch, da ist etwas falsch. Deswegen habe ich um Hilfe gebeten.

Es sieht aus Du kannst nicht helfen aber willst Deine Meinung äußern und kritisieren. Das machen Kluge Burschen gerne. Mach es Gut.
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby Nobbie » 11. July 2020 18:12

würde ich raten, dass Apache nicht die Datei /etc/apache2/.htpasswd lesen kann.


Und warum er das einmal kann, das andere mal aber nicht, das hast Du so eingebaut. Wenn Du Dir bei jeder Anweisung etwas gedacht hast, solltest Du den Unterschied schnell finden. Aber Du erklärst uns ja nicht einmal, wieso es keine Xampp Pfade in der Installation gibt.
Nobbie
 
Posts: 11776
Joined: 09. March 2008 13:04

Re: apache authentication failing

Postby pw44 » 11. July 2020 21:39

Nobbie wrote:würde ich raten, dass Apache nicht die Datei /etc/apache2/.htpasswd lesen kann.


Ich wollte es aber so, um die Konfigurationen mit andere Umgebungen, z.B Ubuntu kompatibel zu halten. Einfacher zu Kopieren, nachdem es in einen funktioniert, um Typfehler zu vermeiden. Mal nachgedacht?

Und warum er das einmal kann, das andere mal aber nicht, das hast Du so eingebaut. Wenn Du Dir bei jeder Anweisung etwas gedacht hast, solltest Du den Unterschied schnell finden. Aber Du erklärst uns ja nicht einmal, wieso es keine Xampp Pfade in der Installation gibt.


Aber den Unterschied habe ich nicht gefunden ;-), deswegen habe ich um Hilfe gebeten, Schlauer Bursche. Hätte ich es gefunden, hätte ich nicht gefragt, aber etwas ist mir nicht eingefallen, deswegen habe ich mich an Speziallisten gewendet.
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby pw44 » 17. July 2020 18:56

Na, schon gelöst. In ein anderen Forum war jemand sehr freundlich und hat den Typ gegeben, ganz zum gegenteil als hier.
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby Altrea » 17. July 2020 20:41

Schade dass du nun dasselbe hier unterstellte unsozial Verhalten an den Tag legst indem du andere Leute nicht an deiner Lösung teilhaben lässt.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10432
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache authentication failing

Postby pw44 » 17. July 2020 23:20

Na ja, aber ich habe keine Unterstützung erhalten nach die Verarschung. Viel Gluck. Dieser Gruppe steige ich aus.

[EDIT von Altrea: Beleidigung entfernt.]
pw44
 
Posts: 6
Joined: 10. July 2020 13:02
XAMPP version: 2.4
Operating System: linux

Re: apache authentication failing

Postby Altrea » 18. July 2020 13:05

Damit, dass du dieselbe Frage an unterschiedlichen Stellen stellst ohne alle darüber zu informieren wo alle Informationen zu dem Thema zu finden sind, nutzt du das System der kostenlosen Community Foren aus. Hier und in anderen Foren lesen und Antworten IT-Experten die teilweise ansonsten Stundensätze von 100€ und mehr in der Wirtschaft ansetzen. Selbst wenn du vielleicht nicht die Antworten erhalten hast, die du dir erhofft hast, so kann es sein, dass sich im Hintergrund immernoch jemand bemüht dein Problem zu lösen. Darüber hinaus bestrafst du mit deiner Geheimniskrämerei all die Hilfesuchenden, die vielleicht dasselbe oder ein Ähnliches Problem haben wie du und bei der Suche auf deine Beiträge stoßen.

Und das Internet vergisst nichts. Solltest du irgendwann nochmal ein Problem haben, welches du versuchst über kostenlose Experten zu lösen, könnte es passieren dass genau der Helfer der dir sofort helfen könnte dein unsoziales Verhalten durch schnelle Internetrecherche findet und sich dann entschließt dir nicht zu helfen. Und das alles, weil du dir durch ein einzelnes Forenmitglied auf den Schlipps getreten fühlst.
Noch dazu sind die Einwände von Nobbie ja nicht ohne Grund. Wenn du zum Beispiel von einer nicht XAMPP Umgebung sprechen würdest (und da deuten deine Pfade ja drauf hin) kann die Grundkonfiguration von Apache komplett anders aussehen und damit auch die Ursache woanders begründet sein.

Aber gut, für das Forum hier ist dieser Beitrag hier nur nützlich, wenn die Lösung auch hier steht. Deshalb:

Die Frage wurde an folgenden Stellen gestellt:

Die Lösung stammt aus dem unteren Link und wurde mit deepl.com ins Deutsche übersetzt:

vmmello wrote:In netdata wird die Authentifizierung auf /netdata/ (innerhalb <location /netdata/> ... </location>) angewendet, während in awstats die Authentifizierung nur auf die Datei awstats.pl (innerhalb <Files awstats.pl>) angewendet wird.

Vielleicht besteht die Lösung darin, die Zeilen <Files awstats.pl> und </Files> zu entfernen. Und damit gilt die Authentifizierung für das gesamte Verzeichnis, auf das /awstats/ zugreifen kann.


pw44 wrote:Die Absicht war, den Zugriff auf die Datei awstats.pl zu authentifizieren

Danke für den Tipp. Es ist so geblieben, und es hat funktioniert. Danke.
Code: Select all
# awstats

       Alias /awstatsclasses "/usr/share/awstats/lib/"
       Alias /awstats-icon/ "/usr/share/awstats/icon/"
       Alias /awstatscss "/usr/share/doc/awstats/examples/css"
       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
       ScriptAlias /awstats/ /usr/lib/cgi-bin/
       Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
       <location /awstats/>
             DirectoryIndex awstats.pl
             AuthUserFile /etc/apache2/.htpasswd
             AuthName "Awstats login"
             AuthType Basic
             Require valid-user
             Order deny,allow
             Allow from all
       </location>
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10432
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache authentication failing

Postby Nobbie » 18. July 2020 18:31

Es gibt nicht "die" Lösung, die Ursache, warum es im einen Fall klappt, im anderen nicht, sind die verschiedenen Zugrifssrechte. Bei dem oberen VirtualHost findet sich diese Konfiguration:

<Location />
<RequireAll>
Require all granted
Require not env BlockCountry
</RequireAll>
</Location>


Damit ist auf alle Dateien der Zugriff gestattet. Eine vergleichbare Klausel fehlt im anderen VirtualHost.
Nobbie
 
Posts: 11776
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 6 guests