Refresher

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Refresher

Postby CassiesOak » 10. May 2020 21:40

I've installed XAMPP on a USB drive and, after several attempts, it is working. It has been many years since I've used it and I am just having trouble getting started again. I want to load a current website (Joomla) from a backup as a test site but cannot remember how to do it once XAMPP is running. Can anyone help, please? Simple 1-2-3 instructions as I'm on technological overload. Thanks for any help, DJ
CassiesOak
 
Posts: 14
Joined: 09. July 2016 22:07
XAMPP version: 5.6.21
Operating System: Windows 10

Re: Refresher

Postby Altrea » 10. May 2020 21:46

What type of backup?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10248
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Refresher

Postby CassiesOak » 11. May 2020 21:47

I have backups made from the live site using Akeeba Backup which I keep on an external hard drive. I've tried a couple different methods to no avail so I know I'm doing something wrong. Most recently, mySQL keeps disconnecting as in below (most of which I don't understand, but it said if it keeps happening to copy and paste the whole thing on the forum). I'm willing to trash everything and start over. The goal is to get my live website onto a local server. Thanks for any help you can give, DJ
4:45:50 PM [main] Initializing Control Panel
4:45:50 PM [main] Windows Version: Home 64-bit
4:45:50 PM [main] XAMPP Version: 7.3.4
4:45:50 PM [main] Control Panel Version: 3.2.3 [ Compiled: Mar 7th 2019 ]
4:45:50 PM [main] Running with Administrator rights - good!
4:45:50 PM [main] XAMPP Installation Directory: "d:\xampp-portable-windows-x64-7.3.4-0-vc15\xampp\"
4:45:50 PM [main] Checking for prerequisites
4:45:50 PM [main] All prerequisites found
4:45:50 PM [main] Initializing Modules
4:45:50 PM [mysql] Problem detected!
4:45:50 PM [mysql] Port 3306 in use by "Unable to get info"!
4:45:50 PM [mysql] MySQL WILL NOT start without the configured ports free!
4:45:50 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
4:45:50 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
4:45:50 PM [main] The FileZilla module is disabled
4:45:50 PM [main] The Mercury module is disabled
4:45:50 PM [main] Enabling autostart for module "Apache"
4:45:50 PM [main] Enabling autostart for module "MySQL"
4:45:50 PM [main] Enabling autostart for module "Tomcat"
4:45:50 PM [main] Starting Check-Timer
4:45:50 PM [main] Control Panel Ready
4:45:51 PM [Apache] Autostart active: starting...
4:45:51 PM [Apache] Attempting to start Apache app...
4:45:51 PM [mysql] Autostart active: starting...
4:45:51 PM [mysql] Problem detected!
4:45:51 PM [mysql] Port 3306 in use by "Unable to get info"!
4:45:51 PM [mysql] MySQL WILL NOT start without the configured ports free!
4:45:51 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
4:45:51 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
4:45:51 PM [mysql] Attempting to start MySQL app...
4:45:51 PM [Tomcat] Autostart active: starting...
4:45:51 PM [Tomcat] Attempting to start Tomcat app...
4:45:52 PM [Apache] Status change detected: running
4:45:52 PM [mysql] Status change detected: running
4:45:57 PM [Tomcat] Status change detected: running
4:46:01 PM [mysql] Status change detected: stopped
4:46:01 PM [mysql] Error: MySQL shutdown unexpectedly.
4:46:01 PM [mysql] This may be due to a blocked port, missing dependencies,
4:46:01 PM [mysql] improper privileges, a crash, or a shutdown by another method.
4:46:01 PM [mysql] Press the Logs button to view error logs and check
4:46:01 PM [mysql] the Windows Event Viewer for more clues
4:46:01 PM [mysql] If you need more help, copy and post this
4:46:01 PM [mysql] entire log window on the forums
CassiesOak
 
Posts: 14
Joined: 09. July 2016 22:07
XAMPP version: 5.6.21
Operating System: Windows 10

Re: Refresher

Postby Altrea » 11. May 2020 22:55

Starting over is probably not an option here, because some process on your computer is listening on port 3306. You need to identify and solve this first.

XAMPP comes with a netstat tool you can open by clicking a button in your control panel. Search for the process listed with port 3306
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10248
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Refresher

Postby CassiesOak » 11. May 2020 23:44

I guess that needs to be fixed before going back to trying to get the live site on a localsite. It says that "mysqld.exe" is using port 3306 but I did not see a way to end it? Port: 3306; PID: 18320; Name: mysqld.exe I FOUND IT! I went to task manager, ended the service and now it appears to work! Thank you so much! Now, back to trying to get my live site on the localserver....
CassiesOak
 
Posts: 14
Joined: 09. July 2016 22:07
XAMPP version: 5.6.21
Operating System: Windows 10

Re: Refresher

Postby CassiesOak » 12. May 2020 00:22

I finally got the localhost up and running with a fresh Joomla install! Getting older and not continuing to do techy stuff daily sure makes it tough when you need to go back to something! Sure appreciate the help!
CassiesOak
 
Posts: 14
Joined: 09. July 2016 22:07
XAMPP version: 5.6.21
Operating System: Windows 10

Re: Refresher

Postby Altrea » 12. May 2020 05:05

You are welcome :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10248
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 110 guests