Semantic MediaWiki Pretty URIs RewriteRule does not seem to

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Semantic MediaWiki Pretty URIs RewriteRule does not seem to

Postby plegault » 25. March 2020 13:35

In the following link I followed the instruction. everything works other than the URIResolver RewriteRule.
https://www.semantic-mediawiki.org/wiki/Help:Pretty_URIs not working as described. RewriteRule ^/id/(.*) https://www.semantic-mediawiki.org/wiki/Special:URIResolver/$1 [L] does not seem to work.
[Tue Mar 24 14:45:32.146800 2020] [rewrite:trace2] [pid 9332:tid 1884] mod_rewrite.c(483): [client 172.16.3.183:59489] 172.16.3.183 - - [server.com/sid#242afbc87b8][rid#242b01f3da0/subreq] init rewrite engine with requested uri /error/contact.html.var, referer: https://server.com/id/Oracle_Database/TS-2DRoadmap
[Tue Mar 24 14:45:32.146800 2020] [rewrite:trace1] [pid 9332:tid 1884] mod_rewrite.c(483): [client 172.16.3.183:59489] 172.16.3.183 - - [server.com/sid#242afbc87b8][rid#242b01f3da0/subreq] pass through /error/contact.html.var, referer: https://server.com/id/Oracle_Database/TS-2DRoadmap

Thanks for the help
plegault
 
Posts: 2
Joined: 25. March 2020 13:11
Location: USA NJ
XAMPP version: 7.3.15
Operating System: Windows Server 2016

Re: Semantic MediaWiki Pretty URIs RewriteRule does not seem

Postby plegault » 26. March 2020 17:16

I found a work around.
RedirectMatch "^/id/(.*)" "https://server.com/wiki/Special:URIResolver/$1"
plegault
 
Posts: 2
Joined: 25. March 2020 13:11
Location: USA NJ
XAMPP version: 7.3.15
Operating System: Windows Server 2016


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests