Probleme mit dem ZipArchive Objekt in XAMPP-VM

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit dem ZipArchive Objekt in XAMPP-VM

Postby uhu » 04. March 2020 09:52

Ich möchte ein Problem melden mit XAMPP 7.4.3 in der VM auf MACOSX.
Ich habe für das Reproduzieren ein kleines Programm geschrieben:
Code: Select all
<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $basename = 'test.txt';
    $zip->addFromString($basename, 'file content goes here');

    $res = $zip->setEncryptionName($basename, ZipArchive::EM_AES_256   ,'passwOrd');
    if ($res === false) {
        throw new RuntimeException('Set encryption failed with Error');
    }
   
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Ich habe XAMPP-VM installiert, dort liefert die Methode setEncryptionName eine "0" zurück und das Skript liefert, wenn nicht der Fehler wie im Skript abgefangen wird, ein unverschlüsseltes Zip-Archiv.

Zum Test habe ich dann XAMPP nativ auf den Mac installiert, dort liefert die Funktion keinen "0"-Wert und das Archiv wird verschlüsselt abgelegt.
Mein Verdacht: In der VM ist eine fehlerhafte Bibliothek eingebunden.
Hat jemand eine Idee / Anleitung, wie man diesen Fehler schnell in der VM beheben kann?

Viele Grüße
UHU
uhu
 
Posts: 1
Joined: 04. March 2020 09:38
XAMPP version: 7.4.3
Operating System: OSX

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests