/usr/local/mysql doesn't exists

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

/usr/local/mysql doesn't exists

Postby mar846 » 08. February 2020 17:51

Help I just updated my XAMPP from 7.1.24 to 7.4.2. First i uninstall my XAMPP using uninstall.app and then i install my new XAMPP. Everything seems fine until I tried to open one of table from any database it said Tables doens't exists in engine. Then i tried to drop my database and it throw an error

#1558 - Column count of mysql.proc is wrong. Expected 21, found 20. Created with MariaDB 100108, now running 100411. Please use mysql_upgrade to fix this error

I tried to search mysql_upgrade peoples said type it on bash/terminal. But my terminal said mysql command not found. Some say i need to declare it first on ~/.bash_profile but i search my /usr/local/ directory mysql doesn't exists.

what should i do?
Posts: 1
Joined: 08. February 2020 17:42
XAMPP version: 7.4.2
Operating System: macOS Catalina 10.15.2

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 7 guests