xampp don't load oci8 on mac

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

xampp don't load oci8 on mac

Postby fnoceda83 » 04. February 2020 16:31

I have on my mac Sierra installed the xamp 7.1.1 (I installed this because on 7.4.X i don't have succesfully results when i run sudo /Applications/XAMPP/xamppfiles/lampp oci8)
Now on 7.1.1. when i run sudo /Applications/XAMPP/xamppfiles/lampp oci8 the result is succesfuly but the oci8 is not load when the server start
The errors i see are:

==> php_error_log <==
[04-Feb-2020 14:40:43 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so' - dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so, 9): image not found in Unknown on line 0

==> error_log <==
[Tue Feb 04 11:40:44.045765 2020] [mpm_prefork:notice] [pid 5107] AH00169: caught SIGTERM, shutting down

==> php_error_log <==
[04-Feb-2020 14:40:48 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so' - dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so, 9): image not found in Unknown on line 0

==> error_log <==
[Tue Feb 04 11:40:49.006020 2020] [ssl:warn] [pid 5285] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 04 11:40:49.006613 2020] [ssl:warn] [pid 5285] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Feb 04 11:40:50.002245 2020] [ssl:warn] [pid 5286] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 04 11:40:50.002575 2020] [ssl:warn] [pid 5286] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Feb 04 11:40:50.002834 2020] [lbmethod_heartbeat:notice] [pid 5286] AH02282: No slotmem from mod_heartmonitor
[Tue Feb 04 11:40:50.002884 2020] [auth_digest:notice] [pid 5286] AH01757: generating secret for digest authentication ...

==> php_error_log <==
[04-Feb-2020 14:40:50 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so' - dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20160303/oci8.so, 9): image not found in Unknown on line 0

==> error_log <==
[Tue Feb 04 11:40:50.018167 2020] [mpm_prefork:notice] [pid 5286] AH00163: Apache/2.4.25 (Unix) OpenSSL/1.0.2j PHP/7.1.1 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Tue Feb 04 11:40:50.018543 2020] [core:notice] [pid 5286] AH00094: Command line: '/Applications/XAMPP/xamppfiles/bin/httpd -E /Applications/XAMPP/xamppfiles/logs/error_log -D SSL -D PHP'


I see very tutorials on google, but not work for me.
Please help me!!
fnoceda83
 
Posts: 1
Joined: 04. February 2020 16:20
XAMPP version: 7.1.1
Operating System: MAC

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests