7.2.7 Symbol not found: _iconv\n

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

7.2.7 Symbol not found: _iconv\n

Postby robske_110 » 22. July 2018 15:12

After upgrading my XAMPP installation from 7.2.6 to 7.2.7, when I try to start apachectl I get the following error:
Code: Select all
httpd: Syntax error on line 522 of /Applications/XAMPP/xamppfiles/etc/httpd.conf: Syntax error on line 10 of /Applications/XAMPP/xamppfiles/etc/extra/httpd-xampp.conf: Cannot load modules/libphp7.so into server: dlopen(/Applications/XAMPP/xamppfiles/modules/libphp7.so, 10): Symbol not found: _iconv\n  Referenced from: /Applications/XAMPP/xamppfiles/lib/libintl.8.dylib\n  Expected in: /Applications/XAMPP/xamppfiles/lib/libiconv.2.dylib\n in /Applications/XAMPP/xamppfiles/lib/libintl.8.dylib

All files mentioned in the error message are existent.

My system is running 10.11.6 (15G22010) OSX El Capitan.

Note: I am not using the VM version.
robske_110
 
Posts: 6
Joined: 22. July 2018 15:07
XAMPP version: 7.2.7 (NON-VM)
Operating System: Mac OSX 11.6 (El Capitan)

Re: 7.2.7 Symbol not found: _iconv\n

Postby robske_110 » 22. July 2018 17:30

Downgrading to 7.2.6 fixed the error, but I‘d still like to have 7.2.7. Is the macos binary for 7.2.7 broken?
robske_110
 
Posts: 6
Joined: 22. July 2018 15:07
XAMPP version: 7.2.7 (NON-VM)
Operating System: Mac OSX 11.6 (El Capitan)

Re: 7.2.7 Symbol not found: _iconv\n

Postby robske_110 » 13. August 2018 15:47

This is still present in the 7.2.8 package. Still having to use 7.2.6. Can anyone help me out here?
robske_110
 
Posts: 6
Joined: 22. July 2018 15:07
XAMPP version: 7.2.7 (NON-VM)
Operating System: Mac OSX 11.6 (El Capitan)

Re: 7.2.7 Symbol not found: _iconv\n

Postby robske_110 » 13. August 2018 15:54

I fixed my issue by commenting out all lines in enviers and envvars-std. Why this didn't appear on 7.2.6 and before is something that remains unknown.
robske_110
 
Posts: 6
Joined: 22. July 2018 15:07
XAMPP version: 7.2.7 (NON-VM)
Operating System: Mac OSX 11.6 (El Capitan)

Re: 7.2.7 Symbol not found: _iconv\n

Postby amarilindra » 16. August 2018 14:58

robske_110 wrote:I fixed my issue by commenting out all lines in enviers and envvars-std. Why this didn't appear on 7.2.6 and before is something that remains unknown.


Where can I find these two files?
"enviers" and "envvars-std"
amarilindra
 
Posts: 1
Joined: 16. August 2018 14:56
XAMPP version: 7.2.8
Operating System: Mac Sierra

Re: 7.2.7 Symbol not found: _iconv\n

Postby robske_110 » 20. August 2018 07:59

In /xamppfiles/bin/envvars and /xamppfiles/bin/envvars-std. Comment out all lines in these files.
robske_110
 
Posts: 6
Joined: 22. July 2018 15:07
XAMPP version: 7.2.7 (NON-VM)
Operating System: Mac OSX 11.6 (El Capitan)

Re: 7.2.7 Symbol not found: _iconv\n

Postby shorng » 29. October 2018 17:06

I was able to fix the same error by removing the /xamppfiles/lib/ folder and run the XAMPP installer again. It's probably due to old lib files from previous version not being updated properly.
shorng
 
Posts: 1
Joined: 29. October 2018 17:03
XAMPP version: 7.2
Operating System: Mac


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 22 guests