Xampp 7.2.4 (Linux) PhpMyAdmin Export Problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Xampp 7.2.4 (Linux) PhpMyAdmin Export Problem

Postby 0x90kh4n » 05. May 2018 18:55

Hi, I'm using Xampp 7.2.4 on Linux. I'm having trouble exporting a database with phpmyadmin. Phpmyadmin's own demo page does not have this problem. I also tested this problem in Windows version of Xampp 7.2.4. I write down the details of the problem below. You can try.

== My sample table ==

CREATE TABLE `posts` (
`id` int(10) UNSIGNED NOT NULL,
`title` varchar(100) NOT NULL,
`description` text NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

After creating the table, I export it via phpMyAdmin.

== PhpMyAdmin Exported ==

CREATE TABLE `posts` (
`id` int(10)
) ;

Problem: If the id column in the posts table is not unsigned then it is exporting properly. As the column is unsigned, export is running corrupt. As I mentioned above, there is no problem with the same version of Windows. The problem exists only in the Linux version. I also experimented with the same version of phpMyAdmin's MariAdB test server, and it makes the exports work properly. The problem is entirely related to Linux xampp.

What can we do about it? I need to fix this problem because I export a lot of files with phpmyadmin. Thank you.
0x90kh4n
 
Posts: 1
Joined: 05. May 2018 18:42
XAMPP version: 7.4.0
Operating System: Linux

Re: Xampp 7.2.4 (Linux) PhpMyAdmin Export Problem

Postby fthpi » 09. September 2018 10:41

same problem exist on manjaro linux. Up :idea:
fthpi
 
Posts: 1
Joined: 09. September 2018 10:39
XAMPP version: 7.2.7-0
Operating System: Manjaro


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests