Unable to start in Windows 7 64-bit

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to start in Windows 7 64-bit

Postby harry007 » 28. October 2013 19:47

Hi,

I am not able to start Apache Web Server on my machine. Could someone please help.

Here is the log:

12:51:09 PM [main] Initializing Control Panel
12:51:09 PM [main] Windows Version: Windows 7 Enterprise SP1 64-bit
12:51:09 PM [main] XAMPP Version: 1.8.3
12:51:09 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
12:51:09 PM [main] You are not running with administrator rights! This will work for
12:51:09 PM [main] most application stuff but whenever you do something with services
12:51:09 PM [main] there will be a security dialogue or things will break! So think
12:51:09 PM [main] about running this application with administrator rights!
12:51:09 PM [main] XAMPP Installation Directory: "b:\xampp\xampp\"
12:51:09 PM [main] Checking for prerequisites
12:51:09 PM [main] All prerequisites found
12:51:09 PM [main] Initializing Modules
12:51:09 PM [main] Starting Check-Timer
12:51:09 PM [main] Control Panel Ready
12:51:18 PM [Apache] Attempting to start Apache app...
12:51:18 PM [Apache] Status change detected: running
12:51:19 PM [Apache] Status change detected: stopped
12:51:19 PM [Apache] Error: Apache shutdown unexpectedly.
12:51:19 PM [Apache] This may be due to a blocked port, missing dependencies,
12:51:19 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:51:19 PM [Apache] Press the Logs button to view error logs and check
12:51:19 PM [Apache] the Windows Event Viewer for more clues
12:51:19 PM [Apache] If you need more help, copy and post this
12:51:19 PM [Apache] entire log window on the forums

Thanks
Hari
harry007
 
Posts: 5
Joined: 28. October 2013 19:08
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-bit

Re: Unable to start in Windows 7 64-bit

Postby harry007 » 28. October 2013 20:51

Hi,

Wanted to add additional information.

I am not able to start Apache & MySQL. However I was able to start FileZilla, Mercury & Tomcat. Here is the full log:

3:51:22 PM [main] Initializing Control Panel
3:51:22 PM [main] Windows Version: Windows 7 Enterprise SP1 64-bit
3:51:22 PM [main] XAMPP Version: 1.8.3
3:51:22 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
3:51:22 PM [main] You are not running with administrator rights! This will work for
3:51:22 PM [main] most application stuff but whenever you do something with services
3:51:22 PM [main] there will be a security dialogue or things will break! So think
3:51:22 PM [main] about running this application with administrator rights!
3:51:22 PM [main] XAMPP Installation Directory: "b:\xampp\xampp\"
3:51:22 PM [main] Checking for prerequisites
3:51:22 PM [main] All prerequisites found
3:51:22 PM [main] Initializing Modules
3:51:22 PM [main] Starting Check-Timer
3:51:22 PM [main] Control Panel Ready
3:51:47 PM [Apache] Attempting to start Apache app...
3:51:47 PM [Apache] Status change detected: running
3:51:48 PM [Apache] Status change detected: stopped
3:51:48 PM [Apache] Error: Apache shutdown unexpectedly.
3:51:48 PM [Apache] This may be due to a blocked port, missing dependencies,
3:51:48 PM [Apache] improper privileges, a crash, or a shutdown by another method.
3:51:48 PM [Apache] Press the Logs button to view error logs and check
3:51:48 PM [Apache] the Windows Event Viewer for more clues
3:51:48 PM [Apache] If you need more help, copy and post this
3:51:48 PM [Apache] entire log window on the forums
3:51:50 PM [mysql] Attempting to start MySQL app...
3:51:50 PM [mysql] Status change detected: running
3:51:51 PM [mysql] Status change detected: stopped
3:51:51 PM [mysql] Error: MySQL shutdown unexpectedly.
3:51:51 PM [mysql] This may be due to a blocked port, missing dependencies,
3:51:51 PM [mysql] improper privileges, a crash, or a shutdown by another method.
3:51:51 PM [mysql] Press the Logs button to view error logs and check
3:51:51 PM [mysql] the Windows Event Viewer for more clues
3:51:51 PM [mysql] If you need more help, copy and post this
3:51:51 PM [mysql] entire log window on the forums
3:51:53 PM [filezilla] Attempting to start FileZilla app...
3:51:53 PM [filezilla] Status change detected: running
3:51:57 PM [mercury] Attempting to start Mercury app...
3:51:57 PM [mercury] Status change detected: running
3:52:02 PM [Tomcat] Attempting to start Tomcat app...
3:52:07 PM [Tomcat] Status change detected: running

Thanks
Hari
harry007
 
Posts: 5
Joined: 28. October 2013 19:08
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-bit

Re: Unable to start in Windows 7 64-bit

Postby Altrea » 28. October 2013 20:52

Hi,

starting \xampp\apache_start.bat gives what information?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6668
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Unable to start in Windows 7 64-bit

Postby harry007 » 28. October 2013 21:30

Hi Altrea,

Thanks for the quick response. I tried the batch file and got some path related errors. So I deleted the folder (b:\xampp\xampp) and extracted the contents to a new folder (b:\xampp).

This time, all the applications started except Mercury. Here is the contents of the log file:

4:25:10 PM [main] Initializing Control Panel
4:25:10 PM [main] Windows Version: Windows 7 Enterprise SP1 64-bit
4:25:10 PM [main] XAMPP Version: 1.8.3
4:25:10 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
4:25:10 PM [main] You are not running with administrator rights! This will work for
4:25:10 PM [main] most application stuff but whenever you do something with services
4:25:10 PM [main] there will be a security dialogue or things will break! So think
4:25:10 PM [main] about running this application with administrator rights!
4:25:10 PM [main] XAMPP Installation Directory: "b:\xampp\"
4:25:10 PM [main] Checking for prerequisites
4:25:10 PM [main] All prerequisites found
4:25:10 PM [main] Initializing Modules
4:25:10 PM [main] Starting Check-Timer
4:25:10 PM [main] Control Panel Ready
4:25:57 PM [Apache] Attempting to start Apache app...
4:25:58 PM [Apache] Status change detected: running
4:26:07 PM [mysql] Attempting to start MySQL app...
4:26:08 PM [mysql] Status change detected: running
4:26:21 PM [filezilla] Attempting to start FileZilla app...
4:26:21 PM [filezilla] Status change detected: running
4:26:56 PM [mercury] Attempting to start Mercury app...
4:26:57 PM [mercury] Status change detected: running
4:27:03 PM [mercury] Status change detected: stopped
4:27:03 PM [mercury] Error: Mercury shutdown unexpectedly.
4:27:03 PM [mercury] This may be due to a blocked port, missing dependencies,
4:27:03 PM [mercury] improper privileges, a crash, or a shutdown by another method.
4:27:03 PM [mercury] Press the Logs button to view error logs and check
4:27:03 PM [mercury] the Windows Event Viewer for more clues
4:27:03 PM [mercury] If you need more help, copy and post this
4:27:03 PM [mercury] entire log window on the forums
4:27:29 PM [Tomcat] Attempting to start Tomcat app...
4:27:34 PM [Tomcat] Status change detected: running

When I tried to get the logs for Mercury, the following was printed in the log file:

4:30:06 PM [main] Executing "b:\xampp\MercuryMail\LOGS"

However I noticed that the logs does not exist. Pls advise.

Regards
Hari
harry007
 
Posts: 5
Joined: 28. October 2013 19:08
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-bit

Re: Unable to start in Windows 7 64-bit

Postby Altrea » 28. October 2013 21:35

Do you really need Mercury?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6668
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Unable to start in Windows 7 64-bit

Postby harry007 » 28. October 2013 21:39

Not really. I was just trying to ensure the installation has been successful.

Thanks
Hari
harry007
 
Posts: 5
Joined: 28. October 2013 19:08
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-bit

Re: Unable to start in Windows 7 64-bit

Postby harry007 » 28. October 2013 21:45

I was able to test the localhost. Here is what I get from the Status link. It says SMTP is DEACTIVATED. Is it because of any configuration issue?

XAMPP Status
This page offers you one page to view all information about what's running and working, and what isn't working.


Component
Status
Hint
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service ACTIVATED
Tomcat Service ACTIVATED


Some changes to the configuration may sometimes cause false negatives. All reports viewed with SSL (https://localhost) do not function!
harry007
 
Posts: 5
Joined: 28. October 2013 19:08
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-bit

Re: Unable to start in Windows 7 64-bit

Postby Altrea » 28. October 2013 22:03

By default XAMPP is configured to use mailtodisk as mail function, so if you use the mail() function the contents will be saved as file for debug view.
So it's okay that Mercury isn't running and SMTP is deactivated because Mercury isn't running.

Not everything that is ever possible to be running needs to be running. Most applications just ever need Apache (with PHP) and MySQL.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6668
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests