First time XAMPPer. Problem with port 80 on windows 8

Problems with the Windows version of XAMPP, questions, comments, and anything related.

First time XAMPPer. Problem with port 80 on windows 8

Postby cyborglizard » 05. August 2013 18:03

Hello,
Just a newbie starting off with PHP and first time installing XAMPP. I get this error:

12:59:46 PM [Apache] Problem detected!
12:59:46 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
12:59:46 PM [Apache] Apache WILL NOT start without the configured ports free!
12:59:46 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:59:46 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

I changed the settings of my skype so it does not use port 80 and 443. But I still cant get apache to run.

I saw on the forums here you can change the registry or change the ports apache uses.

Is there a better way? I saw some people saying to check what is using port 80 and 443 on windows but I am not sure how to do that in windows 8.

thanks for the help!
cyborglizard
 
Posts: 1
Joined: 05. August 2013 18:00
XAMPP Version: 5.6.3
Operating System: windows 8

Re: First time XAMPPer. Problem with port 80 on windows 8

Postby hackattack142 » 05. August 2013 22:38

Hello,

Generally, finding the blocking application is the way to deal with this error. If, for some reason, you cannot find/change the blocking application then you can change the Apache and XAMPP CP configurations to use a different port. I would not suggest any registry changes.

PID 4 is the System process which typically means that a Windows Service is blocking that port. One common blocker is the World Wide Web Publishing service. It is a component of IIS and can be disabled if you are not using IIS (press the Services button in the XAMPP CP and see if it is in the list).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: First time XAMPPer. Problem with port 80 on windows 8

Postby beebox » 07. August 2013 18:37

You need to Stop all services, Close the XAMPP program and restart the program in Administrator Mode by Right Clicking the XAMPP icon and Run as Administrator.
beebox
 
Posts: 1
Joined: 07. August 2013 18:28
XAMPP Version: 1.8.3
Operating System: Win8

Re: First time XAMPPer. Problem with port 80 on windows 8

Postby Kobalt » 02. September 2013 15:01

cyborglizard wrote:I changed the settings of my skype so it does not use port 80 and 443. But I still cant get apache to run.

I saw on the forums here you can change the registry or change the ports apache uses.

Is there a better way? I saw some people saying to check what is using port 80 and 443 on windows but I am not sure how to do that in windows 8.

Hi cyborglizard,
I have solved this problem for me by disabling the service World Wide Web Publishing (http://www.blackviper.com/windows-services/world-wide-web-publishing-service/).
best regards
kobalt
Kobalt
 
Posts: 1
Joined: 02. September 2013 14:44
XAMPP Version: 1.8.3-2
Operating System: Win 7, Win 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests