Apache won't start for xampp-1.7.3 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start for xampp-1.7.3 [SOLVED]

Postby tama_198 » 23. February 2012 07:01

Hi there,

I'm sure this post is quite common and I apologize if this is in the wrong section.

I am running Windows 7 home premium, 64 bit OS and trying to run the Apache server from XAMPP 1.7.3. For some reason the Apache won't start, or if it does it will shut off immediately a few seconds later. The other elements of xampp seem to work just fine except for Apache.

Also to narrow down any possible errors, skype is not running, and have changed the port settings on that so it will not interfere with port 80.

Some concerns I have are: Am I running the appropriate version (xampp1.7.3) for my windows 7 64 bit OS? Is there any special steps I need to take in the installation process of xampp1.7.3 for it to work properly on my system? And lastly of course, why won't it work!

Thank you for your comments and helping me resolve this.
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby JonB » 23. February 2012 15:22

You should look in the Apache error log

/xampp/apache/logs/error_log.txt (as I recall)

Versions 1.7.3, 1.7.4, and 1.7.7 should all work on Windows 7 64 bit.
In some cases, you may have to install the MS Visual C 2008 libraries (but not for 1.7.3)

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 23. February 2012 20:24

Thank you JonB.

The Apache error log file has this same repeated error through out the file:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Would this be the source for Apache not running? Any Suggestions on how to fix it?

Thanks
-tama_198-
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby JonB » 23. February 2012 20:41

OK - see those error logs ARE useful. Well , sure it would keep it from working.

Please check your Windows Hosts file -

http://www.sepago.de/helge/2009/06/04/w ... ndows-x64/

use the editing instructions on that page, and add this line 'for starters', if it is not already present:

127.0.0.1 localhost

reboot your machine (just for grins) and try starting XAMPP. Be sure to run the Control Panel as Admin.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 23. February 2012 21:03

The line: 127.0.0.1 localhost was already present. I rebooted my machine, and ran the program as Administrator all to no avail.

I've been researching various solutions such as:

checking programs listening to port 80 through 'netstat -ao' and uninstalling IIS (after I had installed it following some other advice). But I'm not sure these solutions are corresponding to my error logs.

Thank you for you responses JonB, any other suggestions you may have for my problem?

-tama_198-
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby JonB » 23. February 2012 21:21

your error log is saying unambiguously that it can't locate a free socket to bind Apache to.

An attempt was made to access a socket in a way forbidden by its access permissions

It could be that you don't have a firewall exception for Apache. Are you by any chance running Zone Alarm or Comodo?

http://msdn.microsoft.com/en-us/library ... 68(v=vs.85).aspx

for info : what does your Listen Directive currently say???

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start for xampp-1.7.3

Postby Altrea » 23. February 2012 21:25

In most cases this error is a security software issue.

Please disable your antivirus and firewall software temporary (don't be connected to the internet is recommend at this time) and try to start Apache again.
If this is successfull you have to configire your security software to allow Apache to bind ports/sockets.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6617
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start for xampp-1.7.3

Postby hackattack142 » 23. February 2012 23:14

To me, that error is suggesting your user does not have the proper permissions. You could try right-clicking the control panel and do "Run as Administrator" or make sure you are signed into an account with Administrator privileges.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 24. February 2012 02:23

The administrator I was not doing, however after re-installing xampp as administrator and running the control panel as administrator, there is still no change.

All programs are closed (theoretically port 80 is open and unused) that could run on 80, and firewall is disabled. starting to think it won't run at all on my system.

Thank you all for your inputs

-tama_198-
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 24. February 2012 05:58

This information may be helpful too:
in the xampp control panel, checking the ports, port 80 does not say "free", rather it says "Process: System"

does this mean another program or service has priority over apache? and what are the steps to making port 80 free?

-tama_198-
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby hackattack142 » 24. February 2012 06:09

Yes, it means something is blocking port 80. Typically in Windows 7, it seems to be the World Wide Publishing service. If you do not use IIS, you can safely shutdown and disable this service if it exists (Start > Run > services.msc).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 24. February 2012 18:28

I had installed IIS, then uninstalled it after realizing it was not needed. I am skeptical however of its uninstall because when i go to they address 127.0.0.1, the IIS home page still shows up. There is also no record of IIS installed on my computer. Is this due to the WWWroot file still being there?

cmd > netstat -aon also told me, 0.0.0.0:80 is being used by a process with a PID(4). If this is just a "system" process, would it be fatal to end the process in the task manager if it is visible?
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit

Re: Apache won't start for xampp-1.7.3

Postby tama_198 » 24. February 2012 19:08

Thank you all for your input, and helping me with this.

doing some research led me to this solution:
http://www.lukebrowning.com/blog/nt-kernel-system-using-port-80/

this was exactly my problem. Web development agent service was running on port 80 and shutting it off completely freed up port 80 for apache to run successfully.

Again thank you, and hopefully this thread can be of some use to others as well

-tama_198-
tama_198
 
Posts: 7
Joined: 23. February 2012 06:49
XAMPP Version: 1.8.3-2
Operating System: Windows 7 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests