php_snmp.dll in Vers. 1.7.7 geht nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php_snmp.dll in Vers. 1.7.7 geht nicht

Postby hawkmaster » 04. January 2012 17:00

Hallo,
habe heute versucht den aktuellen XAMPP 1.7.7 mit der PHP extension php_snmp.dll zum laufen zu bringen.
Sobald ich diese DLL in der php.ini aktiviere, stürzt der APache ab, bzw. lässt sich garnicht starten.

ausprobiert unter verschiedenen Win 7 OS

Hat jemand ähnliche erfahrung gemacht oder weiss jemand woran das liegen kann?

Gruss
hawk
hawkmaster
 
Posts: 94
Joined: 22. January 2004 12:33
Location: Stuttgart

Re: php_snmp.dll in Vers. 1.7.7 geht nicht

Postby Altrea » 04. January 2012 18:43

Hallo hawkmaster,

leider muss ich dir mitteilen, dass die snmp Bibliothek, die mit der derzeitigen XAMPP Version ausgeliefert wird, sehr wahrscheinlich nicht korrekt kompiliert worden ist. Statt der thread-safe Version wurde wohl fälschlicherweise die non-thread-safe Variante verwendet. Dies ist bereits bei den Quellen von Apachelounge so (Der Apache der aktuellen XAMPP Version basiert darauf).
Vergleiche dazu diesen Thread hier: http://www.apachelounge.com/viewtopic.php?t=4038

Leider gibt es keine einfache Lösung dafür. Du kannst PHP wie im Thread beschrieben über CGI verwenden statt als Apachemodul. Eine Erklärung wie man dies mit XAMPP machen kann, ist zum Beispiel hier zu finden: http://phpforum.de/forum/showthread.php?t=228309

Die andere Alternative wäre, eine ältere XAMPP Version einzusetzen. Ältere XAMPP Versionen findest du auf Sourceforge.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6539
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: php_snmp.dll in Vers. 1.7.7 geht nicht

Postby hawkmaster » 05. January 2012 08:20

Hallo Altrea,

vielen Dank für deine Hilfe. Das ist doch wenigstens mal eine Aussage, auch wenn es schade ist das ich nicht updaten kann.
Ich hatte nämlich gestern fast den ganzen Tag nach der Ursache geforscht.
Ich habe allerdings deswegen gestern die Version 1.7.5 und auch Version 1.7.4 (vc6) ausprobiert und bei allen trat das gleiche Problem mit der
php_snmp.dll auf.
Nun dann bleibe ich wohl erst mal bei meiner Version 1.7.3. Bei der geht es mit dem SNMP

vielen Dank
Gruss
hawk
hawkmaster
 
Posts: 94
Joined: 22. January 2004 12:33
Location: Stuttgart

Re: php_snmp.dll in Vers. 1.7.7 geht nicht

Postby Altrea » 05. January 2012 18:20

Hallo hawkmaster,

hawkmaster wrote:Ich habe allerdings deswegen gestern die Version 1.7.5 und auch Version 1.7.4 (vc6) ausprobiert und bei allen trat das gleiche Problem mit der
php_snmp.dll auf.

Das kann ich nicht bestätigen, denn die Auswirkungen und Ursachen sind verschieden. Bei der XAMPP 1.7.4 wird die php_snmp.dll garnicht erst mitgeliefert. Der Apache hängt sich auchnicht komplett weg, sondern meckert nur über die fehlende Bibliothek.

hawkmaster wrote:Nun dann bleibe ich wohl erst mal bei meiner Version 1.7.3. Bei der geht es mit dem SNMP

Das wäre auch mein Rat gewesen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6539
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests