[gelöst]Kann Apache nicht starten (1.7.7)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst]Kann Apache nicht starten (1.7.7)

Postby coboly » 31. December 2011 15:56

Hallo,

nach Problemen mit einem Virus, habe ich xampp 1.7.7. auf Win XP neu eingespielt.
Wenn ich xampp starte, erscheint das Control Panel und Mysql und Filezilla lassen sich starten,
aber nicht Apache. Manchmal leuchtet für 1 bis 2 Sekunden die grüne Schrift 'running' auf, verschwindet
aber dann wieder. Im error.log finde ich dann folgenden Eintrag:

[Sat Dec 31 15:38:16 2011] [notice] Digest: generating secret for digest authentication ...
[Sat Dec 31 15:38:16 2011] [notice] Digest: done
[Sat Dec 31 15:38:18 2011] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Dec 31 15:38:18 2011] [notice] Server built: Sep 10 2011 11:34:11
[Sat Dec 31 15:38:18 2011] [notice] Parent: Created child process 3020
[Sat Dec 31 15:38:19 2011] [notice] Digest: generating secret for digest authentication ...
[Sat Dec 31 15:38:19 2011] [notice] Digest: done
[Sat Dec 31 15:38:21 2011] [notice] Child 3020: Child process is running
[Sat Dec 31 15:38:21 2011] [crit] (OS 10022)Ein ungültiges Argument wurde angegeben. : Child 3020: setup_inherited_listeners(), WSASocket failed to open the inherited socket.
[Sat Dec 31 15:38:21 2011] [crit] Parent: child process exited with status 3 -- Aborting.

Kann mir jemand einen Tipp geben, was sich hinter dieser Nachricht verbirgt?

Gruß Bernd
coboly
 
Posts: 4
Joined: 04. October 2010 10:56

Re: Kann Apache nicht starten (1.7.7)

Postby Altrea » 31. December 2011 19:20

Hallo Bernd,

Zuerst einmal möchte ich dich bitten, deine Betriebssystemversion und eingesetzte XAMPP Version in deinem Profileinstellungen zu ergänzen. Dein Fehlerbild kann durchaus auch mit deinem Service-Pack Level zu tun haben. Am besten dieses gleich mit ins Profil schreiben.

coboly wrote:[Sat Dec 31 15:38:21 2011] [crit] (OS 10022)Ein ungültiges Argument wurde angegeben. : Child 3020: setup_inherited_listeners(), WSASocket failed to open the inherited socket.
[Sat Dec 31 15:38:21 2011] [crit] Parent: child process exited with status 3 -- Aborting.

Zu diesem Fehler konnte ich ein paar mögliche Lösungsvorschläge finden. DIe solltest du eine nach der anderen ausprobieren:
- Bring deinen Rechner auf den aktuellen Patch Level stand, falls nochnicht geschehen
- Deaktiviere vorübergehend Firewalls, Antiviren-Programme und sonstige Schutzsoftware (dafür am besten solange die Internet Leitung kappen, damit du auf der ganz sicheren Seite bist)
- \xampp\apache\conf\extra\httpd-mpm.conf ~Zeile 110 ( #Win32DisableAcceptEx ) aktivieren, indem du das # am Anfang entfernst, die Datei speicherst und Apache neustartest.
- Netzwerkverbindungen -> Eigenschaften des Netzwerkadapters -> Reiter Allgemein -> Knopf "Erweitert" -> Reiter "WINS" -> Eigenschaft "LMHOST-Abfrage aktivieren" deaktivieren, indem du das Häkchen rausnimmst und alle Fenster mit OK bestätigst.
- Microsofts Anleitung zum Bestimmen und Reparieren einer Winsock2-Beschädigung durcharbeiten.
- diesen Apache Bug-Report nach weiteren Lösungsansätzen durchlesen

Zuletzt noch zwei Radikallösungen:
- XAMPP komplett deinstallieren und neuinstallieren
- Betriebssystem komplett neuinstallieren.

Generell sind weitere Probleme nicht auszuschließen. Ich wünsche dir viel Erfolg.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6610
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: [gelöst] Kann Apache nicht starten (1.7.7)

Postby coboly » 04. January 2012 18:43

Hallo Altera,

danke für die Tipps.
Der Hinweis:
Bestimmen und Reparieren einer Winsock2-Beschädigung

hat das Problem gelöst.

Gruß Bernd
coboly
 
Posts: 4
Joined: 04. October 2010 10:56

Re: [gelöst] Kann Apache nicht starten (1.7.7)

Postby Altrea » 04. January 2012 18:48

Hallo Bernd,

vielen Dank für die Rückmeldung. Freut mich, dass dein Problem gelöst werden konnte :D
Dann kann ich den Beitrag jetzt als gelöst markieren.

coboly wrote:Hallo Altera,

Wer ist "Altera"? :shock:

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6610
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests