How do i install php 5.2.17 on xampp install with php 5.2.4?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How do i install php 5.2.17 on xampp install with php 5.2.4?

Postby em3g » 11. March 2011 13:17

I was using xampp with php 5.3.1 or something then I downgraded to xampp with php v5.2.4 because most of my code was working better that way (old joomla - one that was happy with 5.2.x).
I then noticed that my host is using php 5.2.17, when i uploaded a site that i had developed earlier with php version 5.3.1. It was having problems that it didn't have when i was using php 5.3.1. My problem is that none of the XAMPP releases have php 5.2.17.

I know the site works well with 5.3.1 but i would like to try it on 5.2.17 and work from there since that is my host's version.
My mission is on how do i install a different ver of php like 5.2.17 (that i downloaded from php.net) on a xampp installation with php 5.2.4 installation?

This is what i did: I backed up my xampp and then extracted the php 5.2.17 package onto my php 5.2.4 folder in xampp\php, then copied the lines that were configured by xampp from php.ini (both in xampp\apache\bin\php.ini and xampp\php\php.ini) to new php.ini-dist and renamed to php.ini. Problem is xampp kept on reporting that i was running ver5.2.4 and errors were still there and even reported some dll issues. (Which I think was a result of nothing happened issue to my gain issue).

Is it possible to do what i want to do or there are tonnes of configurations that need to be done?
em3g
 
Posts: 4
Joined: 11. March 2011 11:30

Re: How do i install php 5.2.17 on xampp install with php 5.

Postby Altrea » 11. March 2011 14:44

You can't upgrade/downgrade any of the core components of xampp.
The components are compiled and configured for just this single combination.

btw: The differences between PHP 5.2.9 (XAMPP 1.7.1) and the current PHP version is very small in respect of the range of functions (sure there are many bugfixes since PHP 5.2.9).
You can try this version with XAMPP first.

If that won't work, then maybe your host has a different configuration in some cases (error reporting, etc.). You can change the XAMPP php configuration too.
Maybe your scripts will work with that. Too bad you don't tell us anything about your error messages.

The other solution is to install Apache, MySQL and PHP as single components.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6818
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: How do i install php 5.2.17 on xampp install with php 5.

Postby em3g » 11. March 2011 16:54

Dude thanks, you have cleared the cob-webs...
Thing is I am trying to avoid working on something that will not work on my host if uploaded....
eeeesh.... saka tight.
em3g
 
Posts: 4
Joined: 11. March 2011 11:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests