Apache not running

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache not running

Postby anirbang11 » 06. April 2010 07:39

Hi everybody,
This is my first post in this forum and I am sure I will get the answer. Thanks in advance.

I installed Xampp 1.7.2 for windows in my machine. And the Installation process was done without error or warning.
But when I want to run apache from control panel, it is not running, no error message is giving.
But Mysql and others are running well.

please give me a solution how to overcome this problem.
anirbang11
 
Posts: 1
Joined: 06. April 2010 07:23

Re: Apache not running

Postby Altrea » 06. April 2010 10:31

anirbang11 wrote:But when I want to run apache from control panel, it is not running, no error message is giving.

Please take a look in the Apache error.log file. Error messages will be logged there.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache not running

Postby Narrowboyy » 07. April 2010 00:30

Look in \xampp\apache\logs\error.log file for clues why Apache can't start.

An advanced forum search in XAMPP for Windows using apache can't start as the keywords may produce some useful results.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Apache not running

Postby benjamin_ » 07. April 2010 17:31

I get the Very same thing, So i check my Error logs, and found this:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down


So i then ran a port check, and that came back with this:


Apache <HTTP> 80 Process: System


This is where i am Stuck, I am running a Windows 7 Home premium System, I think there is a Windows connector running somewhere, but i know not what its called or what port its running on.

Any tips? :)
benjamin_
 
Posts: 1
Joined: 07. April 2010 17:26

Re: Apache not running

Postby Narrowboyy » 08. April 2010 00:35

"System" may mean that World Wide Publishing service is running and would need to be disabled if you are running XAMPP servers.

Click on the SCM (Service Control Manager) button in your XAMPP Control Panel and look for the
World Wide Publishing service or www publishing service.
Right click and select Properties and first Stop the service then select Disable.

Not sure if you need to restart Windows but it won't hurt to do that.

Then do a Port Check again and see if all is now Free.

If so then you should now be able to move forward with XAMPP.

I don't have W7 so please post back if this worked for you or not.
Thanks.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Apache not running

Postby kenneths » 08. April 2010 00:36

Do you by any chance have skype installed? :)
If so check the settings, there is a chechbox (was enabled with me) that lets skype use port 80 and another one to accept calls.
Once I disabled this it started for me.
kenneths
 
Posts: 4
Joined: 08. April 2010 00:30

Re: Apache not running

Postby Tom0 » 08. April 2010 10:03

@Narrowboyy: Worked perfectly thanks a million.

Im running Windows 7 Ultimate, yesterday I installed .NET 3.5.1 and after a few hours apache wouldnt start. I dont know if its related but its the only thing other than editing php files I did all day. Anyway stopping the publishing service worked a treat. Thanks.
Tom0
 
Posts: 1
Joined: 08. April 2010 09:59

Re: Apache not running

Postby Daanne » 08. April 2010 18:44

Hello!

I might have the same problem since my Apache wont run because the port 80 is busy.

Im using Xampp 1.7.0 and I've tried your example over Narrowboyy but I didnt found any publish service.

Im clicking on the SCM and it should come up a list?

/Danne
Daanne
 
Posts: 1
Joined: 08. April 2010 18:40

Re: Apache not running

Postby Narrowboyy » 09. April 2010 00:50

Daanne wrote:I might have the same problem since my Apache wont run because the port 80 is busy.
Please read the \xampp\apache\logs\error.log file for clues if Apache can't start.

Run \xampp\portcheck.exe and see what is using the ports - they should all be 'Free' if you have not started any XAMPP components.

To be an Administrator of a web server (XAMPP) you need to be logged into your Windows as an Administrator.

What Windows are you running?

Daanne wrote:Im clicking on the SCM and it should come up a list?
Yes, this SCM will give you a list of all Windows Apps. installed as a service - you need to be logged into your Windows as an Administrator to manipulate Windows Services.

Depending on what Windows OS you are using the www publishing service may have a different name, in some it is IIS or inetsvr and has to be disabled in other locations.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Apache not running

Postby bobatron83 » 09. April 2010 20:33

Hello

Think I am having a similar problem as well. I'm using XP

Apache would not start from the control panel and after checking the error log I found

"(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs"

After checking my ports I founf that a prgram called kroniki (used for BBC Iplayer and Sky Player I believe) was using port 80.

So I went to the httpd CONF file (located xampp/apache/conf)

and changed

#Listen 0.0.0.0:80
#Listen [::]:80
Listen 80

to

#Listen 0.0.0.0:85
#Listen [::]:85
Listen 85


Apache seems to be running now but when I go to http://localhost/ nothing is happening.

I'm very new to this so will keep trying but if anyone has any advice it would be very much appreciated.
bobatron83
 
Posts: 2
Joined: 09. April 2010 20:06

Re: Apache not running

Postby WilliL » 09. April 2010 21:06

baobtron83,
try http://localhost:85/
if I where you, I would try to change the port of kronikifor
port 80 is usually used for http and I would give it Apache.
Willi
WilliL
 
Posts: 619
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: Apache not running

Postby bobatron83 » 10. April 2010 01:11

WilliL wrote:baobtron83,
try http://localhost:85/
if I where you, I would try to change the port of kronikifor
port 80 is usually used for http and I would give it Apache.


Cheers and apologies for the late thanks. That is working now, but I will heed your advice and change the K port after the wekends sport.

Thanks again
bobatron83
 
Posts: 2
Joined: 09. April 2010 20:06

Re: Apache not running

Postby HugoFox » 12. June 2010 18:16

look out for kservice. That uses port 80. Also its using your bandwidth to send out channel 4's tv programs which you probably dont want either.
Sorry if someone already said this...
HugoFox
 
Posts: 1
Joined: 12. June 2010 18:12

Re: Apache not running

Postby stardog » 14. June 2010 01:20

I too am having a similar problem. A few weeks ago, I tried just installing the regular Apache server, and it worked fine. But I messed something up when I was configuring it, so I decided to uninstall and re-install it. From then on, it wouldn't work, giving me the following error:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

I tried the uninstall/reinstall cycle again, and even went through my Windows registry to get rid of any references to Apache, but it didn't help.

I installed XAMPP recently and got the same error, so I ran the port check. It showed all ports--INCLUDING PORT 80--to be free. Yet I still get the error. And yet MySQL works fine.

Incidentally, I had left Apache on my machine before, and once when I rebooted it actually ran fine. I though maybe somehow the problem was no longer there, so I uninstalled it and installed XAMPP, but this error popped up. I'm at a complete loss here, so any help would be greatly appreciated.
stardog
 
Posts: 5
Joined: 14. June 2010 01:10
Location: Ibaraki, Japan

Re: Apache not running

Postby JonB » 14. June 2010 01:50

Take a look at this, it may provide your answer.

viewtopic.php?f=16&t=40717&p=161042#p161042

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests