Xampp 1.0.1 Listen to multiple ports

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Xampp 1.0.1 Listen to multiple ports

Postby castles » 23. April 2009 02:57

I have been happily using the previous version of Xampp listening on multiple ports.. in my httpd.conf file it looks like this:

Listen 80
Listen 81
Listen 82 etc..

but with the new version Apache won't start when I use more than one port.

The error in the log file is: httpd: Could not open configuration file /Applications/XAMPP/xamppfiles/etc/httpd.conf: Too many levels of symbolic links

Is there something I'm doing wrong?

Thanks in advance.
castles
 
Posts: 4
Joined: 23. April 2009 02:52

Re: Xampp 1.0.1 Listen to multiple ports

Postby MegaChriz » 02. May 2009 15:08

I also have this problem. But no solution yet.

This is also an error I get:
/Applications/XAMPP/xamppfiles/bin/apachectl: line 70: ulimit: open files: cannot modify limit: Invalid argument
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
XAMPP Version: 1.8.3-3
Operating System: Mac OS X

Re: Xampp 1.0.1 Listen to multiple ports

Postby castles » 07. May 2009 03:19

Bump, anyone?
castles
 
Posts: 4
Joined: 23. April 2009 02:52


Re: Xampp 1.0.1 Listen to multiple ports

Postby MegaChriz » 08. May 2009 14:38

Hey, XAMPP has a bug tracker!
http://bugs.xampp.org/

It seems that the problem with multiple ports doesn't have something to do with the ulimit-bug.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
XAMPP Version: 1.8.3-3
Operating System: Mac OS X

Re: Xampp 1.0.1 Listen to multiple ports

Postby castles » 19. June 2009 02:05

http://bugs.xampp.org/view.php?id=110
looks like its a confirmed bug... no work around yet.. anyone have a clue?
castles
 
Posts: 4
Joined: 23. April 2009 02:52

Re: Xampp 1.0.1 Listen to multiple ports

Postby MegaChriz » 22. June 2009 11:12

On a PPC-Mac adding "AcceptMutex flock" to httpd.conf worked for me. I wasn't able yet to test this on an Intel-Mac.

On the PPC-Mac the virtual hosts (still) gave some problems. I had to add
Code: Select all
   <Directory />
      Options Indexes FollowSymLinks ExecCGI Includes
      AllowOverride All
      Order allow,deny
      Allow from all
   </Directory>
for each virtual host. The virtual hosts didn't took over these configuration-lines from httpd.conf.
This wasn't the case in XAMPP for Mac 0.7.4 (and before). In these versions the virtual hosts did took over the configuration from httpd.conf.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
XAMPP Version: 1.8.3-3
Operating System: Mac OS X

Re: Xampp 1.0.1 Listen to multiple ports

Postby castles » 22. June 2009 13:59

Fantastic, I can confirm that this solution works on my Intel Mac. Thanks heaps MegaChriz
castles
 
Posts: 4
Joined: 23. April 2009 02:52

Re: Xampp 1.0.1 Listen to multiple ports

Postby brwalias » 30. December 2009 19:28

MegaChriz wrote:On a PPC-Mac adding "AcceptMutex flock" to httpd.conf worked for me. I wasn't able yet to test this on an Intel-Mac.

On the PPC-Mac the virtual hosts (still) gave some problems. I had to add
Code: Select all
   <Directory />
      Options Indexes FollowSymLinks ExecCGI Includes
      AllowOverride All
      Order allow,deny
      Allow from all
   </Directory>
for each virtual host. The virtual hosts didn't took over these configuration-lines from httpd.conf.
This wasn't the case in XAMPP for Mac 0.7.4 (and before). In these versions the virtual hosts did took over the configuration from httpd.conf.


Sweet, using "AcceptMutex flock" works for me on an intel mac. very nice fix!
brwalias
 
Posts: 1
Joined: 30. December 2009 19:25

Re: Xampp 1.0.1 Listen to multiple ports

Postby h2mao » 29. September 2010 03:16

Lovely!!

Paste my steps here - hopefully it'll be simple to someone new to this:
1. Adding "AcceptMutex flock" to httpd.conf
2. Remove "#" in front of httpd-vhost.conf in httpd.conf - Load httpd-vhosts.conf
# Virtual hosts
Include /Applications/XAMPP/etc/extra/httpd-vhosts.conf

3. Adding "Listen 9001" to http-vhosts.conf - you can change to the port number you like, higher than 1024.
4. Adding "<VirtualHost *:9001>" to http-vhosts.conf
<VirtualHost *:9001>
ServerAdmin postmaster@dummy-host2.localhost
DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs/tcc-clients/www.thecreativecompany.com.au/"
#ServerName http://www.thecreativecompany.com.au
#ServerAlias http://www.thecreativecompany.com.au
#ErrorLog "logs/dummy-host2.localhost-error.log"
#CustomLog "logs/dummy-host2.localhost-access.log" combined
</VirtualHost>



It works for MacOSXServer + XAMPP for Mac OS X 1.7.3.
h2mao
 
Posts: 1
Joined: 29. September 2010 03:09

Re: Xampp 1.0.1 Listen to multiple ports

Postby tapsytapsy » 25. October 2010 11:31

Thanks h2mao, your solution works perfectly for me!
tapsytapsy
 
Posts: 1
Joined: 25. October 2010 11:27


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests