Mysql Security

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Mysql Security

Postby Abycats312 » 30. March 2009 00:17

I followed all your instructions and when I try to delete the XAMPP folder, I get a window saying "Destination Folder Access Denied You need permission to perform this action." I double clicked on XAMPP folder and scrolled down to the Uninstall folder. For the record, I did not click on it. But there is a red circle with a slash across it on the lower right corner of the orange icon. So...now what?

By the way, I originally used the installer link on the Apache Friends site. I didn't run setup_xampp.bat file. I tried to now, before going through your uninstall instructions, and I got a message something like "There's nothing to do!" And, from what I understood when I began this whole process, using the installer link was the easy way. Plus I don't have any software for unzipping files, not sure if I would need it if I don't use the installer? Assuming I get the uninstall taken care of, can I just try the installer again? If not, what method do you suggest that won't lose me?

Hope I'm making a little sense! I really appreciate all your time,

Cynthia
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 30. March 2009 02:25

You are sure you are logged into Vista as an administrator?

Reboot your PC and make sure you log in as an administrator and see if you can delete the xampp folder - let me know before moving on to the reinstall if the folder has gone.

Is there not an uninstall file that is part of XAMPP when you use the installer version?
(I only use the EXE (7zip) version as I personally don't like installers).

Make sure your virus scanner is not blocking the delete by temporarily disabling it, then try and delete again.

You may have a file that is still in use in the folder which will prevent the folder from being deleted.
Also check the permissions set for the folder by right clicking on the folder Properties>Security edit the permission to give you the admin full rights.

Here is a link that has some fixes for this deleting issue:
http://forums.techguy.org/windows-vista ... d-you.html

Here is a link to the Secret Super Administrator setup (very easy):
http://www.winvistaclub.com/t12.html



If you use the EXE (7zip) version it is self extracting and no need for zip software and in my opinion is much more reliable and just as easy if not more so than the installer version.

Download and extract to the C:\ drive and it will put all the files in C:\xampp (after your old one has been deleted).

Then run setup_xampp.bat file to set all the paths correctly.

Next open the XCP - xampp\xampp-control.exe - and start Apache and MySQL.

Then go to http://localhost/ and select you language and you should be taken to the Welcome Page.

If all is well you should be able to go forward.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 30. March 2009 03:12

OK, uninstall complete. Yes, I had to use the uninstall folder that came with the installer. I hadn't wanted to try that before checking with you. So, I'm going to reboot, take a deep breath, and try the 7zip as per your direction. I will let you know....

Cynthia

And thanks for the Vista links.
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Abycats312 » 30. March 2009 23:50

I've followed your instructions and the download went seemingly smooth, yet the same problems persist. I've searched for answers in documentation and FAQ's, but coming up short.

First, when I type 127.0.0.1 or 127.0.0.1/security into the browser, I still get "Request Error" as I detailed earlier. Using localhost, I still only get the table listing the security openings, but nothing more on the security page. I am supposed to see more, right? (I had to change Allow from localhost to Allow from 127.0.0.1 to even get this far.)

Second, is there a step by step instruction manual anywhere that will walk me through setting up the security? (If the above issued ever get resolved.) After that, I can move on to the Joomla! tutorial--they cover setting up the database.

Yes, I am logged on as administrator, UAC is off.
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 00:00

Cynthia, you are not having much luck with XAMPP, but we will win this battle.

Tell me what you see when you go to these:
http://localhost/
http://127.0.0.1/
http://localhost/xampp

If you have error message please try and give me back the exact messages.


Go to http://localhost/xampp/phpinfo.php and look for this line and tell me what it says please:
Loaded Configuration File
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 00:32

Izzy wrote:you are not having much luck with XAMPP, but we will win this battle.


I truly appreciate your support! My newbie confidence is a little shaky right now...

For localhost, I see:

XAMPP for Windows

Welcome to XAMPP for Windows version 1.7.0!
Congratulations: You have successfully installed XAMPP on this system!
etc, etc.

For 127.0.0.1, I see:

Request Error (invalid_request)
Your request could not be processed. Request could not be handled
This could be caused by a misconfiguration, or possibly a malformed request.

For localhost/xampp, I see:

The same screen as for just localhost.

Loaded Configuration File reads:
c:\xampp\xampp\apache\bin\php.ini
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 00:51

Open C:\Windows\system32\drivers\etc\Hosts file by right clicking on Notepad and selecting to run as an administrator.

You should have this line as the first line after all the comments:
127.0.0.1 localhost

If not add it.

If you see this line:
::1 localhost
then comment it out so it looks like this:
# ::1 localhost

Save the file then try and go to http://127.0.0.1


BTW if you can go to http://localhost/security do you still have the error and no full page.

Double check that the edits you made in the httpd-xampp.conf file look like my earlier post.

Don't be disheartened we will hopefully succeed with this issue it's just a matter of digging out the root cause of it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 01:44

In the Hosts file, I added the # sign. Everything else was as you said it should be. 127.0.0.1 still has the request error, even after rebooting.

localhost/security does not give an error, but I only get the title "XAMPP for Windows" and the orange sidebar where I can click security or a new language. When I click security, I get the chart displaying security openings that need fixing. This is just like when I enter localhost, get the welcome screen, click security, then click security again.

I double checked the httpd-xampp.conf edits. They're like your earlier post.

Could Spysweeper be interfering? When I changed the Hosts file, I got a warning from Spysweeper, but clicked to save the changes anyway. When that happened, I just wondered if Spysweeper is known to be a problem? Haven't heard that, but one never knows.
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 02:10

There is something definitely interfering with 127.0.0.1 - as you know by the edits in the httpd-xampp.conf file that XAMPP relies on 127.0.0.1 for many things and if it is not available then those errors will show.

I don't know Spysweeper but if there is a way of temporarily disabling it and then testing XAMPP again then give it a try.

Also a firewall may be at issue so first try Spysweeper then if after disabling it you still have problems then try temporarily disabling the Windows firewall.

This is now definitely not XAMPP related but rather something interfering on your PC, its just a matter of finding what is interfering and a process of elimination will be the way to go.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 02:46

I disabled Spysweeper, Windows firewall, and Trend Antivirus. I'm getting the same Request Error. I googled the error and found nothing helpful. Any ideas of what else to check? I don't have any other security software on my pc.
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 02:52

Did you reboot after disabling Spysweeper as I found lots of instances where Spysweeper interfered with 127.0.0.1 and after disabling it may still be working until you reboot.

This is the Google search I am using at the moment.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 03:20

I tried the reboot (after disabling spysweeper and the automatic start at logon). Same error.

These last two times when I go to delete my browser cache, the history shows "http://127.0.0.1:37848/Main" (which I certainly did not type in) as well as what I have actually typed in: "127.0.0.1". Does that give you any clues?
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 03:32

You may be using Internet Explorer perhaps.

Look in the Internet Properties by right clicking on the IE icon on your desktop
(I only have an old IE that I use for testing web sites so these instructions may be slightly different for a new version).

Click on Connections tab.

Click on Settings

If Proxy server is ticked make sure that also ticked is Bypass proxy server for local addresses.

Now click on LAN Settings

And check that Bypass proxy server for local addresses is ticked if you set a proxy for the LAN.

Or if you are using any other proxy, anywhere then make sure that local addresses are bypassed.

You may try http://127.0.0.1:80 and see if it gets there.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 03:55

After clicking on Settings, there is no place that says anything about proxy settings. I clicked on LAN settings. "Use a proxy server for your LAN" is not ticked. I ticked it and also the Bypass... box. Still a Request Error. I went back and unticked both boxes.

I don't know what a proxy is. So I don't think I'm using one anywhere else. Is there any way to check that so I can bypass local addresses?

I tried 127.0.0.1:80 and got this: "The webpage cannot be displayed." Lower down, I clicked on the option "Search online for a program you can use to view this web content." That page gave this message: Protocol Type: 127.0.0.1
Description: Unknown
Windows does not recognize this protocol.
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 04:04

I am checking into your last post to see what I can find.

But are you adding the http:// when you type 127.0.0.1 like so?
http://127.0.0.1:80/

or http://127.0.0.1/ etc.

Also can you please paste the contents of the Hosts file.
Thanks.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: ramasubburam and 68 guests