all requests go to http:/localhost/xampp ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

all requests go to http:/localhost/xampp ?

Postby Enno Julian » 23. December 2008 11:55

Installed xampp on my Vista laptop under c:/xampp (NOT c:/program files/xampp). Xampp runs, mysql runs. However all local http requests e.g. (http://localhost/testsite/page.php) return to the xampp homepage (http://localhost/xampp) instead off to the requested page of the local development site.

When I open a page of the testsite for the first time I also get prompted to complete xampp username and password which I have never seen before on the xampp installation on my other p.c..

I checked Firewall settings, both xampp and mysql are enabled.

What could be the case?
Enno Julian
 
Posts: 5
Joined: 23. December 2008 11:41

Re: all requests go to http:/localhost/xampp ?

Postby Sharley » 23. December 2008 12:05

Where did you create your testsite folder?

C:\xampp\htdocs\ = http://localhost/
C:\xampp\htdocs\testsite\ = http://localhost/testsite/

Have you made any changes at all in any of the XAMPP component configuration files?


Check in C:\Windows\system32\drivers\etc\HOSTS file for the IPv6 setting:
::1 localhost
and comment it out to
# ::1 localhost
if you find it.
See if that helps if you have created your testsite folder as above.
You can always uncomment the line again if it has no effect.

BTW what happens when you go to just http://localhost/
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: all requests go to http:/localhost/xampp ?

Postby Enno Julian » 01. January 2009 13:14

Thanx for your reply, I made the changes to the host file as you suggested, but it made no difference.
Could it be somewhere in the firewall properties for the Apache server which is active under the Firewall Incoming Connections?
Enno Julian
 
Posts: 5
Joined: 23. December 2008 11:41

Apache installation instructions for Vista

Postby Enno Julian » 17. January 2009 15:36

This thread was for Xampp 1.6.8. . After installing Xampp 1.7 I ran into further problems: the security settings in admin page gave a 403 in the browser. This lead finally to the following thread viewtopic.php?f=4&t=32677&p=132274&hilit=vista#p132274 which gave me the solution for all installation problems in Vista.
In short:
Changing the Windows settings as mentioned by Sharley (see above) is a part of the solution. Additional changes need to be made in Apache itself . I Solved the Apache installation problems in Vista by following the instructions in the aforementioned thread.
Enno Julian
 
Posts: 5
Joined: 23. December 2008 11:41

Warning: mail() [function.mail]: SMTP server response: 550 5

Postby rehriff » 25. November 2009 11:18

OR ANY OF THE ERRORS ACCOMPANYING IT



How To: PHP Sendmail and XAMPP on Windows

It can be difficult getting the PHP’s default mail functions to work when you run an apache server on windows instead of a unix environment. I ran into this problem with my server (running XAMPP), and thought others may benefit from a quick how-to. Another slight problem I had to get working was using an SMTP server that requires [/contents/crypto/ssl.php3 SSL] connections (gmail for one). I didn’t realize that most recent XAMPP releases have sendmail built in already. This takes part of the hassel out, but we still have some configuring to do.
First, ensure that you have an XAMPP release that does include the fake sendmail program. [More details here]
Next, go to the XAMPP directory (often C:\xampp\), then open the ’sendmail’ subdirectory. You’ll most likely see the following files (default):
sendmail.exe
readme.html
sendmail.ini
sendmail_example.ini
license.html
Open the file sendmail.ini – this is where all of your SMTP server configurations will go, for example: SMTP Username, Password, Host, Port, etc
My sendmail.ini file looks something like this:
; configuration for fake sendmail
[sendmail]
smtp_server=smtp.gmail.com
smtp_port=465
; SMTPS (SSL) support
; auto = use SSL for [/contents/internet/port.php3 port] 465, otherwise try to use TLS
; ssl = alway use SSL
; tls = always use TLS
; none = never try to use SSL
smtp_ssl=auto
default_domain=brettshaffer.com
error_logfile=error.log
; if your smtp server requires authentication, modify the following two lines
auth_username=<USERNAME / EMAIL ADDRESS HERE>
auth_password=<[/contents/attaques/passwd.php3 PASSWORD] HERE>

Note that this is a very simple setup. The variable names are fairly obvious, so simply fill in the SMTP server, port, ssl mode, username, password, and default domain / error log if you&#8217;d like.
GMail requires an SSL connection, so my config was setup to use SSL port 465 and smtp_ssl=auto. If SSL is not necessary for your SMTP server, simply set smtp_ssl=none.

Once the configuration is setup, make sure to save changes, then exit.

If you are going to use SSL connections, you will need two additional files, available here "http://glob.com.au/sendmail/sendmail-SSL.zip" (as of March 2009) &#8211; if this link no longer works, use the contact form and let me know.
Extract the two compressed files (libeay32.dll and ssleay32.dll) to the same directory as sendmail.exe (for me, C:\xampp\sendmail\)
Now, everything on the sendmail&#8217;s end is setup &#8211; now we just need to let the server know its there!
Edit your PHP.ini file:
XAMPP installations often have multiple files. If you are doubtful of the correct one, you can always go through and change them all. But before you do that, change the php.ini in \xampp\apache\bin\.
Look for the following line:

sendmail_path = &#8220;C:\xampp\sendmail\sendmail.exe -t&#8221;
Uncomment the line (if already commented) by removing the semicolon at the start.
Ensure that the path to sendmail.exe is correct (this is correct for me).
Save and exit php.ini
Restart the apache server and everything should work!
rehriff
 
Posts: 1
Joined: 25. November 2009 11:15

Re: all requests go to http:/localhost/xampp ?

Postby doppelgangland » 25. November 2009 11:30

I have the same problem as Enno here. I'm running a website under windows xp using xampp. I had to go to the apache config file and specify that the document root was your equivalent for testsite. Now all petitions go to the desired website and people no longer see the prompt for user and password.

However, now I can't access the xampp admin part anymore unless I revert that change! And I'd really like to be able to, so I could check statistics and export tables for other uses.

Can anyone help me or point me in the right direction?
Last edited by doppelgangland on 25. November 2009 11:37, edited 1 time in total.
doppelgangland
 
Posts: 3
Joined: 25. November 2009 11:13

Re: all requests go to http:/localhost/xampp ?

Postby Nobbie » 25. November 2009 11:37

Apply VirtualHosts to your installation (different domain/hostnames for same IP). Each VirtualHost has its own DocumentRoot.
Nobbie
 
Posts: 6766
Joined: 09. March 2008 13:04

Re: all requests go to http:/localhost/xampp ?

Postby doppelgangland » 25. November 2009 11:39

Nobbie wrote:Apply VirtualHosts to your installation (different domain/hostnames for same IP). Each VirtualHost has its own DocumentRoot.


I've tried that a couple of times, but I guess I don't understand it very well because It always ends badly. Is there a thread or tutorial about this you could point me to?
doppelgangland
 
Posts: 3
Joined: 25. November 2009 11:13

Re: all requests go to http:/localhost/xampp ?

Postby Nobbie » 25. November 2009 12:15

You may also supply Alias (instead of VirtualHosts), its much easier and will work also.

Example:

Code: Select all
Alias /xampp c:/xampp/htdocs


And you also need <Directory c:/xampp/htdocs> ... to apply Options and sufficient rights for Apache to access that folder.

After restart you can reach your Xampp htdocs folder via http://localhost/xampp.

Or define an Alias for your phpmyadmin folder (whereever it is installed):

Code: Select all
Alias /phpmyadmin c:/where/ever/it/is/phpmyadmin
<Directory c:/where/ever/it/is/phpmyadmin>
...
Allow From all
</Directory>


and you reach it via http:/localhost/phpmyadmin
Nobbie
 
Posts: 6766
Joined: 09. March 2008 13:04

Re: all requests go to http:/localhost/xampp ?

Postby doppelgangland » 25. November 2009 13:26

The Alias solution worked like a charm, thank you so very much!

I guess the VirtualHosts directive was not meant for this anyway...
doppelgangland
 
Posts: 3
Joined: 25. November 2009 11:13

Re: all requests go to http:/localhost/xampp ?

Postby Nobbie » 25. November 2009 13:39

doppelgangland wrote:I guess the VirtualHosts directive was not meant for this anyway...


It depends. If you would like to reach your server from inside (localhost) and outside (Public IP / Domain), and would like to hide admin tools like phpmyadmin, a VirtualHost is the perfect solution. There is no "not meant for", everything depends on your needs.
Nobbie
 
Posts: 6766
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests