Vista: make_sock: could not bind to address 0.0.0.0:8

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Vista: make_sock: could not bind to address 0.0.0.0:8

Postby Bob Furber » 03. September 2008 23:10

I suppose the 1st question should be how to search this forum. I imagine my question has already been answered:

I installed XAMPP on a WinVista PC from xampplite-win32-1.6.7.exe into D:\Program Files\xampp, then ran setup-xampp.bat which produces:

########################################################################
# ApacheFriends XAMPP setup win32 Version 1.6 #
#----------------------------------------------------------------------#
# Copyright (c) 2002-2005 Apachefriends #
#----------------------------------------------------------------------#
# Authors: Kay Vogelgesang <kvo@apachefriends.org> #
# Carsten Wiedmann <webmaster@wiedmann-online.de> #
########################################################################

Configure for server 1.6.7
Configure XAMPP with awk for 'Windows_NT'
Please wait ...
Enable AcceptEx Winsocks v2 support for NT systems DONE!


##### Have fun with ApacheFriends XAMPP! #####


Press any key to continue . . .


When I run apache_start.bat, I get:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .


What am I missing? How can I join all the happy users anf get XAMPP to work on Vista?
Bob Furber
 
Posts: 3
Joined: 03. September 2008 22:46
Location: Canada

Postby Wiedmann » 03. September 2008 23:44

What am I missing?

You have allready another program running which is using port 80. Stop this program and you can start XAMPP/Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bob Furber » 04. September 2008 05:41

I am having a devil of a time trying to determine who is using port 80.

With all apps closed, save the cmd window, I enter a netstat command and find that port 80 is indeed in use:

C:\>netstat -na

Active Connections

Proto Local Address Foreign Address State
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
TCP 0.0.0.0:443 0.0.0.0:0 LISTENING
: :

The Task Manager shows no apps running.

I disconnected the network in the "Network and Sharing Center" and, still netstat shows port 80 in use.

Any thoughts how one can free port 80 to start Apache?

Thanks,

Bob
Bob Furber
 
Posts: 3
Joined: 03. September 2008 22:46
Location: Canada

Postby Bob Furber » 04. September 2008 05:48

Duh!

It turns out that Skype, sitting in the system tray, was locking up port 80.

Thanks for your patience and help,

RF
Bob Furber
 
Posts: 3
Joined: 03. September 2008 22:46
Location: Canada

Postby CarlClark » 03. October 2008 07:01

Bob, thank you so much for figuring this out! You just saved my sanity. I've been trying for days to get Apache back up and running!

Keep up the good work! 8)
CarlClark
 
Posts: 1
Joined: 03. October 2008 06:59

Re: Vista: make_sock: could not bind to address 0.0.0.0:8

Postby th1alb » 19. December 2008 16:52

Thanks skype does block apache by using port 80 , thanks- i wish i'd found this post sooner. :D
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: Vista: make_sock: could not bind to address 0.0.0.0:8

Postby begodwilling » 13. February 2009 00:02

Thank you guys, that is Skype. I disabled it and Apache works!
begodwilling
 
Posts: 1
Joined: 13. February 2009 00:00

Re: Vista: make_sock: could not bind to address 0.0.0.0:8

Postby Izzy » 13. February 2009 00:42

begodwilling wrote:Thank you guys, that is Skype. I disabled it and Apache works!
No need to disable Skype just change the ports that it uses.

Skype uses port 80 and 443 by default.
You can alter that behavior by going to:
Tools\Options\Connection
Untick
Use port 80 and 443 as alternative for incoming connections
You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

Use ports between 49152 through 65535.
http://www.iana.org/assignments/port-numbers
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests