Error 32 ! pls help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 32 ! pls help

Postby tommy70777 » 12. August 2008 09:02

Hi ! I have a problem with MySQL, I want start MySQL in console mode, but it doesnt work. When I start MySQL console (xampp/mysql.bat) it write me :

"Operating system error nimber 32 in a file operation. The error ,means that another program is using InnoDB's files. This might be a backup or antivirus software or another instance. Please close it to get rid of this error."

and I dont know what can I do with that.
Or how can I start mysql in console mode ?
Posts: 1
Joined: 12. August 2008 08:49

Postby JaCKo » 02. October 2008 19:01

Had the same problem, just fixed it, partly. see if you have any more luck and get back to this thread please.

So, I have an HP laptop with HP software that came with it. Among the software are also a Mobile protection system and protect tools security manager. I turn these off through msconfig/startup and I run the mysql bat. I don't get the error 32, but the thing just hangs forever. This is what comes up:
Mysql is starting with mysql/bin/my.cnf (console)
081002 19:45:14 InnoDB: started; log sequence number 0 43655
081002 19:45:14 [Note] mysql/bin/mysqld: ready for connections.
Version: '5.0.67-community' socket: ' 'port: 3306 Mysql Community edtition (GPL)

I know I'm supposed to wait a while the first time it starts up, but its been hanging for 15 minutes now, seems like a lot.
Posts: 7
Joined: 02. October 2008 09:07

Postby glitzi85 » 03. October 2008 16:07

@tommy70777: Try to switch off any Security-Software, like Virus-Scanners or any Software like that JaCKo mentioned.

@JaCKo: Nothing more will happen. You now can connect to your Database.

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby JaCKo » 05. October 2008 08:02

Unfortunately that isn't/wasn't the case.
I couldn't connect to the database because the connection just hung in the air, it never actually connected, no green lights in the control panel.

I uninstalled xampp and reinstalled with the installer with no effect - the thing was that I couldn't delete cetain files, so I tried moving them and after a while (and a ton of 'access denied' warnings) I managed to get them out of the xampp folder. I then downloaded the .zip version of xampp and unpacked it into c:/xampp and voila, the thing works.

Don't ask me why or what happened, haven't gotta clue, it just works now and I' happy.

Hope this helps any further issues you may have had with your installation.
Posts: 7
Joined: 02. October 2008 09:07

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests