Installation of XAMPP on a Mac

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Installation of XAMPP on a Mac

Postby gwpowell » 16. July 2008 11:05

I Have just downloaded and installed XMAPP for Mac everything appeared to go well. Installation completed without a hitch, but when I tried to open my browser with "http://localhost" as per the instructions in the quick start guide I encountered a "problem loading page error"

I consulted the specific XMAPP installation guide for Mac and came across this. I have know idea what any of this means. It seems to be installation procedure for older computers.

* Step 2: Installation
After downloading simply run the following commands in a terminal:

Installation requires an admin account.
# Enter „sudo su“. You will be prompted for a password.
# tar xfvz xampp-macosx-0.7.3.tar.gz -C /

Notice: all old installations of XAMPP for MacOS X will be overwritten!

That's all. XAMPP is now installed below the /Applications/xampp directory.
* Step 3: Start
After installing simply type in the following commands to start XAMPP for MacOS X:

1. Go to a Terminal shell and login as the system administrator root:

sudo su

2. To start XAMPP simply call this command:

/Applications/xampp/xamppfiles/mampp start

You should now see something like this on your screen:

Starting XAMPP for MacOS X 0.7.3...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for MacOS X started.

Ready. Apache and MySQL are running.

If you get any error messages please take a look at the MacOS X FAQ.

I went to the FAQ for MacOS X and there are no FAQ's
Any help would be appreciated.
Posts: 2
Joined: 16. July 2008 11:01

Postby Nobbie » 16. July 2008 12:07

> I have know idea what any of this means

What? And what did you mean by "Installation completed without a hitch,"?

If you have "no idea" what any of the installation description (yes, thats the installation description!) means, how could you complete the installation "without a hitch"? What did you actually do there?
Posts: 11996
Joined: 09. March 2008 13:04

Postby gwpowell » 16. July 2008 23:32

When i say without a hitch, I meant apparently successfully.
When I opened the downloaded program the automatic installation procedure took over and installed the program into the applications folder. The only thing I was requested to do was enter the password for my computer. then the installation completed itself.
It was just like installing any other software.
Posts: 2
Joined: 16. July 2008 11:01

Postby jmdirc » 17. July 2008 15:20

Did you actually try to open a page or did you just go to Localhost? What is in your htdocs folder?
User avatar
Posts: 154
Joined: 10. February 2008 22:44

got the same problem

Postby riceandfish » 22. July 2008 07:28

I cant seem to see the orange background index page/. Instead I see an apache test page. what are we doing wrong? ANYONE>>???
Posts: 1
Joined: 22. July 2008 07:20

Postby jmdirc » 22. July 2008 14:04

I just recently posted this in another thread, but I'll put it here also, this should fix your problem:

if you want to reach the xampp index page - http://localhost/xampp/ index.php by typing http://localhost


go to:

<VirtualHost *:80>
DocumentRoot "/Applications/xampp/htdocs"
ServerName localhost
Options FollowSymLinks
AllowOverride All

you can comment out or delete the sample entries if you like (just keeping it clean)
User avatar
Posts: 154
Joined: 10. February 2008 22:44

The same problem

Postby kstroud1 » 16. October 2008 01:19

I believe I've done what you described but am still getting the xampp page that is not the one with the orange background. I did the v-host thing and still nothing has changed. I'm not a programmer so please keep it simple.
Posts: 1
Joined: 16. October 2008 01:10

Postby jmdirc » 16. October 2008 20:48

when that page comes up - just click on your language- your done
User avatar
Posts: 154
Joined: 10. February 2008 22:44

having a similar problem

Postby kage » 17. October 2008 13:08

I am running a fresh installation of xampp on leopard. I set up the installation and everything was working fine on safari and opera (latest versions). But because of some webprogramming conflicts I needed to install firefox. I installed 3.0.3 and I then started getting problems with my localhost. First I lost the xampp indexpage and got the apache homepage, I then started to get an authentication box (which I didn´t know the password to) and then the problem migrated to opera and safari - so my localhost became inaccessable because of the authenication box.
I followed suggestions from a forum - turn off websharing and restart - and i changed my doc root and directory. This was a work around for the sake of opera and safari - I can now see my localhost but have lost the xampp admin page,

on firefox - (which i really need) I get directed to http://localhost/xampp/index.php . when I type in localhost - which it can´t find.
http://localhost/web (where I put my web docs) which works in safari and opera is "not found" on firefox.

Any suggestions - I have looked around a lot on all forums but I can´t seem to work out if this is a firefox problem or not.

update: I tried changing the /Applications/xampp/etc/extra/httpd-vhosts.conf as suggested by jmdirc which worked a treat for me and my firefox prob. but it only works when I assign another place to put my web docs. If I keep them in xampp/htdocs I get the whole authentication problem again. However without xampp/htdocs I don´t get xampp admin page - or am I missing something?
Posts: 2
Joined: 17. October 2008 11:47

Postby jmdirc » 17. October 2008 20:28

What do you get? Error page anything?

edit: if I understand your problem right: you should get an authentication page - use name: "Xampp", and your password you set up the application with. If you forgot the password, try your mac account password. If that doesn't work, you may have to uninstall and reinstall xampp - write your password down.
User avatar
Posts: 154
Joined: 10. February 2008 22:44

Re: Installation of XAMPP on a Mac

Postby keif » 04. December 2008 18:11

Do you have websharing enabled? (hit your IP address, is it the default mac apache page?)

I had some conflicts with my mac's apache instance since I had it turned on - once I turned it off, I got right into xampp's homepage.
Posts: 2
Joined: 04. December 2008 05:09

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 3 guests