DocumentRoot not working

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

DocumentRoot not working

Postby pkiula » 30. June 2008 03:50

Hi, I have just downloaded and installed xampp on my leopard iMac. It all works flawlessly, thanks for the lovely install!

But now I want to move the DocumentRoot in httpd.conf to my own path so that I can see my own files. I don't mind having "xampp" as an alias, but that's it.

So I open the /Applications/xampp/etc/httpd.conf and add the following lines:

DocumentRoot "/Users/Me/Code"
<Directory "/Users/Me/Code">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>

<Directory "/">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>


And then I restart Apache. But this always gives a 403 access forbidden. Why is that? What can I do to make sure that all my apache files (htdocs) are where I want them and not inside that long arcane xampp install?

Thanks! [/quote]
pkiula
 
Posts: 4
Joined: 30. June 2008 03:35

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests