Skype interferes with xampp on port 80

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Skype interferes with xampp on port 80

Postby rgoya » 28. June 2008 00:36

I tried to install xampp and xampplite but could not start the apache server it appeared to be a problem with using port 80

I installed wampserver and the port 80 test determined that Skype may be using it

I closed Skype and then the server was able to run and I could put wamp online and view the test pages - working fine

I restarted Skype which went through a reinstall procedure, I guess to automatically change ports, so now I have the wamp server and Skype both running

I stopped wampserver and reinstalled xampplite which is running fine now, no conflict with Skype

If you are having trouble with wamp, xampp or xampplite try closing Skype
~are you netsperienced?
http://netsperience.org
rgoya
 
Posts: 3
Joined: 28. June 2008 00:32
Location: USA

Postby Arianna-Microchip » 28. June 2008 12:05

[excuse me for my english, I'm Italian]

problem is skype, not xampp (or others).

So... open skype, go on the option panel -> Advanced -> connection [i read this in Italian, translate must be so...]
and uncheck "Use 80 and 443 ports like alternative for incoming connection"

So you solve! :)
User avatar
Arianna-Microchip
 
Posts: 6
Joined: 27. June 2008 23:55
Location: Rome, Italy

yes but xampp did not diagnose the problem

Postby rgoya » 28. June 2008 14:54

yes that is a good solution - I have already done that

I was frustrated with xampp until I installed wampserver and its port 80 test suggested the conflict could be Skype

others may also have a conflict problem installing xampp but not realize that Skype is running on port 80

scusa mio italiano
habitavo nel Roma 35 anni fa
la bella citta!
ciao!
~are you netsperienced?
http://netsperience.org
rgoya
 
Posts: 3
Joined: 28. June 2008 00:32
Location: USA

Postby Arianna-Microchip » 28. June 2008 23:43

Infact the first time I don't know why my port 80 was used...
I try to close skype because it was the only software running (with internet), so I solved immediately :)

You speak Italian! :) WOW!!!! :)
I'm Sicilian, but now I live in Rome. Beautiful city!
Arianna Microchip
User avatar
Arianna-Microchip
 
Posts: 6
Joined: 27. June 2008 23:55
Location: Rome, Italy

!

Postby rgoya » 29. June 2008 00:11

Here is the exact procedure to turn off port 80:

Using Skype 3.8.0.139 (I believe latest version)

Under the Tools menu > in Options > in Advanced > in Connection

there is a text field to set the port number - mine by default is 59040 and I left it alone

below there is a checkbox "Use port 80 and 443 as alternatives for incoming connections"

I unticked the box and Skype and xammp are working fine


from The Webmaster Forums

And I contacted Kai and Kay about the conflict..

I speak italiano cosi malo - it was a long time ago

I lived one block from il Colosseo and I remember once during a traffic jam all the cars drove around Circo Massimo!

Arianna, feel free to PM me or you can IM me right from my website at http://netsperience.org - but don't expect me to parlo molto italiano - maybe you can help get some of the rust off!
~are you netsperienced?
http://netsperience.org
rgoya
 
Posts: 3
Joined: 28. June 2008 00:32
Location: USA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests