XAMPP does not work under Windows XP SP2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP does not work under Windows XP SP2

Postby ajnin » 10. February 2008 14:18

Hi there,

I have just installed the contents of "xampp-win32-1.4.16-installer.exe" on WinXP SP2 (Home Edition). When it starts, it only shows a green tick in the check box beside MySQL and FileZilla.

When I try to start Apache and/or MySQL, they do not show as running and the following errors are returned when I try to start them:

When using "apache_start".bat":
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
Syntax error on line 57 of C:/server/xampp/apache/conf/httpd.conf:
ServerRoot must be a valid directory

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
_____________________________________________

When using "mysql_start".bat":
Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running
MySQL is trying to start
Please wait ...
MySQL is starting with mysql\bin\my.cnf (console)
080210 21:08:09 [ERROR] Can't find messagefile '\xampp\mysql\share\english\errms
g.sys'
080210 21:08:09 [ERROR] Aborting


MySQL konnte nicht gestartet werden
MySQL could not be started
Press any key to continue . . .
___________________________________________

If I look at the console, all buttons, except "Admin", are active.
I have performed the port checker and all show as follows:


***************************************************************
* XAMPP PortCheck v1.2 *
* *
* (c) 2005 Carsten Wiedmann <info@wiedmann-online.de> *
* *
* This script uses openport.exe: *
* (c) 2003 DiamondCS <http://www.diamondcs.com.au/openports/> *
***************************************************************

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 443 free

MySQL 3306 free

FileZilla (FTP) 21 C:\server\xampp\FileZillaFTP\FileZillaServer.exe
FileZilla (Admin) 14147 C:\server\xampp\FileZillaFTP\FileZillaServer.exe

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free

Press <Return> to continue.
_____________________________________________

I have deactivated Windows Firewall. I have not defined port exceptions yet, though.

I have since unchecked the connection setting on Skype that uses port 80.

AVG is my anti-virus software, which I have also deactivated.

I have since uninstalled and reinstalled a number of times trying to get this to work....to no avail.

Please advise how I can trouble shoot further/fix this issue....
"Learn as you'd live forever, but live as you'd die tomorrow" - Ghandi
ajnin
 
Posts: 4
Joined: 10. February 2008 07:40
Location: Hong Kong

Postby Scory » 10. February 2008 16:23

Simply read the error message:

Syntax error on line 57 of C:/server/xampp/apache/conf/httpd.conf:
ServerRoot must be a valid directory


A perfect information - isn't it?

Same for MySQL:

MySQL is starting with mysql\bin\my.cnf (console)
080210 21:08:09 [ERROR] Can't find messagefile '\xampp\mysql\share\english\errms


What a great message - all you need to know!

Look into the mentioned files and tell us, what went wrong!
Scory
 

Postby Izzy » 11. February 2008 04:48

I have since uninstalled and reinstalled a number of times trying to get this to work....to no avail.

When uninstalling XAMPP, make sure that all the XAMPP modules are stopped and all XAMPP modules installed as a service have been uninstalled and close the Control Panel - then run the uninstall script and make sure that the xampp directory has been deleted, don't try and reinstall by overwriting the original xampp directory as this will cause your installation to fail.

Tip 1 - next time you do an installation try and install to C:\ root directory as this often alleviates path issues - your ServerRoot would then look like this:
ServerRoot "C:/xampp/apache/bin"

Tip 2 - The zipped versions doesn't mess with the Windows installer so you can extract XAMPP to any location you like and then run the setup_xampp.bat file and your installation paths will all be set correctly.


Your current path issues may also be related to the antique version of XAMPP you have installed, perhaps not having a refined installer that is present in the newer versions.

So perhaps in this case, running the setup_xampp.bat file first may help with your issue

This has the effect of setting your installation path to the correct locations as you have installed to a different location than is normal.

After running the bat file, manually check line 57 of your httpd.conf file in a text editor and see if it looks like this perhaps:
ServerRoot "C:/server/xampp/apache"
If not then change it to look like the above.

Make sure any other paths in the httpd.conf file show your XAMPP installation path "C:/server/xampp" in much the same format as the above ServerRoot path.

Try and start Apache again after saving the file if you made any changes - always make a backup of conf and ini files before editing.

The other issue with MySQL may also be cleaned up by running the setup_xampp.bat file but if not then drag the C:\server\xampp\mysql\bin\my.cnf (it may be just called my and look like a link) into your text editor and check the paths look like this:
# The MySQL server
[mysqld]
basedir="C:/server/xampp/mysql"
tmpdir="C:/server/xampp/tmp"
datadir="C:/server/xampp/mysql/data"

And for any other paths in this file - also make sure the tmpdir exists.

Save the file if you changed anything and restart MySQL.

The above may not help but you have an obvious path issue from the errors you posted in your original post.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby ajnin » 12. February 2008 07:41

[quote="Izzy"]

Tip 1 - next time you do an installation try and install to C:\ root directory as this often alleviates path issues - your ServerRoot would then look like this:
ServerRoot "C:/xampp/apache/bin"

Tip 2 - The zipped versions doesn't mess with the Windows installer so you can extract XAMPP to any location you like and then run the setup_xampp.bat file and your installation paths will all be set correctly.


quote]

Ok, so I have now donwloaded the .zip version of the file. I have extracted the contents to C:/. I ran the setup_xampp.bat file from there, which set the right path in the httpd.conf file as you suggested.

The next step I took was to start the Apache 2 with
apache_start.bat, but the CMD prompt states:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
___________________________________________________

Is it supposed to stay like that? Or should it say it has started, if successful?
"Learn as you'd live forever, but live as you'd die tomorrow" - Ghandi
ajnin
 
Posts: 4
Joined: 10. February 2008 07:40
Location: Hong Kong

Postby Izzy » 12. February 2008 08:09

Is it supposed to stay like that? Or should it say it has started, if successful?
Yes, that looks good now, no error messages and it will stay like that.
You can either reduce it to the tray or click on it to close it and stop Apache - You can close it now and use the Control Panel mentioned below.

This bat file is mainly used to troubleshoot the module as it gives back error messages if there is a failure.

Now you can use the XAMPP Control Panel:
C:\xampp\xampp-control.exe
to start Apache and MySQL.
You should see both Running with a green background after clicking the Start buttons.

BTW, the MySQL Admin... link is no longer used, so use phpMyAdmin from the menu mentioned below or go direct:
http://localhost/phpmyadmin

Use root as the username and no password is required till you set one after reading the security section of the Welcome Pages. Then click on Go and you should be in phpMyAdmin.


When you have them both started go to:
http://localhost and select your language.
Then check out all the menu items to give XAMPP, the server and MySQL a good workout.
Last edited by Izzy on 12. February 2008 08:24, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby ajnin » 12. February 2008 08:24

Brilliant, thanks.

Should I enable Intranet settings on my browser?

btw - I signed the petition and posted the link on my facebook profile.
"Learn as you'd live forever, but live as you'd die tomorrow" - Ghandi
ajnin
 
Posts: 4
Joined: 10. February 2008 07:40
Location: Hong Kong

Postby Izzy » 12. February 2008 08:36

Should I enable Intranet settings on my browser?
Not necessary to run XAMPP but if you find you need to then that will be fine - personally I don't have the need to, so can only hazard a guess if you will need it or not.

Thanks for signing the petition and every little bit helps to grow the bigger picture. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

All fixed -belated thanks

Postby ajnin » 01. March 2008 08:38

Sorry for not replying earlier...meant to say thanks for all the help, everything is working out fine.

:D
"Learn as you'd live forever, but live as you'd die tomorrow" - Ghandi
ajnin
 
Posts: 4
Joined: 10. February 2008 07:40
Location: Hong Kong

Apache does not connect

Postby countrycharm » 06. March 2008 16:56

I have windows XP Pro with sp2 installed. I have followed every detail of these forms and nothing seems to work for me. I have tried Apache on port 80, 8080 and so on. I am now trying the dtx program changing the ports to 6060 and 6080 but still Apache has error problems. or my computer does. This is the error log.
[Thu Mar 06 10:48:52 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Mar 06 10:48:57 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Thu Mar 06 10:48:57 2008] [notice] Server built: Jan 18 2008 00:37:19
[Thu Mar 06 10:48:57 2008] [notice] Parent: Created child process 3644
[Thu Mar 06 10:48:58 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Mar 06 10:48:59 2008] [notice] Child 3644: Child process is running
[Thu Mar 06 10:48:59 2008] [notice] Child 3644: Acquired the start mutex.
[Thu Mar 06 10:48:59 2008] [notice] Child 3644: Starting 250 worker threads.
[Thu Mar 06 10:48:59 2008] [notice] Child 3644: Starting thread to listen on port 6060.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:48:59 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:49:00 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Thu Mar 06 10:49:00 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3644: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.


This is what it says even on port 80 If some one could point me in the right direction, I sure would be grateful. What I trying to do is set a test web site up on my computer. I have a zen web site already, I just want to set up a test site so I can make changes on my home computer before I update my main site. Thank you for your time.
countrycharm
 
Posts: 5
Joined: 06. March 2008 16:37

Postby ridgewood » 08. March 2008 15:02

The problem is that I haven't encountered a lot of these problems with XP and Xampp... and I do a lot of different test beds on a lot of different computers... here are a couple of suggestions...

- check the windows firewall and see what the settings are for the Apache HTTP Server... not just the 'exception' but also the path in the exception. If you can turn the firewall off without exposing your system or by (taking it off line) see what that does. If you are running any other firewalls like Zone Alarm or a virus scanner, check the advanced settings.

- on line 53 use: Listen "localhost:6060" in the httpd.conf

*make sure that there are no services or sessions of XAMPP running from previous installs*

If that doesn't change things.... try a fresh build...

- if you have a removable USB drive or stick available: download the zip version of XAMPP and unpack it to the drive, put it in a sub-directory say; dtx/ and the dtx-controller in dtx/xampp/ .... follow the instructions in the read me (especially commenting out the SSL!) ....

When you launch the dtx-controller it will trigger the setup batch file with a new path etc. (one of the reasons to use a different directory structure)...

If anything blocks the startup there should be a prompt... it should surface the 'blocker'...

If you can't use a USB drive, then try the above using a path like: c:\dtx\xampp

I am still traveling but I have access to the net until at least March 11th ...let me know how you make out.
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02

Postby countrycharm » 08. March 2008 19:15

I appreciate your help. Someone told be to try adding this line to my Apache httpd.conf file Win32DisableAcceptEx" at the bottom around line 357 and it worked. Now I'm able to run both xampp and wamp without any problems. Thank you again for your help.
countrycharm
 
Posts: 5
Joined: 06. March 2008 16:37

Re: XAMPP does not work under Windows XP SP2

Postby athenaz » 29. November 2009 09:04

Is it possible to setup a VPN to access my home LAN network from my lappy via public WiFi? I believe this could be useful for gaming as well....please lets avoid Hamachi.
athenaz
 
Posts: 1
Joined: 27. November 2009 12:06

Re: XAMPP does not work under Windows XP SP2

Postby Abbala » 07. December 2009 08:58

I am glad this has provided you with good info. Thanks for your comment.
Enjoy yuor self
Abbala
 
Posts: 1
Joined: 07. December 2009 08:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests