Enable AcceptEx Winsocks v2 support for NT systems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Enable AcceptEx Winsocks v2 support for NT systems

Postby jasonb » 26. July 2006 23:03

Hello all:

I am very sorry if someone has already answered this question, but i was not able to find the answer:

When installing apachefriends, i got the following screen:

########################################################################
# ApacheFriends XAMPP setup win32 Version 1.5 #
#----------------------------------------------------------------------#
# Copyright (c) 2002-2005 Apachefriends #
#----------------------------------------------------------------------#
# Authors: Kay Vogelgesang <kvo@apachefriends.org> #
# Carsten Wiedmann <webmaster@wiedmann-online.de> #
########################################################################

Configure for server 1.5.3a
Configure XAMPP with awk for 'Windows_NT'
Please wait ...
Enable AcceptEx Winsocks v2 support for NT systems


and there it stops.

Does anyone know what i have to do next?

Many thanks.
jasonb
 
Posts: 3
Joined: 26. July 2006 22:57

Postby Izzy » 27. July 2006 02:19

Try this:
Open xampp/apache/conf/httpd.conf in your favourite text editor after making a backup first of course. ;)

Go down to the bottom of the httpd.conf file and add this line:

Win32DisableAcceptEx

Or if that fails change it to this:

Win32DisableAcceptEx ON

If any of the above 2 lines are present already then comment them out by adding # to the beginning of the line so it looks like this:

#Win32DisableAcceptEx

or this:

#Win32DisableAcceptEx ON

It is that entry or lack of it in the httpd.conf file that is generating the error and cousing Apache not to start or install properly. You may also want to check out the exampp/apache/logs/error.log to see if it points to any clues.

Then try your install again or restart Apache again after each and every change you make so that Apache gets to read the changed httpd.conf file.

HTH and good luck! :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wiedmann » 27. July 2006 03:12

jasonb wrote:
Enable AcceptEx Winsocks v2 support for NT systems

and there it stops.

You get a prompt after this line?

Your install path?

Izzy wrote:Win32DisableAcceptEx ON

That's wrong. Only "Win32DisableAcceptEx" with out "ON" is correct in an Apache config file.

BTW:
The reportet error is not from a server start with "apache_start.bat". Thus a change in "httpd.conf" cannot help here.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Izzy » 27. July 2006 05:17

Carsten Weidmann wrote:Izzy wrote:
Win32DisableAcceptEx ON

That's wrong. Only "Win32DisableAcceptEx" with out "ON" is correct in an Apache config file.

I stand corrected if I am wrong.

This is a clip from my 1.4.13 version of XAMPP's Apache httpd.conf file:
# Win32DisableAcceptEx ON
Which clearly shows that indeed this is a correct statement. If it is wrong then XAMPP's authors included this wrong statement in the file.

I included all possible combinations of this as I also have the 1.5.3a version which does not have that entry at all in the httpd.conf file. The original poster did not include much info to work on hence your own questions. I also did say Try this I did not say that it was the definitive answer or fix to his problem just to have a go and try it. If it was of no use he would have posted back then another look at his issue could have ensued.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wiedmann » 27. July 2006 05:43

Izzy wrote:This is a clip from my 1.4.13 version of XAMPP's Apache httpd.conf file:
# Win32DisableAcceptEx ON
Which clearly shows that indeed this is a correct statement.

If you definitely want know what is correct, look into the Apache manual:
http://httpd.apache.org/docs/2.2/mod/mp ... leacceptex

Izzy wrote:If it is wrong then XAMPP's authors included this wrong statement in the file.

Right, he have included a wrong statement. (But he was a lucky man, because Apache doesn't warn the user about this error and it still works)

Izzy wrote:I also did say Try this I did not say that it was the definitive answer or fix to his problem just to have a go and try it.

I know what you have written. And I know definitive that this is not the answer or fix for his problem.

The original poster did not include much info to work on hence your own questions.

Correct. And that's the reason for my additional two questions. (And to prevent him to make unnecessary changes in "httpd.conf".)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jasonb » 27. July 2006 06:37

Hey Guys:

Wiedmann wrote:
jasonb wrote:
Enable AcceptEx Winsocks v2 support for NT systems

and there it stops.

You get a prompt after this line?

Your install path?

Izzy wrote:Win32DisableAcceptEx ON

That's wrong. Only "Win32DisableAcceptEx" with out "ON" is correct in an Apache config file.

BTW:
The reportet error is not from a server start with "apache_start.bat". Thus a change in "httpd.conf" cannot help here.


My install path was to c:\xampp.

I did not get any further lines in the command line window except the "Enable AcceptEx Winsocks v2 support for NT systems". I read somewhere that it should say "DONE" afterwards, but i never got a message saying it was "DONE".

If you could not already tell, I am running windows xp with service pack 2, but i am not using the windows firewall.

EDIT - i forgot to mention that i am trying to install the 1.5.3a version.

Thanks!
jasonb
 
Posts: 3
Joined: 26. July 2006 22:57

Postby Izzy » 27. July 2006 06:48

Weidmann wrote:And I know definitive that this is not the answer or fix for his problem.
That is wrong. That should not be definitive is should be definitely.

To say that you are a moderator in an English speaking forum, you don't have a very good command of the language, do you? Your grammar is often interpreted as being rude and confrontationist, which may be the way a native German speaking individual might express themselves but in English it is not the way to go. There is much reading available on the Internet for you to brush up on your grammar and an attitude change would not go astray either.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wiedmann » 27. July 2006 06:53

My install path was to c:\xampp.

OK. A normal path.

I did not get any further lines in the command line window except the "Enable AcceptEx Winsocks v2 support for NT systems". I read somewhere that it should say "DONE" afterwards, but i never got a message saying it was "DONE".

Right, a:
Code: Select all
  DONE!

  ##### Have fun with ApacheFriends XAMPP! #####

I'm missing here after the line with "Enable AcceptEx ...". And the return to the shell with a prompt like:
Code: Select all
C:\xampp>


EDIT - i forgot to mention that i am trying to install the 1.5.3a version.

No problem, see your first post:
jasonb wrote:Configure for server 1.5.3a


You are using the zip or 7zip-exe for the installation?
Have you test the md5sum for the downloaded file?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jasonb » 27. July 2006 21:17

hello all:

i had to reinstall windows on my computer to solve a lot of other problems my comptuer has been having, and after i reinstalled, xampp seems to be working perfectly.

however, i did test the md5checksum when i originally downloaded the file, and it checked out fine.

thank you to everyone who posted, i really apprecaite it.

thanks.
jasonb
 
Posts: 3
Joined: 26. July 2006 22:57

Postby Izzy » 28. July 2006 04:43

Thats a good out come for you, Jason. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests