Pear/Pecl install not working

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Pear/Pecl install not working

Postby pete1ford » 14. February 2007 17:50

I've downloaded and installed:
XAMPP MacOS X (tar) 0.6a

When I am in the /Applications/xamp/xamppfiles/bin logged in as sudo su I run:
Code: Select all
./pecl install apc

I get this error in the output:

Code: Select all
downloading APC-3.0.12p2.tgz ...
Starting to download APC-3.0.12p2.tgz (94,809 bytes)
.....................done: 94,809 bytes
35 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
ERROR: `phpize' failed

Any ideas what I am doing wrong??

When I run ./pecl config-show I see:
Code: Select all
Auto-discover new Channels     auto_discover    <not set>
Default Channel                default_channel
HTTP Proxy Server Address      http_proxy       <not set>
PEAR server [DEPRECATED]       master_server
Default Channel Mirror         preferred_mirror
Remote Configuration File      remote_config    <not set>
PEAR executables directory     bin_dir          /Applications/xampp/xamppfiles/bin
PEAR documentation directory   doc_dir          /Applications/xampp/xamppfiles/lib/php/pear/doc
PHP extension directory        ext_dir          /Applications/xampp/xamppfiles/lib/php/php5/extensions/no-debug-non-zts-20060613
PEAR directory                 php_dir          /Applications/xampp/xamppfiles/lib/php/pear
PEAR Installer cache directory cache_dir        /tmp/pear/cache
PEAR data directory            data_dir         /Applications/xampp/xamppfiles/lib/php/pear/data
PEAR Installer download        download_dir     /tmp/pear/cache
PHP CLI/CGI binary             php_bin          /Applications/xampp/xamppfiles/bin/php
PEAR Installer temp directory  temp_dir         /tmp/pear/temp
PEAR test directory            test_dir         /Applications/xampp/xamppfiles/lib/php/pear/test
Cache TimeToLive               cache_ttl        3600
Preferred Package State        preferred_state  stable
Unix file mask                 umask            22
Debug Log Level                verbose          1
PEAR password (for             password         <not set>
Signature Handling Program     sig_bin          /usr/local/bin/gpg
Signature Key Directory        sig_keydir       /Applications/xampp/xamppfiles/etc/pearkeys
Signature Key Id               sig_keyid        <not set>
Package Signature Type         sig_type         gpg
PEAR username (for             username         <not set>
User Configuration File        Filename         /var/root/.pearrc
System Configuration File      Filename         /Applications/xampp/xamppfiles/etc/pear.conf
Posts: 2
Joined: 14. February 2007 17:38


Postby groovecoder » 19. April 2007 04:19

Ever get this resolved? I'm getting the same error message when trying to install PDO.
Posts: 6
Joined: 26. February 2007 03:30
Location: Tulsa, OK, USA

never got it working

Postby pete1ford » 19. April 2007 16:53

gave up on it. Instead just bit the bullet and installed Apache, PHP, MySQL seperately and got it all working.
This page was helpful:
Posts: 2
Joined: 14. February 2007 17:38

Postby woodan » 16. July 2007 00:14

I'm also having huge problems trying to install PDO. Has anyone had any luck with this at all?
Posts: 3
Joined: 16. July 2007 00:12

Return to XAMPP für macOS

Who is online

Users browsing this forum: No registered users and 2 guests