Probleme mit Start des XAMPP als Funktionsuser

Irgendwelche Probleme mit XAMPP für Solaris? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit Start des XAMPP als Funktionsuser

Postby swoosh777 » 21. July 2006 10:06

Hallo,

Ok, ich glaub ich hab vorher alles ausprobiert, was ich weiß, gesucht hab ich auch, was hilfreiches gefunden habe ich leider aber nicht.
Erstmal vielen Dank das es XAMPP auch für solaris gibt. Wir haben hier ein Solaris 9 und unter root läuft XAMPP auch wunderbar,
Jedoch soll nicht unter root, sondern unter einem Funktionsuser laufen. (Da der XAMPP für ein wiki benötigt wird, heißt dieser User wiki.)
In dessen home ist jetzt auch der xampp installiert. Beim starten des XAMPP stellt dieser auch korrekt fest, das XAMPP nicht als root gestartet wird
und versucht auf port 8080 zu gehen.

Code: Select all
bash-2.05$ xampp start
XAMPP is not installed at /opt/xampp. You choosed /export/home/wiki/xampp.
The configuration files needing to get adapted to this location.
XAMPP: Do you want me to continue? [yes] yes
Okay. Giving my best...
######################################################################################
Starting XAMPP for Solaris 0.8.1...
XAMPP: You are not root: Using port 8080 for Apache
XAMPP: Starting Apache...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: A MySQL daemon is already running.
XAMPP: Skipping XAMPP-ProFTPD (you need to be root to start ProFTPD).
XAMPP for Solaris started.

Der Apache kann jeodch nicht gestartet werden (Error 1).

Das ./logs/apachestart.log sagt:
Code: Select all
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[Danach hab ich auch gegoogeld, aber ich find nur die Empfehlung den Apache als root zu starten.]
Wenn ich die httpd.conf händisch ändere, also "Listen 80" auf "Listen 8080" umschriebe versucht Apache sich als nicht root auf 443 zu verbinden, warum auch immer.

Das ./logs/error_log sagt:
Code: Select all
[Sun Jan 08 12:51:17 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jan 08 12:51:17 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!
?
[Sun Jan 08 12:51:18 2006] [notice] suEXEC mechanism enabled (wrapper: /opt/xampp/bin/suexec)
[Sun Jan 08 12:51:24 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jan 08 12:51:24 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!
?
[Sun Jan 08 12:51:29 2006] [notice] Apache/2.2.0 (Unix) mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/5.1.1 configured
-- resuming normal operations
[Sun Jan 08 12:52:08 2006] [notice] caught SIGTERM, shutting down

Nein es läuft kein anderer Apache, Port 80 und 8080 sind frei.

Ich hoffe ich hab den Fall, so klar wie möglich dargelegt. Kann mir einer nen Tipp geben?

Vielen Dank!

Gruß Swoosh
swoosh777
 
Posts: 2
Joined: 21. July 2006 09:56

Postby swoosh777 » 21. July 2006 10:29

Also es geht jetzt. Anscheinend gab es unter dem fktusr Probleme mit ssl, was ich jetzt aus der httpd.conf auskommentiert hab. Nich schön, aber egal...
swoosh777
 
Posts: 2
Joined: 21. July 2006 09:56


Return to XAMPP für Solaris

Who is online

Users browsing this forum: No registered users and 0 guests