Error 1! Couldn't start Apache!

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

Error 1! Couldn't start Apache!

Postby phenix » 03. March 2004 11:20

why i cant start the Apache?? i'm the normal user not root.

the server already had installed apache, mysql, and php, etc...

please help.... :D

Thanks !!!
phenix
 
Posts: 3
Joined: 03. March 2004 11:12

Postby Kristian Marcroft » 03. March 2004 12:54

Hi,

could you please check what the error.log says?
Is Port 8080 maybe already in use?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Can't Startr Apache

Postby phenix » 04. March 2004 08:01

Hi,

there is no errors inside the error_log.
I'd change the port to others, but it still din't work..

I try to change the listening port in httpd.conf
and start the apache using
XAMPP_ROOT/bin/apachectl -k start
-f XAMPP_ROOT/etc/httpd.conf


then in the error_log >>
[warn] Init: PRNG still contains insufficient entropy!
[error] Init: Failed to generate temporary 512 bit RSA private key
Configuration Failed
phenix
 
Posts: 3
Joined: 03. March 2004 11:12

Postby Oswald » 04. March 2004 11:16

Dear phenix!

Did you changed something in the configuration files? httpd.conf or ssl.conf? The errors indicating a SSL problem. SSL should work but it's not tested well. Please call

XAMPP_ROOT/xampp stopssl

and then try to start XAMPP Apache again.

Please use always the XAMPP start script to start the XAMPP Apache:

XAMPP_ROOT/xampp startapache

A simple bin/apachectl will mostly fail.

Good luck
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby phenix » 05. March 2004 03:39

I din't change anything inside SSL.conf, but only change the listening port in httpd.conf

there is another version of Apache, PHP and MySQL running using ROOT account. so is it the problem?
phenix
 
Posts: 3
Joined: 03. March 2004 11:12

Postby Oswald » 05. March 2004 09:29

Dear Phenix!

Did you ever call .../xampp startssl?

In this case please call ../xampp stopssl to undo the above command.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Error 1! Couldn't start Apache!

Postby mimicol » 22. March 2006 23:03

EN:
I had the same problem.
It was due to an error in httpd.conf (a bad copy/paste which inserted a password in the middle of the httpd.conf)
Greetings , Michel
------
FR:
J'avais le même problème.
C'était dû à une erreur dans le httpd.conf (un mauvais copier/coller qui a inséré un mot de passe au milieu du httpd.conf)
Michel
----
DE:
Ich hatte dasselbe Problem.
Es war einen Fehler im httpd.conf (ein schlechtes zu kopieren/zu kleben, das ein Paswort in der Mitte des httpd.conf eingefügt hat)
Michel
mimicol
 
Posts: 5
Joined: 22. March 2006 18:23
Location: Paris - FRANCE

Re: Error 1! Couldn't start Apache!

Postby richbeck2 » 10. January 2010 01:31

Right,

Just wanted to add my 2 pence contribution to this brilliant project by explaining how I solved this exact problem!

In short: BLAME SKYPE (for me atleast).

You can start skype after Apache is running, but not before... if you start it before, it hogs the ports needed and you get error %%1 when trying to start the server.

Use Port-Check to make sure your ports are free from such programs then try starting apache again.

Hope this helps atleast one other person out, in which case it was worth posting :).
richbeck2
 
Posts: 1
Joined: 10. January 2010 01:27

Re: Error 1! Couldn't start Apache!

Postby chocoholic » 17. January 2011 16:52

Thanks richbeck2, My problem solved by the Skype trick!!!
chocoholic
 
Posts: 1
Joined: 17. January 2011 16:48


Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 1 guest