kein Zugriff mit ftp-prog

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Postby deepsurfer » 19. October 2005 15:11

Firewall des Linuxrechners den Port 21 freigeben
(gilt für beide debian und Suse, sobald X-Server Installiert wird um mit KDE/Gnome oder einem anderen GUI zu spielen)


checken, testen, melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby oliverw » 19. October 2005 16:28

ich meint schon die komplette ip 80.74.14x.xxx .

auf irgenwelche gui habe ich zum konfigurieren gar keinen zugriff, da es sich um einen webserver handelt, der bei einem provider steht, der ihn aber als blankes system ohne ftp,apache,DB etc. hingestellt hat.

wenn

ich von meinem PC aus

connecting to 80.74.14x.xxx:21
Connected to 80.74.14x.xxx port 21
220 ProFTPD 1.2.10 Server (ProFTPD) [80.74.14x.xxx]

bekomme, muss der port 21 doch offen sein, oder ?

wie wuerde ich die firewall bei einem debian "aus der box" denn konfigurieren ? ist das iptables ?
oliverw
 
Posts: 9
Joined: 04. August 2005 07:52

Postby deepsurfer » 20. October 2005 00:45

noch ein gegenfrage:
stimmen die pfade der user in der proftp conf ?
ich weiss jetzt nicht ob ProFTP trotzdem startet obwohl ein Pfad des User womöglich nicht existiert oder falsch geschrieben wurde.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 20. October 2005 02:22

So....etwas gegengetestet...

Debian Sarge 3.1 stable -NETINSTALL
habe den Kernel nicht gepatcht bzw. nicht neu kompiliert.
Installation nur für Netzwerkkarte sonst nix...

XAMPP draufgehauen und gestartet

- FileZilla Client
- FireFTP
- WS-FTPpro
- Browser FTP

alle male ging der Login einwandfrei.
Ich vermute noch das es an einer routing Auflösung hapert.
Meine damit das auf deinem Server etwas intern nicht aufgelöst werden kann.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby oliverw » 20. October 2005 07:31

danke fuer an ansatz.
ich probiere, beim provider etwas zu erreichen.
er hat das debian installiert und der server haengt natuerlich auch an dessen router.
oliverw
 
Posts: 9
Joined: 04. August 2005 07:52

Login incorrect

Postby rk1954m » 15. January 2007 22:25

Habe den gleichen Fehler bei mir auf der Kiste.

MacPro mit OS X 10.4.8

Xampp installiert und läuft prima. Alle Teilbereiche laufen, auch der ProFTPd. Nur einloggen kann ich mich auch nicht.

530 Login incorrect.

Egal womit ich es versuche.

Da ist doch was verbogen, denn es ist ein absolut "clean install"
rk1954m
 
Posts: 5
Joined: 15. January 2007 20:48

Postby jens_k » 22. January 2007 20:16

Hallo rk1954m,

hatte am Anfang auch das Problem und bin hier im Forum fündig geworden, weiss nur nicht mehr in welchem Thread...

Hast Du schon die Datei /Applications/xampp/etc/proftd.conf editiert?
Falls nicht, suche dort nach:
UserPass nobody XXXXXXXX
Füge darüber folgende Zeile ein:
RequireValidShell off

Ich weiss nicht mehr, ob anschliessend ein Neustart des ProFTP nötig wahr - Danach hat bei mir der Login gefunzt.

Greez,
Jens
jens_k
 
Posts: 11
Joined: 22. January 2007 15:41

Postby rk1954m » 23. January 2007 00:22

Ich habe mir von ProFTPd das File ftpasswd gezogen und ein passendes Passwort erstellt - seit dem geht es.

Vielseitiges kleines Programm!

Mit der Shell klingt logisch, da 'nobody' ja keine hat. Witzig ist dann aber, das das erstellen eines neuen 'korrekten' Passwortes das Problem beseitigt. Der 'Herr' hat ja immer noch keine eigene Shell, kann sich aber nun einloggen.

In meiner Wut habe ich zwischenzeitlich OS X Server 10.4 aufgesetzt, kann aber nicht auf xampp verzichten - es geht so vieles nicht auf Hieb und selber compilieren einer php4 mit allem drauf geht auch nicht. Dann läd er die libphp4.so nicht mehr. Entropy php5 geht.

So kann ich auf xampp nicht verzichten, denn das Paket läuft wesentlich runder...
rk1954m
 
Posts: 5
Joined: 15. January 2007 20:48

filezilla kann nicht in die xampp-Dateien

Postby ww-wupp » 14. May 2007 22:02

Hallo zusammen,
ich hab mich nun durch einige Foren durchgesucht, bin Linux-Anfänger und habe mir wegen php-Erstellen dringend empfehlen lassen, Xampp zu installieren. Auch in der Xampp-FAQ bin ich nicht nur nicht fündig geworden, sondern habe auch leider (vielleicht mangels Erfahrung?) keinen Anknüpfungspunkt für mein Problem gefunden.

Die gegenständlichen Programme: Xampp ist bei mir in der Version für Linux 1.6.1, (Paket stammt von http://www.apachefriends.org/download.p ... 6.1.tar.gz ) während mein Linux Suse 10.2 ist, mein Filezilla hat Version: 3.0.0-19.1. Meine Homepage kann ich mit diesem Filezilla problemlos erreichen, die Einstellungen für Xampp krieg ich damit aber bisher nicht hin. Allerdings habe ich den allerneuesten Update für Filezilla noch nicht runtergeladen.

Nun zu meinem eigentlichen Problem: Wenn ich z. B. als Server "localhost" eingebe, als Benutzername das standardmäßige "nobody", das von mir für ProFTPD neu genommene Passwort (das auch Sonderzeichen beinhaltet) und als Port "21" nehme, bekomme ich folgendes Protokoll:

Status: Auflösen der IP-Adresse für localhost
Status: Verbinden mit xxx.x.x.x:21...
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Antwort: 220 ProFTPD 1.3.0a Server (ProFTPD) [xxx.x.x.x]
Befehl: USER nobody
Antwort: 331 Password required for nobody.
Befehl: PASS ******
Antwort: 530 Login incorrect.
Fehler: Verbindung mit Server fehlgeschlagen

(die (?)IP-Zahlen habe ich durch "x" ersetzt, wobei ich von der Windows-Partition desselben Rechners aus andere Zahlen als IP angezeigt bekam.)

Ich habe noch etliche weitere Varianten bei Filezilla durchprobiert, die aber alle ebenfalls nicht geklappt haben. D. h. ich habe auch "lampp" als Benutzernamen versucht, diverse Varianten mit htdocs und auch nacheinander alle von mir gewählten Passworte für die übrigen Xampp-Bereiche genommen.

Leider verstehe ich noch nicht die Kurzformen der in manchen Forumsantworten genannten Befehlscodes, noch kann ich ausschließen, ob die Linux-Firewall anders konfiguriert werden müsste. Allerdings habe ich, wie angedeutet, kein Problem mit dem Up- und Downloaden von und auf die eigene Homepage. Für diese letztere Konfiguration habe ich aber die konkreten Daten vorliegen.

Ich versuche, Filezilla für Xampp zu aktivieren, weil ich Joomla in die Xampp-Dateien herüberladen möchte, da ich unsere Internetseite teilweise mit php verbessern möchte.

Nun hoffe ich, dass ich alle für die Diagnose wichtigen Details beisammen habe und deutlich machen konnte, dass ich selbst schon so einiges versucht habe, bevor ich - obwohl Anfänger - diese Frage poste.

Bitte um Hinweise, wie ich an diesem Punkt weiterkommen könnte.

LG

ww-wupp
ww-wupp
 
Posts: 3
Joined: 14. May 2007 21:11

Postby ww-wupp » 15. May 2007 09:15

Hallo zusammen,
die gestrige Frage habe ich nun endlich selbst lösen können: Filezilla klappt hierbei nur, wenn ich KEIN Passwort eingebe. Dann läuft aber alles viel zu langsam, und den Accelerator kann ich nach der Gebrauchsanweisung nicht einschalten, weil ich regelmäßig beim Abspeichern von /opt/lampp/etc/ini.php die Mitteilung bekomme, dass ich entweder kein Zugriffsrecht habe oder kein Speicherplatz vorhanden ist. Ich vermute, dass ich in dem Vorgang irgendwie ein Terminal zur Eingabe des Passworts (welches dann aber?) einbauen müsste ...

Bitte um einen Link, wo ich hier weiterkommen könnte!

LG

ww-wupp
ww-wupp
 
Posts: 3
Joined: 14. May 2007 21:11

Postby ww-wupp » 23. May 2007 09:04

Hallo zusammen,
Inzwischen habe ich mir selbst weiterhelfen können, musste allerdings xampp vorher komplett entfernen. Nun klappt Filezilla, wenn ich das Passwort für ProFTPD eingebe. Anscheinend werden die Passworte nicht konsequent in den installierten Skripts der gegenwärtigen Version umgesetzt. Dann lief aber alles weiterhin viel zu langsam, obwohl ich den Accelerator durch entsprechende chmod - Befehle aus der Konsole nach der Gebrauchsanweisung einschalten konnte. Nach ebensolchen chmod - Eingaben konnte ich dann direkt aus dem Download-File Joomla in den Xampp-Ordner bekommen. Allerdings ist die dortige abschließende Anweisung für mich irreführend gewesen: Das Joomla-System funktioniert erst, nachdem der Ordner "installation" mit allen Dateien und Unterordnern entfernt ist, ich hatte jedoch verstanden, ich müsste die Download-Datei entfernen und entfernte danach beim ersten Mal den Ordner, in den ich Joomla zuerst entpackt hatte und dann auch noch die gesamte Installation über einen Konsolenbefehl (in der Annahme, es müsste alles aus dem Web neu geladen werden und dass das aus dem verbliebenen Link ginge(':lol:'), wonach dann natürlich alles weg war. Im 2. Anlauf hats dann aber wie beschrieben geklappt, vielleicht hilft dies ja anderen...

Gar nicht geklappt hat allerdings das Ausräumen der letzten Sicherheitslücke, die Anweisungen auf den empfohlenen Links klappen bei mir nur für die vorletzte Sicherheitslücke. Ich bekomme also weiterhin die Meldung " PHP register_globals setting is `ON` instead of `OFF` "Da muss ich wohl auf den richtigen Update im dortigen Forum warten.

LG

ww-wupp
ww-wupp
 
Posts: 3
Joined: 14. May 2007 21:11

Previous

Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 0 guests