proFTP - user?

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

proFTP - user?

Postby reggler » 16. June 2005 09:28

Hallo zusammen,

ich habe xampp auf meiner Suse-Kiste laufen und möchte nun
einen FTP-Account einrichten in dem ein User ("NewUser") nur auf ein
bestimmtes Verzeichnis in htdocs ("/NewUser") zugreiffen kann.
Wie stell' ich das an, ich hab' die proftpd.conf mal angeschaut, kann mir
aber nicht wirklich helfen. :roll: Ich hoffe ihr könnt mir helfen. herzlichen Dank! :lol:
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby PF4 » 16. June 2005 09:40

http://community.apachefriends.org/f/viewtopic.php?t=8935

Die SuFu muss wohl defekt sein sonst hääte man das in 10 Sekunden gefunden! :roll:
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby reggler » 20. June 2005 19:23

PF4 wrote:http://community.apachefriends.org/f/viewtopic.php?t=8935

Die SuFu muss wohl defekt sein sonst hääte man das in 10 Sekunden gefunden! :roll:


Okay *nachgekukt*:
folgendes:
reggler wrote:
deepsurfer wrote:Ok... zur Ergänzung, da es scheinbar sehr viele unterschide gibt.

Meine "adduser" Anweisung stammt aus REDHAT 9.1
Da ich nun hier noch ein DEBIA-Sarge laufen habe schaue ich natürlich nach.

Für all die anderen die mit Linux anfangen.
In einer Konsole hat man mehrere möglichkeiten.
Wenn alle Manuals installiert sind kann man oftmals mit
"man adduser" etwas erfahren, sollte Manuals nicht vorhanden sein, dann einfach mal "adduser --help".
[snip]

Bei SuSE 9.3 standart Install gibs es den useradd
useradd -d /opt/lampp/htdocs/NAME -p passwort -s /bon/false NAME
Mit dieser Eingabe wird auch direkt das Passwort mit eingetragen.

Was soll denn das jetzt:

server:~ # useradd -d /opt/lampp/htdocs/Marc -p ***** -s /bin/false Marc
useradd: invalid user name 'Marc'

hab' auch versucht mit der man-page was rauszufinden, ich seh' den Fehler aber nicht, müsste dochfunktionieren...:(
übrigens, ich benutze Suse 8.0...
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby Kristian Marcroft » 21. June 2005 11:24

Hi,

versuchs mal mit "marc" und nicht "Marc"

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby reggler » 21. June 2005 17:21

Kristian Marcroft wrote:Hi,

versuchs mal mit "marc" und nicht "Marc"

So long
KriS


yup, genau das wars. Aber jetzt bitte nur noch in dem Thread schreiben:
http://community.apachefriends.org/f/viewtopi ... 2483#52483
Dann lassen wir diesen sterben. Danke :)
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby Refreshed » 22. September 2005 20:58

Hi, hab nen Problem!

Habe alles so gemacht wie oben und im anderen Thread beschrieben aber trotzdem kommt:
SmartFTP v1.5.990.2
Resolving host name "192.168.0.35"
Connecting to 192.168.0.35 Port: 21
Connected to 192.168.0.35.
220 ProFTPD 1.2.10 Server (FTP) [192.168.0.35]
USER admin
331 Password required for admin.
PASS (hidden)
530 Login incorrect.
Server closed connection
Cannot login waiting to retry (30s)...


Was kann ich dagegen machen?

Ich benutze SuSE 9.3 Prof.

edit:

Peinlich peinlich: Hab vergessen den Ordner anzulegen
:oops: ... sry leute habe erst seit zwei Tagen Xampp auf Linux laufen.... hatte es sonst immer auf Windoof...
Refreshed
 
Posts: 25
Joined: 27. March 2004 11:52


Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 0 guests