FTP Zugriffsrechte!

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Postby jsb » 19. April 2005 18:00

Ich habe hier ein ähnliches Problem
deepsurfer wrote:Lassen wir das und geben stattdessen direkt
Code: Select all
adduser NAME -d /opt/lampp/htdocs/NAME -s /bin/false


ein, dann steht der User direkt richtig im pfad via FTP und hat aber keine Berechtigung über ein SHELL auf dein System zu kommen

den befehl zur passwd NAME (passwort setzen) muss du noch machen.
Es gibt laut anleitung von adduser den Flag -p test123 , aber der hat bei mir nicht funktioniert von daher lieber local gegentesten.

chirio
Deep


Da ich die Benutzer nur für den FTP Zugang brauche wolte ich wie oben beschrieben einen anlegen (unter Suse 8.2) und erhielt folgende Meldung
# adduser NAME -d /opt/lampp/htdocs/NAME -s /bin/false
bash: adduser: command not found
www:/ #


Könnte mal eine genaue Schritt für Schritt Anleitung für das erstellen/einrichten verschiedener Benutzer nur für ProFTPD hier gegeben werden? Durch die vielen verschiedenen Angaben hier blicke ich garnicht mehr durch.
Last edited by jsb on 19. April 2005 18:35, edited 1 time in total.
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby Jan H. Krüger » 19. April 2005 18:20

Moin,

probiere mal useradd.
adduser ist auf manchen Systemen eingerichtet, aber nicht zwingend.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby jsb » 19. April 2005 18:33

Jan H. Krüger wrote:Moin,

probiere mal useradd.
adduser ist auf manchen Systemen eingerichtet, aber nicht zwingend.



ergibt ebenfalls die Meldung command not found
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby mton1964 » 04. May 2005 08:45

deepsurfer wrote:zu frage 1 = ja
frage 2 = in linuxkonsole mit root rechten den befehl adduser benutzen.

dann mit

Code: Select all
 passwd NAME


dem user ein passwort geben.
Im normalfall hat nun dieser User das Verzeichniss /home/NAME zum login, damit dieser aber im lampp/htdocs/NAME landet müsstest du die passwd editieren.

Lassen wir das und geben stattdessen direkt
Code: Select all
adduser NAME -d /opt/lampp/htdocs/NAME -s /bin/false

ein, dann steht der User direkt richtig im pfad via FTP und hat aber keine Berechtigung über ein SHELL auf dein System zu kommen

den befehl zur passwd NAME (passwort setzen) muss du noch machen.
Es gibt laut anleitung von adduser den Flag -p test123 , aber der hat bei mir nicht funktioniert von daher lieber local gegentesten.

chirio
Deep



Hallo !
die Thematik dieses Beitrages betrifft gerade mein Anliegen ,

ich bekomme jedoch nach dieser Eingabe
Code: Select all
 adduser NAME -d /opt/lampp/htdocs/NAME -s /bin/false


folgende Fehlermeldung :
' -> No more than two names <- '

was mache ich bei der Eingabe falsch ?

System : debian

Danke und beste Grüsse

Marco
mton1964
 
Posts: 2
Joined: 20. April 2005 11:21

Postby PF4 » 04. May 2005 10:33

Hi,

also laut den Gentoo-adduser-manpages muss der Name ans Ende.
Denke das verhält sich auf debian nicht anderst.
Generell gibt immer:
programm [parameter] befehl
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby deepsurfer » 04. May 2005 13:21

Ok... zur Ergänzung, da es scheinbar sehr viele unterschiede gibt.

Meine "adduser" Anweisung stammt aus REDHAT 9.1
Da ich nun hier noch ein DEBIA-Sarge laufen habe schaue ich natürlich nach.

Für all die anderen die mit Linux anfangen.
In einer Konsole hat man mehrere möglichkeiten.
Wenn alle Manuals installiert sind kann man oftmals mit
"man adduser" etwas erfahren, sollte Manuals nicht vorhanden sein, dann einfach mal "adduser --help".


Bei RedHAT 9.1 (Mittlerweile bekannt als Fedora Core)
adduser NAME -d /opt/lampp/htdocs/NAME -s /bin/false
danach noch passwd NAME um Passwort zu setzen

Bei DeBian-Sarge
adduser --home /opt/lampp/htdocs/NAME --shell /bin/false NAME
es wird dann direkt zur Passwort eingabe geleitet

Bei DeBian-Sarge gibt es auch den useradd
useradd -d /opt/lampp/htdocs/NAME -s /bin/false NAME
danach noch passwd NAME für passwort vergabe

Bei SuSE 9.3 standard Install gibs es den useradd
useradd -d /opt/lampp/htdocs/NAME -p passwort -s /bin/false NAME
Mit dieser Eingabe wird auch direkt das Passwort mit eingetragen.
Last edited by deepsurfer on 02. March 2006 19:21, edited 3 times in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby reggler » 18. June 2005 09:13

deepsurfer wrote:Ok... zur Ergänzung, da es scheinbar sehr viele unterschide gibt.

Meine "adduser" Anweisung stammt aus REDHAT 9.1
Da ich nun hier noch ein DEBIA-Sarge laufen habe schaue ich natürlich nach.

Für all die anderen die mit Linux anfangen.
In einer Konsole hat man mehrere möglichkeiten.
Wenn alle Manuals installiert sind kann man oftmals mit
"man adduser" etwas erfahren, sollte Manuals nicht vorhanden sein, dann einfach mal "adduser --help".
[snip]

Bei SuSE 9.3 standart Install gibs es den useradd
useradd -d /opt/lampp/htdocs/NAME -p passwort -s /bon/false NAME
Mit dieser Eingabe wird auch direkt das Passwort mit eingetragen.

Was soll denn das jetzt:

server:~ # useradd -d /opt/lampp/htdocs/Marc -p ***** -s /bin/false Marc
useradd: invalid user name 'Marc'

hab' auch versucht mit der man-page was rauszufinden, ich seh' den Fehler aber nicht, müsste dochfunktionieren...:(
übrigens, ich benutze Suse 8.0...
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby reggler » 20. June 2005 19:22

reggler wrote:
deepsurfer wrote:Ok... zur Ergänzung, da es scheinbar sehr viele unterschide gibt.

Meine "adduser" Anweisung stammt aus REDHAT 9.1
Da ich nun hier noch ein DEBIA-Sarge laufen habe schaue ich natürlich nach.

Für all die anderen die mit Linux anfangen.
In einer Konsole hat man mehrere möglichkeiten.
Wenn alle Manuals installiert sind kann man oftmals mit
"man adduser" etwas erfahren, sollte Manuals nicht vorhanden sein, dann einfach mal "adduser --help".
[snip]

Bei SuSE 9.3 standart Install gibs es den useradd
useradd -d /opt/lampp/htdocs/NAME -p passwort -s /bon/false NAME
Mit dieser Eingabe wird auch direkt das Passwort mit eingetragen.

Was soll denn das jetzt:

server:~ # useradd -d /opt/lampp/htdocs/Marc -p ***** -s /bin/false Marc
useradd: invalid user name 'Marc'

hab' auch versucht mit der man-page was rauszufinden, ich seh' den Fehler aber nicht, müsste dochfunktionieren...:(
übrigens, ich benutze Suse 8.0...


Kann, oder will, mir niemand mehr helfen? :(
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby deepsurfer » 20. June 2005 19:55

Kann, oder will, mir niemand mehr helfen?


Wollen schon, aber hab hier kein SuSE 8.x auf der platte rumfliegen.

wie schaut es denn aus wenn du " man useradd " oder " man adduser " in der Konsole eingibst ?
In einen von beiden fällen müsstest du eine Auflistung der Befehle erhalten.
Darin sind auch die zusammenhänge ablesbar wie der komplette Befehl bei SuSE 8.x lauten kann.

Ich weiss das hast du schon getan, aber vielleicht sahst du vor lauter Bäumen den Wald grad nicht.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby reggler » 20. June 2005 20:03

deepsurfer wrote:
Kann, oder will, mir niemand mehr helfen?


Wollen schon, aber hab hier kein SuSE 8.x auf der platte rumfliegen.

wie schaut es denn aus wenn du " man useradd " oder " man adduser " in der Konsole eingibst ?
In einen von beiden fällen müsstest du eine Auflistung der Befehle erhalten.
Darin sind auch die zusammenhänge ablesbar wie der komplette Befehl bei SuSE 8.x lauten kann.

Ich weiss das hast du schon getan, aber vielleicht sahst du vor lauter Bäumen den Wald grad nicht.


yup, das ist der header von man useradd:
Code: Select all

SYNOPSIS
       useradd [-c comment] [-d home_dir]
               [-e expire_date] [-f inactive_time]
               [-g initial_group] [-G group[,...]]
               [-m [-k skeleton_dir]] [-o] [-p passwd]
               [-s shell] [-u uid] login

       useradd -D [-g default_group] [-b default_home]
               [-e default_expire_date] [-f default_inactive]
               [-s default_shell]


aber wie oben beschrieben, versuch' ichs anzuwenden aaaaber... :(


server:~ # useradd -d /opt/lampp/htdocs/Marc -p marc -s /bin/false Marc
useradd: invalid user name 'Marc'
server:~ #
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby deepsurfer » 21. June 2005 16:00

mach mal zuerst
Code: Select all
mkdir /opt/lampp/htdocs/Marc

danach noch
Code: Select all
chown nobody.root /opt/lampp/htdocs/Marc


und dann den " useradd "

eventuell mal das " -p marc " wegglassen.
Hatte ich mal beschrieben das dieser flag bekannt sei aber nicht angenommen.

Wenn es ohne " -p marc " funktioniert, dann musst du nachher noch
Code: Select all
passwd Marc

durchführen um ein PW zu setzen.


Ansonsten durch den Doppelpost verursachten Mischmasch:
http://community.apachefriends.org/f/viewtopi ... 2462#52462
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby reggler » 21. June 2005 17:19

deepsurfer wrote:Ansonsten durch den Doppelpost verursachten Mischmasch:
http://community.apachefriends.org/f/viewtopi ... 2462#52462

genau so musste ichs machen, dann hats funktioniert. Jetzt noch folgendes:
Ich kann mit dem user marc sauber einloggen und komm' sauber ins Dir '/htdocs/Marc', aber ich kann dann mit Verzeichniss aufwärts die anderen auch sehen. Wie beschränk ich den user marc jetzt aufs dir '/htdocs/Marc'?
Danke!
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby Kristian Marcroft » 21. June 2005 19:32

Hi,

in der proftpd.conf DefaultRoot ändern von:

DefaultRoot /opt/lampp/htdocs
auf
DefaultRoot ~

Speichern, neustarten fertig.
~ (Tilde) bedeutet, das jeder User in sein Homedir kommt wenn er sich einlogged.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby reggler » 21. June 2005 19:50

Kristian Marcroft wrote:Hi,

in der proftpd.conf DefaultRoot ändern von:

DefaultRoot /opt/lampp/htdocs
auf
DefaultRoot ~

Speichern, neustarten fertig.
~ (Tilde) bedeutet, das jeder User in sein Homedir kommt wenn er sich einlogged.

So long
KriS


ok, scheint zu funktionieren aber jetzt muss ich noch ein neuer ftp-admin-account anlegen der wiederum die ganzen htdocs verwalten kann?
=====roN=====
:) kEEp on rockin'
reggler
 
Posts: 16
Joined: 16. May 2005 19:23
Location: CH

Postby Kristian Marcroft » 21. June 2005 19:59

Hi,

normallerweise gibt es sowas nicht.
Ein Admin verwaltet einen Server auf der console.
Aber du kannst versuchen einen User anzulegen, dessen HomeDir /opt/lampp/htdocs ist.
Achtung! Dateien die Du anlegst, können von anderen nicht verändert werden. Heirzu muss die umask noch geändert werden. Und jeweils die entsprechenden Benutzer UND Gruppenrechte erfasst sein.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

PreviousNext

Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 1 guest

cron