Vorbildliche Vhost Einträge

Einfach Dinge, die nichts mit XAMPP, Apache Friends, Apache, MySQL, PHP und alle dem zu tun haben. Allerlei halt. ;)

Postby Mario Lanz » 23. March 2005 21:56

Hallo....

Versuche nun schon ein paar Tagen V-Hosts zu erstellen!!!:

Hier der Code im httpd.conf:

Code: Select all
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
<VirtualHost *:80>

   ServerName www.alfarumore.com
   Serveradmin homepage@lanz-mario.com
   DocumentRoot J:/apachefriends/xampp/htdocs/Alfa/
</VirtualHost>


habe auch unter C:/windows/system32/drivers/etc/ die host datei angepasst:
Code: Select all
# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
62.2.80.202     www.lanz-mario.com
62.2.80.202     www.alfarumore.com
62.2.80.202     www.tulanz.com


Was stimmt denn hier nicht?

Vielen Dank für die Hilfe...

Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby mättu » 24. March 2005 07:21

Ciao Mario

Bei mir siehts so aus unf funzt:

httpd.conf:
Für jeden VHost erstellst du einen solchen Block:
Code: Select all
NameVirtualHost 127.0.0.1:80
<VirtualHost 127.0.0.1:80>
   ServerAdmin admin@localhost
   DocumentRoot "C:/irgendwo/"
   ServerName localhost
   <directory C:/irgendwo>
      AllowOverride All
   </directory>
</VirtualHost>

Das hier ist das Beispiel von localhost, das du auch definieren musst.
Lass alle Vhosts auf 127.0.0.1:80 und pass nur "DocumentRoot", "Servername" und "Directory" an. (Wenn du magst noch den "ServerAdmin".
Gibt für dich 4 solche Blöcke.

im "host" sieht es dann so aus:
Code: Select all
127.0.0.1       localhost
127.0.0.1       www.lanz-mario.com
127.0.0.1   www.alfarumore.com
127.0.0.1   www.tulanz.com


Natürlich ist das alles für den lokalen Gebrauch. Im "richtigen" Internet würde ich die Sites nicht selber hosten, wenn du mit solch "einfachen" Problemen kämpfst. (Bitte verzeih die Frechheit, zähle mich auch in diese Kategorie) ;-)

Grüsse
m.
mättu
 
Posts: 9
Joined: 01. January 2005 15:04

Postby Mario Lanz » 24. March 2005 08:37

Hallo mättu....

Vielen Dank....

tja, ich hab halt einen eigenen Server....

und um etwas zu lernen, was man vorher noch nie gebraucht hat, muss man halt ab und zu blöde fragen sellen....
Code: Select all
NameVirtualHost 127.0.0.1:80
<VirtualHost 127.0.0.1:80>
   ServerAdmin admin@localhost
   DocumentRoot "C:/irgendwo/"
   ServerName localhost
   <directory C:/irgendwo>
      AllowOverride All
   </directory>
</VirtualHost>


anstatt der 127.0.0.1 (localhost) kann ich dann doch meine IP einfügen, oder?
aha, das directory fehlt.... hoffe, dass es nur an dem liegt....
was bedeutet AllowOverride All, was erlaube ich damit, zu überschreiben?

Danke und Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby deepsurfer » 24. March 2005 09:30

Code: Select all
#
# "AllowOverride" legt fest, welche Anweisungen von der Datei .htaccess überschrieben
# werden dürfen. Das kann "All" sein oder "None", oder irgendeine Kombination aus:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride None


in deinem Fall bedeutet das, das du mit dem VHOST eintrag einer möglichen -htaccess datei erlaubst etwas zutun.
Wenn du auf none schaltest, so wird keine .htaccess vorgabe innerhalb des VHOST erlaubt
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mario Lanz » 24. March 2005 12:41

man, es will einfach nicht gehen.....

jetzt habe ich genau diese codes so eingetragen, wie ich es hier sehen kann!!!!
Es will nicht...

Hier die codes:
Code: Select all
NameVirtualHost 62.2.80.202:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
<VirtualHost 62.2.80.202:80>
   ServerName www.lanz-mario.com
   Serveradmin homepage@lanz-mario.com
   DocumentRoot "J:/apachefriends/xampp/htdocs/"
   <directory J:/apachefriends/xampp/htdocs/>
      AllowOverride All
   </directory>
</VirtualHost>


<VirtualHost 62.2.80.202:80>
   ServerName www.alfarumore.com
   Serveradmin homepage@lanz-mario.com
   DocumentRoot "J:/apachefriends/xampp/htdocs/Alfa/"
   <directory J:/apachefriends/xampp/htdocs/Alfa/>
      AllowOverride All
   </directory>
</VirtualHost>

<VirtualHost 62.2.80.202:80>
   ServerName www.tulanz.com
   Serveradmin homepage@lanz-mario.com
   DocumentRoot "J:/apachefriends/xampp/htdocs/Alfa/me/"
   <directory J:/apachefriends/xampp/htdocs/Alfa/me/>
      AllowOverride All
   </directory>
</VirtualHost>

# Win32DisableAcceptEx ON


und bei host:
Code: Select all
127.0.0.1       localhost
62.2.80.202     www.lanz-mario.com
62.2.80.202     www.alfarumore.com
62.2.80.202     www.tulanz.com


komm jetzt echt nicht mehr nach....

Was mache ich falsch?

Wäre cool, könnte ich das noch vor Oster klären....
(ist praktisch unmöglich, habe ja in 2h schon Ostern und dann gehts nicht mehr nach hause bis Samstag abend....)

Aber schon mal vielen Dank für die Hilfe...

Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Wiedmann » 24. March 2005 13:11

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName www.lanz-mario.com:80
    Serveradmin homepage@lanz-mario.com
    DocumentRoot "J:/apachefriends/xampp/htdocs"
    <Directory "J:/apachefriends/xampp/htdocs">
        Order allow,deny
        Allow from All
        AllowOverride All
    </directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName www.alfarumore.com:80
    Serveradmin homepage@lanz-mario.com
    DocumentRoot "J:/apachefriends/xampp/htdocs/Alfa"
    <Directory "J:/apachefriends/xampp/htdocs/Alfa">
        Order allow,deny
        Allow from All
        AllowOverride All
   </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName www.tulanz.com:80
    Serveradmin homepage@lanz-mario.com
    DocumentRoot "J:/apachefriends/xampp/htdocs/Alfa/me"
    <Directory "J:/apachefriends/xampp/htdocs/Alfa/me">
        Order allow,deny
        Allow from All
        AllowOverride All
    </Directory>
</VirtualHost>


Die IP "62.2.80.202" ist die IP von der NIV im Server oder die WAN-IP vom Router? (Muss jedenfalls die IP von der Server-NIC sein.)

Das Laufwerk "J:" ist ein physikalisches, oder ein Netzwerkmapping? (Laufwerksbuchstaben sollte man nur nehmen, wenn es sich um physikalische Laufwerke handelt)


Nicht vergessen die "ssl.conf" auch anzupassen... (oder du schaltest es ab, wenn du es nicht brauchst)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Mario Lanz » 24. March 2005 13:56

WAN IP

NIC ist die, die ich vom Router zugeteilt bekomme!!!!

das ist eine 2.te hd...

sorry, muss gehen...

schöne Ostern.!!!!

Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby jsb » 11. April 2005 22:29

Ich klinke mich hier mal ein da ich ein ähnliches prob habe.
Zwar handelt es sich hier um einen internen Webserver für test und entwicklung von sites.
in der httpd.conf steht
<VirtualHost *:80>
ServerName localhost:80
DocumentRoot "m:/xampp/htdocs"
<Directory "m:/xampp//htdocs">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.linux.js:80
DocumentRoot "m:/xampp/htdocs/linux"
<Directory m:/xampp/htdocs/linux>
AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.farbigo.js:80
DocumentRoot "m:/xampp/htdocs/farbigo"
<Directory m:/xampp/htdocs/farbigo>
AllowOverride All
</Directory>
</VirtualHost>

in hosts
127.0.0.1 localhost
127.0.0.1 www.linux.js
127.0.0.1 www.farbigo.js
192.168.0.2 www.linux.js
192.168.0.2 www.farbigo.js


Damit sollte im Browser ja bei Aufruf von -www.linux.js- die entsprechende Startseite zu sehen sein. hurra das klappt :)
nur beim Aufruf von -www.farbigo.js sehe ich leider ebenfalls die Startseite von linux.
das Laufwerk M ist eine HDD in dem Rechner auf dem xampp läuft.

Sicher ist es nur ein kleiner Fehler meinerseits wäre schön wenn mir hier geholfen wird.
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby Wiedmann » 11. April 2005 22:46

entweder diese Zwei:
Code: Select all
127.0.0.1 www.linux.js
127.0.0.1 www.farbigo.js

oder diese Zwei:
Code: Select all
192.168.0.2 www.linux.js
192.168.0.2 www.farbigo.js

solltest du löschen
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jsb » 11. April 2005 23:14

Danke Danke ja es funktioniert. bin HAPPY
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby jsb » 16. April 2005 13:40

ich habe nun das gleiche auf einem Linux-Rechner versucht.
Dieser läuft unter Suse 8.2 Prof. (Ist so nen altes Teil was nix neues mehr kann)

Dort habe ich folgende Probleme.
1.
nach dem einrichten der Vhosts funktioniert der Aufruf von phpmyadmin nicht mehr.Ich erhalte eine Error 404 Seite.
Bei der Installation unter Win2000 s.oben klappt das.
Was muß ich bei Linux anders machen als bei der Install unter Win?
Die Lösung hierzu habe ich in einer weiteren Antwort beschrieben.
2.
bei /opt/lampp/lampp stop erhalte ich folgende Meldungen
[Fri Apr 15 00:14:34 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVir tualHost address is not supported, proceeding with undefined results
[Fri Apr 15 00:14:35 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVir tualHost address is not supported, proceeding with undefined results
[Fri Apr 15 00:14:35 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVir tualHost address is not supported, proceeding with undefined results
[Fri Apr 15 00:14:35 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVir


Den Punkt 2 habe ich gelöst bei NameVitualHost stand
NameVitualHost *
dies mußte in
NameVitualHost *:80
geändert werden.
------
die hosts Datei enthält folgende einträge. wobei mich der letzte irritiert, da dadurch die IP 127.0.0.1 zweimal vorkommt.

127.0.0.1 localhost
192.168.0.4 www.linux.js
192.168.0.4 www.farbigo.js
192.168.0.4 www.bei-juergen.js

# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback

fe00::0 ipv6-localnet

ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts

127.0.0.2 keywest.gay keywest
127.0.0.1 www # added by Apache Friends XAMPP

Woran liegt das? Wo hab ich noch was falsch gemacht?

Jetzt wundert mich nur noch die Zeile die von XAMPP in die Hosts eingefügt wurde. Seit dem kommt auch in der konsole immer @www statt wie vorher der Rechnername keywest
Last edited by jsb on 19. April 2005 18:15, edited 1 time in total.
User avatar
jsb
 
Posts: 38
Joined: 26. March 2004 13:50
Location: Berlin

Postby micindustries » 17. April 2005 03:40

moin. ich hab jetzt seit ungefähr 4h in diesem forum gelesen, aber ich werde aus den VHosts nicht ganz schlau. ich will einen LAN-Party-Server aufbauen, der über www.mickla.de bzw. www.mickla.forum.de o.ä. angesprochen werden kann.

momentan sieht mein VHost bereich so aus:

Code: Select all
#<VirtualHost *>
#    ServerAdmin webmaster@dummy-host.example.com
#    DocumentRoot /www/docs/dummy-host.example.com
#    ServerName dummy-host.example.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>

NameVirtualHost 192.168.0.6

<VirtualHost 192.168.0.6:80>
   ServerAdmin micindustries@msn.com
   ServerName mickla.forum.de
   DocumentRoot /opt/lampp/htdocs/forum/
</VirtualHost>


ich steig bei dem zeug noch net so ganz durch :oops:


/edit: hab grad gemerkt, dass wenn ich direkt über die server-IP gehe, er den foren-pfad als default verwendet, sprich er öffnet sofort das forum wie im VHost angegeben. er soll das aber nur dann direkt öffnen, wenn ich mickla.forum.de im browser eintippe

außerdem kann ich net auf meinen FTP zugreifen. er ist aktiviert und ich hab ein neues kennwort gesetzt, trotzdem kann ich net connecten. er fragt dann immer wieder nach benutzername / kennwort, obwohl ich beides korrekt getippt hab *grml*

danke im vorraus
micindustries
 
Posts: 15
Joined: 17. April 2005 03:34

Postby Jan H. Krüger » 17. April 2005 06:52

@micindustries
Bedenke das der erste VHost-Container immer benutzt wird um alle Abfragen zu behandeln welche in keinem der nachfolgenden VHost-Container definiert werden. Steht ein paar Zeilen drüber.

Um die beiden von dir genannten Möglichkeiten zu bieten, www.mickla.de und forum.mickla.de, sind folgende Einträge in der /opt/lampp/etc/httpd.conf nötig:

Bei NameVirtualHost folgender Eintrag:
Code: Select all
NameVirtualHost *:80


Code: Select all
<VirtualHost *:80>
    ServerName  forum.mickla.de:80
    DocumentRoot "/htdocs/software/forum"
   <Directory "/htdocs/software/forum">
      AllowOverride None
      Options ExecCGI
   </Directory>
    ErrorLog logs/forum.mickla.de-error_log
    CustomLog logs/forum.mickla.de-access_log common
</VirtualHost>

Denke daran DocumentRoot und Directory an deine eigenen Pfade anzupassen.

Code: Select all
<VirtualHost *:80>
    ServerName www.mickla.de:80
    DocumentRoot "/htdocs"
   <Directory "/htdocs/">
      AllowOverride None
      Options ExecCGI
   </Directory>
    ErrorLog logs/www.mickla.de-error_log
    CustomLog logs/www.mickla.de-access_log common
</VirtualHost>

Auch hier die Pfade anpassen nicht vergessen.

Danach sind noch zwei Änderungen in der /etc/hosts-Daten zu tätigen:
Code: Select all
127.0.0.1 forum.mickla.de
127.0.0.1 www.mickla.de
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby micindustries » 17. April 2005 12:27

Danach sind noch zwei Änderungen in der /etc/hosts-Daten zu tätigen:
Code: Select all
127.0.0.1 forum.mickla.de
127.0.0.1 www.mickla.de


ich habe keine datei die so heißt. muss ich die erst erstellen, oder hab ich da was beim installieren falsch gemacht?

vielen dank für die hilfe :)

/edit: hab die datei gefunden, das nächste mal werde ich ERST die suchfunktion von linux und DANN das forum benutzen ;)

für alle anderen die noch am suchen sind: wurzelverzeichnis/etc/hosts (zumindest bei suse 8.2)
micindustries
 
Posts: 15
Joined: 17. April 2005 03:34

Postby micindustries » 17. April 2005 13:09

ok, jetzt glaub ich wirklich dass ichs nemme raff ^^ hab alles wie oben beschrieben eingefügt, aber jetzt erreich ich den server garnicht mehr. weder direkt über die IP (da kommt dann "You don't have permission to access / on this server.") noch über eine der adressen (server nicht gefunden)

hab nem kumpel die adressen auch übers netz gegeben, er bekommt die selben fehlermeldungen (auch den permission-error über meine dyn-ip-adresse)

hab jetzt einige sachen probiert, zb. statt der *:80 in den VHosts die server-IP eingetragen und statt 127.0.0.1 in der hosts ebenfalls die server-IP

bei ienem neustart von xampp zeigt er auch keine fehler in der hosts oder httpd.conf an
micindustries
 
Posts: 15
Joined: 17. April 2005 03:34

PreviousNext

Return to Allerlei

Who is online

Users browsing this forum: No registered users and 1 guest