Xammp on 'Skolelinux' based on Debian - Syntax error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Xammp on 'Skolelinux' based on Debian - Syntax error

Postby Esos » 16. September 2004 11:32

I have installed a versjon of Skolelinux (http://www.skolelinux.org/portal/index_html) with the profile for workstation. The install of Xampp 1.4.7 completed without errors, but when I start the Xampp with the command:

'/opt/lampp/lampp start'

the root-konsoll responsed with

'/opt/lampp/lampp: 10: Syntax error: "(" unexpected'

Ref:
#4:# For RedHat (thanks to Sudhaker Raj):

#10:function testport() {
#11: if netstat -an | egrep ":$1 .*LISTEN" > /dev/null
#12: then
#13: return 0
#14: else
#15: return 1
#16: fi
#17:}

I gess line 4 is the essensial here, but how can I solve this?

By the way, this is my first linux-installation ever!

Espen
Esos
 
Posts: 3
Joined: 16. September 2004 08:57
Location: Bergen, Norway

Re: Xammp on 'Skolelinux' based on Debian - Syntax error

Postby dcr » 04. November 2011 01:30

take out the function ketword

so this
#10:function testport() {
to this:
#10:testport() {
dcr
 
Posts: 1
Joined: 04. November 2011 01:28
XAMPP Version: 5.6.3
Operating System: Ubuntu

Re: Xammp on 'Skolelinux' based on Debian - Syntax error

Postby Sharley » 04. November 2011 01:44

Thanks for your post, but are you aware that you resurrected a 7 year old topic and so things may well have changed in the mean time. :shock:
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xammp on 'Skolelinux' based on Debian - Syntax error

Postby DarkKnight33 » 17. September 2012 15:05

I know this is an old topic, but after an very exhaustive search I stumbled on this page which (mostly) solved my problem.

First, I wanted to say: Thanks for digging up a 3 year old post. Yours is the only answer I've found related to the OP's and my problem.

Second, to get it to work, you have to follow your instructions as well as remove 'function' from /opt/lampp/share/lampp/lampplib AND add () after asky askn askp in the same file.

That got everything going on my end.

Thank you again, and I hope this helps someone down the road like it did me.
DarkKnight33
 
Posts: 1
Joined: 17. September 2012 15:00
XAMPP Version: 5.6.3
Operating System: Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests