mysql startet nicht->Nobody? Wie?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

mysql startet nicht->Nobody? Wie?

Postby bLEIFus » 10. September 2004 04:03

040909 19:42:26 mysqld started
Fatal error: Can't change to run as user 'nobody' ; Please check that the user exists!
040909 19:42:26 Aborting

040909 19:42:26 /opt/lampp/sbin/mysqld: Shutdown Complete

040909 19:42:26 mysqld ended

040909 19:43:43 mysqld started
Fatal error: Can't change to run as user 'nobody' ; Please check that the user exists!
040909 19:43:43 Aborting

040909 19:43:43 /opt/lampp/sbin/mysqld: Shutdown Complete

040909 19:43:43 mysqld ended

040909 19:44:15 mysqld started
040909 19:44:15 Can't start server : Bind on unix socket: Permission denied
040909 19:44:15 Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
040909 19:44:15 Aborting

040909 19:44:15 /opt/lampp/sbin/mysqld: Shutdown Complete

040909 19:44:15 mysqld ended

040909 19:48:15 mysqld started
040909 19:48:15 Can't start server : Bind on unix socket: Permission denied
040909 19:48:15 Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
040909 19:48:15 Aborting

040909 19:48:15 /opt/lampp/sbin/mysqld: Shutdown Complete

040909 19:48:15 mysqld ended

040909 19:51:16 mysqld started
040909 19:51:16 Can't start server : Bind on unix socket: Permission denied
040909 19:51:16 Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
040909 19:51:16 Aborting

040909 19:51:16 /opt/lampp/sbin/mysqld: Shutdown Complete

040909 19:51:16 mysqld ended


Hallo!

Wie man oben sieht startet mysql nicht. Ich habe dämlicher weise "nobody" gelöscht!

Ich habe mir das log durchgelesen und per:

Code: Select all
useradd nobody


den "nobody" neu angelegt. allerdings bestimmt nicht richtig. sonst würde es ja gehen.

Kann mir bitte jemand helfen und mir sagen wie ich einen nobody korrekt anlege, damit mysql funzt?

Dankeschön
bLEIFus
 
Posts: 19
Joined: 14. August 2004 17:18

Postby bLEIFus » 10. September 2004 04:48

HAT SICH ERLEDIGT
bLEIFus
 
Posts: 19
Joined: 14. August 2004 17:18

Postby Kristian Marcroft » 10. September 2004 05:59

Hi,

wäre sehr gut, wenn du sagen könntest WIE?
Dann haben andere User welche in Zukunft evtl das gleiche oder ein ähnliches Problem haben einen anhaltspunkt.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: mysql startet nicht->Nobody? Wie?

Postby Ikonn » 08. May 2012 22:22

So, ich hole das Thema mal kurz hoch. Ich hatte die gleiche Problematik unter OS X, plus der Fehlermeldung "xampperrordomain error 1". Der Befehl "useradd nobody" hat im Terminal nichts gebracht, also bin ich über die Systemsteuerung gegangen und habe dort einen neuen user "nobody" angelegt. Und voila MySQL lässt sich wieder starten. Ich hoffe das hilft noch dem ein oder anderen. Der weit verbreitete Tip die Zugriffsrechte des XAMPP-Ordners auf 0777 zu stellen war nämlich a) keine Option und b) hat keine Besserung gebracht.
Ikonn
 
Posts: 27
Joined: 23. January 2011 03:30
XAMPP Version: 5.6.3
Operating System: GNU/Linux Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests