New XAMPP-VM idea for the Mac

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Re: New XAMPP-VM idea for the Mac

Postby mahendura » 22. October 2018 13:22

Hi all,

Do we have reference how to set up the virtual host? I have following this article https://jonathannicol.com/blog/2012/03/11/configuring-virtualhosts-in-xampp-on-mac/ but I got an error when starting the Apache.
mahendura
 
Posts: 2
Joined: 22. October 2018 13:17
XAMPP version: XAMPP-VM / PHP 7.2.11
Operating System: macOs Mojave

Re: New XAMPP-VM idea for the Mac

Postby Altrea » 22. October 2018 14:07

Which error?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10021
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: New XAMPP-VM idea for the Mac

Postby CarlosFreire » 04. July 2019 18:19

Hi everyone

Even following all possible documentation, I could not:

1. create virtual host's for my different sites;
2. allow access to the mysql database through Sequel Pro (or MySQL Tools) - only phpMyadmin.

Step by step.
1. Creating virtual host's:

- In "lampp / etc / httpd.conf", I uncommented the line:
# Virtual hosts
Include etc / extra / httpd-vhosts.conf

- In "lampp / etc / extra / httpd-vhosts.conf", I created the virtual directories

<VirtualHost *: 80>
    DocumentRoot "/ opt / lampp / htdocs"
    ServerName localhost
    ServerAlias ​​localhost
    ErrorLog "logs / localhost-error_log"
    CustomLog "logs / localhost-access_log" common
</ VirtualHost>

# "/ topdesk / httpdocs" would be one of the sites
<VirtualHost *: 80>
    DocumentRoot "/ opt / lampp / htdocs / topdesk / httpdocs"
    ServerName topdesk.local
    ErrorLog "logs / topdesk-error_log"
    CustomLog "logs / topdesk-access_log" common
</ VirtualHost>

Xampp -> open terminal -> command "apachectl -S" results:

VirtualHost configuration:
*: 80 is a NameVirtualHost
default server localhost (/opt/lampp/etc/extra/httpd-vhosts.conf:1)
         port 80 namevhost localhost (/opt/lampp/etc/extra/httpd-vhosts.conf:1)
         alias localhost
         port 80 namevhost topdesk.local (/opt/lampp/etc/extra/httpd-vhosts.conf:9)
ServerRoot: "/ opt / lampp"
Main DocumentRoot: "/ opt / lampp / htdocs"
Main ErrorLog: "/ opt / lampp / logs / error_log"
Mutex ldap-cache: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir = "/ opt / lampp / logs /" mechanism = default
Mutex mpm-accept: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex proxy-balancer-shm: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex rewrite-map: using_defaults
Mutex authdigest-client: using_defaults
Mutex ssl-stapling: using_defaults
PidFile: "/opt/lampp/logs/httpd.pid"
Sets: DUMP_VHOSTS
Defines: DUMP_RUN_CFG
Defines: MODPERL2
User: name = "daemon" id = 1
Group: name = "daemon" id = 1

In the browser:
http: // localhost: 8080 -> ok (Xampp dashboard)
http: // localhost: 8080 / topdesk / httpdocs -> ok (site)
http: // localhost -> browser does not connect -> localhost-error.log empty
http: //topdesk.local -> browser does not connect -> topdesk-error.log empty

2. I configured Sequel Pro as described in lampp / etc / my.cnf file:

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /opt/lampp/var/mysql/mysql.sock

Sequel Answer:
Can not connect via socket, or the request has expired
Double-check that the socket path is correct and that you have the necessary privileges, and that the server is running
MySQL reported: Can not connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)

Note:

- I uncommented the #password line and put my real password in the my.cnf file. Same result.

- External access to phpmyadmin is ok.

- By checking the security of Xampp, I see that external access to MySql is blocked ... and I do not know how to undo it.

root @ debian: ~ # / opt / lampp / lampp security
XAMPP: Quick security check ...
XAMPP: MySQL is not accessible via network. Good.
XAMPP: MySQL has a root passwort set. Fine! :)
XAMPP: ProFTPD has a new FTP password. Great!
XAMPP: Do you want to change the password anyway? [no] no
XAMPP: Done.

Any idea?

Regards,
Carlos Freire
CarlosFreire
 
Posts: 4
Joined: 19. March 2019 13:54
Location: Rio de Janeiro, Brasil
XAMPP version: 7.3.6-2
Operating System: MacOs 10.13.6 [High Sierra]

Re: New XAMPP-VM idea for the Mac

Postby chimdesa » 27. January 2020 11:37

on this MYSQL is is not start?? what is the problem??
chimdesa
 
Posts: 2
Joined: 27. January 2020 08:54
XAMPP version: 7.4
Operating System: Mac OS

Re: New XAMPP-VM idea for the Mac

Postby swettymac » 07. February 2020 18:45

i like your xampp vm but....

It's now even easier to run commands on XAMPP-VM. From the stack manager page, click the "Open Terminal" button and you'll be logged in to a XAMPP-VM console with full root privileges.

Open Terminal button doesn't work and i need it to reset mysql root password
swettymac
 
Posts: 1
Joined: 07. February 2020 18:35
XAMPP version: xampp-osx-7.4.2-vm
Operating System: OSX

Re: New XAMPP-VM idea for the Mac

Postby Mountbaten » 20. February 2020 13:09

swettymac wrote:i like your xampp vm but....

It's now even easier to run commands on XAMPP-VM. From the stack manager page, click the "Open Terminal" button and you'll be logged in to a XAMPP-VM console with full root privileges.

Open Terminal button doesn't work and i need it to reset mysql root password


Thanks for the tip.
Mountbaten
 
Posts: 5
Joined: 02. October 2019 18:21
XAMPP version: 7.3.7
Operating System: Windows 10

Re: New XAMPP-VM idea for the Mac

Postby mlenaghan » 24. February 2020 18:14

"Open Terminal" is opening to my home directory rather than /opt/lampp.

Some background:

* I'm running macOS 10.15.3 (Catalina)
* I'm using 7.4.2-vm.
* I'm successfully running Start.
* I'm successfully mounting /opt/lampp.
* After mounting a "lampp" volume shows up on my Desktop.
* After mounting the Explore button opens that mounted volume.
* In Terminal the mount command shows a mounted NFS volume:

Code: Select all
        92.168.64.2:/opt/lampp on /Users/.../.bitnami/stackman/machines/xampp/volumes/root (nfs, nodev, nosuid, mounted by ...)


* I can cd to that directory, but a) I'm logged in as me, not at the XAMPP root user and b) I think XAMPP expects that directory (or one of its parents) to be the root volume, not a subdirectory. For example, running xampp produces this error:

Code: Select all
 ./xampp: line 69: /Applications/XAMPP/xamppfiles/share/xampp/xampplib: No such file or directory
cat: /Applications/XAMPP/xamppfiles/lib/VERSION: No such file or directory
./xampp: line 426: -s: command not found


Any thoughts on how to fix this, or how to debug it?
mlenaghan
 
Posts: 2
Joined: 24. February 2020 18:01
XAMPP version: 7.4.2
Operating System: macOS 10.15.3

Re: New XAMPP-VM idea for the Mac

Postby mlenaghan » 24. February 2020 21:38

OK, I found the problem—and the solution. In Terminal | Preferences | General I had set "Shells open with:" to "Command (complete path):" rather than "Default login shell". Setting it back to "Default login shell" made everything work as expected.
mlenaghan
 
Posts: 2
Joined: 24. February 2020 18:01
XAMPP version: 7.4.2
Operating System: macOS 10.15.3

Previous

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests