How to install the latest version of ICU and INTL

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

How to install the latest version of ICU and INTL

Postby wikao » 18. April 2019 16:26

Hello,
I would like to install on Xampp under Mac Os X, Prestashop 1.7.5.1.
During the installation, I have a warning to the ICU system package and the PHP extension.
I tried several manipulations found on the Internet, but I can not upgrade the ICU system package.
When I check PHP info, it says that it is ICU version 4.8.1.1 while the latest version is 64.2 (you see the difference)
The version of intl PHP extension is 1.1.0 and the latest version of Intl is 3.0.0 (in 2013 because this package is not maintained anymore and has been superseded)
How can I install the latest version of ICU and INTL ?
Thank you for your answers

Have a nice day
wikao
 
Posts: 6
Joined: 18. April 2019 09:25
XAMPP version: 5.6.40
Operating System: Mac OS X Mojave

Re: How to install the latest version of ICU and INTL

Postby wikao » 25. April 2019 08:18

Nobody has an answer ?
wikao
 
Posts: 6
Joined: 18. April 2019 09:25
XAMPP version: 5.6.40
Operating System: Mac OS X Mojave

Re: How to install the latest version of ICU and INTL

Postby Nobbie » 25. April 2019 11:57

That is one of the disadvantages of using Xampp, it is hard (or impossible) to upgrade single components. Usually you have to wait for a newer Xampp release. Ask Bitnami if they can deliver a newer version (but dont expect to much).

It might be easier to run Linux (Ubuntu, Mint etc.) and install Apache, PHP, MySQL from their repository, that is by far easier to keep updated. Xampp is easily to install, but you cannot extend nor upgrade it (or any component).
Nobbie
 
Posts: 11147
Joined: 09. March 2008 13:04

Re: How to install the latest version of ICU and INTL

Postby wikao » 25. April 2019 12:30

Thank you very much for your answer Nobbie
Have a nice day ;-)
wikao
 
Posts: 6
Joined: 18. April 2019 09:25
XAMPP version: 5.6.40
Operating System: Mac OS X Mojave


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests