Apache startet nicht (kein Socket Problem)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht (kein Socket Problem)

Postby SaWu » 10. March 2019 13:29

Hallo,

Ich habe in der Vergangenheit schon erfolgreich Xampp genutzt. Jetzt habe ich Xampp 7.3.2. (aktuellste Version) auf Windows 7 installiert. Folgendes Problem tritt auf:

- ich starte das xampp control panel
- ich kicke auf "netstats": Sockets 80 und 443 sind frei
- ich klicke auf Apacke Starten", die Meledung "Versuche Apache zu starten ..." erscheint
- in den Netstats erscheint httpd.exe auf Port 80 und 443
- im Control Panel wird der "Admin" Buttin nicht aktiv, der "Starten" Button bleibt unverändert (wechselt nicht zu stoppen)
- klicke ich erneut auf Starten kommt die Fehlermeldung, dass Port 80 und 443 blockiert sind.
- klicke ich auf "Logs" und dann "error.log" erscheinen zwar Warnungen und Meldungen, ich kann damit aber nichts anfragen:
[Sun Mar 10 12:42:22.347820 2019] [ssl:warn] [pid 5320:tid 236] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:42:22.878221 2019] [ssl:warn] [pid 5320:tid 236] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:42:23.517822 2019] [mpm_winnt:notice] [pid 5320:tid 236] AH00455: Apache/2.4.38 (Win64) OpenSSL/1.1.1a PHP/7.3.2 configured -- resuming normal operations
[Sun Mar 10 12:42:23.517822 2019] [mpm_winnt:notice] [pid 5320:tid 236] AH00456: Apache Lounge VC15 Server built: Jan 18 2019 14:26:34
[Sun Mar 10 12:42:23.517822 2019] [core:notice] [pid 5320:tid 236] AH00094: Command line: 'F:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Sun Mar 10 12:42:23.533422 2019] [mpm_winnt:notice] [pid 5320:tid 236] AH00418: Parent: Created child process 6088
[Sun Mar 10 12:42:24.391424 2019] [ssl:warn] [pid 6088:tid 248] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:42:25.077825 2019] [ssl:warn] [pid 6088:tid 248] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:42:25.265025 2019] [mpm_winnt:notice] [pid 6088:tid 248] AH00354: Child: Starting 150 worker threads.
[Sun Mar 10 12:45:41.466224 2019] [ssl:warn] [pid 5676:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:45:41.544224 2019] [ssl:warn] [pid 5676:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:45:41.669024 2019] [mpm_winnt:notice] [pid 5676:tid 244] AH00455: Apache/2.4.38 (Win64) OpenSSL/1.1.1a PHP/7.3.2 configured -- resuming normal operations
[Sun Mar 10 12:45:41.669024 2019] [mpm_winnt:notice] [pid 5676:tid 244] AH00456: Apache Lounge VC15 Server built: Jan 18 2019 14:26:34
[Sun Mar 10 12:45:41.669024 2019] [core:notice] [pid 5676:tid 244] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Sun Mar 10 12:45:41.669024 2019] [mpm_winnt:notice] [pid 5676:tid 244] AH00418: Parent: Created child process 2484
[Sun Mar 10 12:45:41.887425 2019] [ssl:warn] [pid 2484:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:45:41.934225 2019] [ssl:warn] [pid 2484:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Mar 10 12:45:41.965425 2019] [mpm_winnt:notice] [pid 2484:tid 256] AH00354: Child: Starting 150 worker threads.



Was ich bereits probiert habe:
- control panel als admin starten
- xampp deinstallieren und neu installieren
- apache_start.bat auf der Kommandozeile starten, dort erscheint nur "Apache 2 is starting ..." dann passiert nichts mehr.

Hat jemand einen Tipp?
SaWu
 
Posts: 5
Joined: 10. March 2019 13:22
XAMPP version: 7.3.2
Operating System: Windows 7

Re: Apache startet nicht (kein Socket Problem)

Postby Jubojo » 10. March 2019 15:35

Hi,
wieso führst due die Datei xampp_start.exe nicht aus.
Mit dieser Datei startet Apache und MYSQL.
Wenn du mysqlo nicht starten willst, führe doch danach die Datei mysql_stop.bat aus.
Gruß, Jubojo
Jubojo
 
Posts: 2
Joined: 10. March 2019 15:10
XAMPP version: 7.3.2
Operating System: Windows Home 10

Re: Apache startet nicht (kein Socket Problem)

Postby SaWu » 14. March 2019 07:00

Hallo Jubojo,
danke für den Hinweis, er hat mich in eine richtige Richtung gestoßen.

Tatäschlich startet sowohl xampp_start.exe als das Controll Panel apache und mysql - es sieht nur im Control Panel nicht so aus. Über http://localhost/phpmyadmin/ und http://localhost/phpinfo.php sind mysql und php erreichbar.

Trotzdem ärgerlich, dass das control panel nicht richtig funktioniert.
SaWu
 
Posts: 5
Joined: 10. March 2019 13:22
XAMPP version: 7.3.2
Operating System: Windows 7

Re: Apache startet nicht (kein Socket Problem)

Postby Altrea » 14. March 2019 11:26

Hallo,

Setzt du wirklich die aktuellste Version XAMPP 7.3.2-2 ein oder noch die ältere 7.3.2-1?
Mit Revision 2 wurde nämlich ein Fehler im Control Panel behoben (ist nun CP version 3.2.3), das sich ziemlich nach deinem anhört.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9733
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht (kein Socket Problem)

Postby SaWu » 16. March 2019 12:13

Danke - ja am letzten Wochenende hatte ich die aktuellste Version, aber mit der noch neueren klappt es jetzt.
SaWu
 
Posts: 5
Joined: 10. March 2019 13:22
XAMPP version: 7.3.2
Operating System: Windows 7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests