Access denied

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Access denied

Postby Dani Solis » 27. February 2019 23:31

I'm new in the forum.

I hope I can contribute something to the community.

I have installed XAMPP and Workbench, when try access to "PHPMyAdmin" appear following error:
Image

Similar error appear in Workbench:
Image

I try modified the Config.inc.php file. But error is persistent.

Somebody the forum know how resolve this issue?

Thanks

DS
Dani Solis
 
Posts: 3
Joined: 27. February 2019 23:02
XAMPP version: v3.2.2
Operating System: Windows10

Re: Access denied

Postby Nobbie » 28. February 2019 09:23

You havent applied a valid user in config.inc.php
Nobbie
 
Posts: 11167
Joined: 09. March 2008 13:04

Re: Access denied

Postby Dani Solis » 28. February 2019 19:45

I access with user root and same password but now not me permit access.

My Config.inc.php file
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = '';
$cfg['Servers'][$i]['controlpass'] = 'pma';

Before:

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'root';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = '';
$cfg['Servers'][$i]['controlpass'] = 'pma';
Dani Solis
 
Posts: 3
Joined: 27. February 2019 23:02
XAMPP version: v3.2.2
Operating System: Windows10

Re: Access denied

Postby Altrea » 28. February 2019 21:04

Why is $cfg['Servers'][$i]['user'] an empty string and not 'root'?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9808
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Access denied

Postby Dani Solis » 28. February 2019 22:07

With root or without root appear me the error:
MySQL said: Documentation
Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = false;
$cfg['Lang'] = '';
Dani Solis
 
Posts: 3
Joined: 27. February 2019 23:02
XAMPP version: v3.2.2
Operating System: Windows10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests