Start Probleme und Intranet

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Start Probleme und Intranet

Postby old_rabbit » 01. January 2019 13:38

Hallo guten Morgen und frohes Neues,

habe mir auf den KDE-Desktop eine Verknüpfung zu xampp gelegt, die wie folgt aussieht:
Code: Select all
#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Type=Application
StartupWMClass=osxmanager
Terminal=false
Icon[en_US]=/opt/lampp/htdocs/favicon.ico
Name[en_US]=XAMPP
Exec=sudo -H /opt/lampp/manager-linux-x64.run
Comment[en_US]=Start XAMPP Control Panel
Name=XAMPP
Comment=Start XAMPP Control Panel
Icon=/opt/lampp/htdocs/favicon.ico
und die unter '~/.local/share/applications/xampp-control-panel.desktop' liegt.
Das ganze funktioniert auch mit gksudo oder kdesudo, zumindest auf Benutzerebene nicht, gebe ich folgendes '/opt/lampp/manager-linux-x64.run', in der Konsole als root ein funktioniert die Sache?

Zweitens habe ich xampp (Windows 7) erfolgreich laufen und das Datenverzeichnis sowie die Datenbank auf ein lokales Verzeichnis ausgelagert. Hintergrund war das ich ebenfalls unter oder mit Linux selbiges nutzen kann, was mir aber nicht wirklich gelingt. Derzeit sind einfach die lokalen Verzeichnisse von Windows (../xampp//htdocs/my_projekt und ../xampp/mysql/data/projekt_db) zu den Verzeichnissen Linux (../opt/lampp/htdocs/ und ../opt/lampp/var/mysql/projekt_db) via Symbolischer Link verknüpft! Was teilweise auch funktioniert, öffne ich phpmyadim (Linux Seite) habe ich zugriff auf die Datenbank 'projekt_db', das htdocs; 'my_projekt' wird zumindest im Browser 'http://localhost/my_projekt' gefunden, aber leider wird dann die Drupal Installation eingeleitet anstatt die fertige Drupal Seite im Browser zu öffnen.

Viele Grüße
old_rabbit :roll:
old_rabbit
 
Posts: 4
Joined: 01. January 2019 12:53
XAMPP version: 7.3
Operating System: debian

Re: Start Probleme und Intranet

Postby old_rabbit » 05. January 2019 11:35

Hallo Leute,

versuche gerade das ganze ohne symbolischen Link. Habe in der ../etc/httpd.conf DocumentRoot und <Directory> entsprechend den UNC Pfad gesetzt.
Gleiches in der ../etc/my.cnf hier datadir, innodb_data_home_dir und innodb_log_group_home_dir.
Leider startet (run) MySQL Database nun nicht mehr, bzw springt nach einiger Zeit im xampp Fenster, wieder auf stopped. Jemand eine gute Idee?

:roll:
old_rabbit
 
Posts: 4
Joined: 01. January 2019 12:53
XAMPP version: 7.3
Operating System: debian

Re: Start Probleme und Intranet

Postby Nobbie » 05. January 2019 13:20

Wahrscheinlich falsche/ungenügende Dateirechte?!

ich verstehe das Szenario sowieso nicht so richtig, wenn es einen Windows7 Rechner mit Xampp bereits gibt, wieso muss Xampp dann nochmal installiert werden? Ich würde auf dem Linux Rechner in die PHP Scripts für die Datenbank einfach die Verbindungsdaten für den Xampp Rechner angeben, exakt das ist der Sinn von Servern. Beim Connect statt "localhost" die LAN IP des Windows Rechners.
Nobbie
 
Posts: 10970
Joined: 09. March 2008 13:04

Re: Start Probleme und Intranet

Postby old_rabbit » 05. January 2019 16:31

nee es soll nicht der MYSQL Server freigegeben werden, sondern nur das Freigegeben Verzeichnis gemeinsam genutzt werden.
Unter Windows 7 funzt das ja auch , sprich htdocs und mysqlDB liegen auf dem Share Verzeichnis.
Nur unter Linux will es nicht mit mysqlDB Share Verzeichnis funktionieren. (/home/rabbit/myShare Uno/Html & Ko/mysql/data)
old_rabbit
 
Posts: 4
Joined: 01. January 2019 12:53
XAMPP version: 7.3
Operating System: debian

Re: Start Probleme und Intranet

Postby Nobbie » 05. January 2019 19:08

old_rabbit wrote:nee es soll nicht der MYSQL Server freigegeben werden, sondern nur das Freigegeben Verzeichnis gemeinsam genutzt werden.


Weiß ich, das ist aber konzeptioneller Unsinn.

Gleichzeitig wird es NIE gehen, weil der erste Server (wahrscheinlich Windows) einen Lock auf die Dateien macht. Mindestens einen Write-lock, ggf. sogar einen Read-lock.

Man kann (wenn überhaupt) nur abwechselnd Xampp auf Linux und/oder Xampp auf Windows starten. Aber auch da muss man schauen, dass das gemountete Verzeichnis und die darunter liegenden Dateien mit hinreichenden Rechten für die Linux Xampp Version ausgestattet sind. Das muss auf dem Windows Server freigegeben werden und beim mount unter Linux (ggf. mit Hilfe von Samba) richtig konfiguriert werden. Das ist aber schieres Linux KnowHow, ist im Xampp Forum falsch platziert.
Nobbie
 
Posts: 10970
Joined: 09. March 2008 13:04

Re: Start Probleme und Intranet

Postby old_rabbit » 06. January 2019 11:21

Ok, gleichzeitiger Zugriff liegt mir fern, aber dennoch sehr aufschlussreich, vielen Dank
old_rabbit
 
Posts: 4
Joined: 01. January 2019 12:53
XAMPP version: 7.3
Operating System: debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests

cron