Login to phpmyadmin not working with Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Login to phpmyadmin not working with Xampp

Postby Alexander92 » 11. December 2018 11:42

I'm trying to login to phpmyadmin using the Xampp Programm.
I get this report when i'm using the Config auth-type.
Code: Select all
mysqli_real_connect(): The server requested authentication method unknown to the client [caching_sha2_password]
mysqli_real_connect(): (HY000/2054): The server requested authentication method unknown to the client

It says i should check the username and password in the config.inc.php and compare it with the information i got from the administrator (incidentially i don't know which information he's talking about)
When i use the Cookie auth-type I get the same error report missing out the advice to compare the admin-information.
Auth-type http opens a window from the browser in front of an empty page where i can set username and password. No matter what i type in the window disappears and reappears.
Auth-type Signon leads me direct to the website i'm telling him but not to phpmyadmin so this auth-type drops out for me.

It can be there are some topics in the internet or this forum about this case open yet (if solved or not) but i'm searching about this problem about 2-3 days in the internet now so please don't lead me to another topic that supposes to have the same problem. If so, I hope it is no big deal to just enter the solution in this topic firstly or again. Thanks anyway!

nice regards
Alex
Alexander92
 
Posts: 3
Joined: 11. December 2018 11:15
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Login to phpmyadmin not working with Xampp

Postby Nobbie » 11. December 2018 13:36

Try "'cookie" as auth_type. Enter "root" as User and leave passwort empty. Thats the Xampp default configuration. If it does not work, you must have changed the database.

P.S.: Are you sure, that Xampps MySQL(MariaDB) is up and running? It looks a bit as if you already are running a different MySQL Server and phpmyadmin trys to connect to that one?!
Nobbie
 
Posts: 11149
Joined: 09. March 2008 13:04

Re: Login to phpmyadmin not working with Xampp

Postby Alexander92 » 12. December 2018 12:50

I reinstalled the programm again to make sure that i'm using mariadb. I think mariadb was installed previous though.
So now I changed the port for mysql again (from 3306 to 3307) to get it working anyway. I made some additional setting (or funktion) in the config.ini.php before I reinstalled the programm so now maybe some setting is different but it seemes it doesnt make a big difference. At least it's not working better...
I installed that programm (in the link) and it says it uses mariadb
https://www.apachefriends.org/blog/new_xampp_20151019.html
Alexander92
 
Posts: 3
Joined: 11. December 2018 11:15
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Login to phpmyadmin not working with Xampp

Postby Altrea » 12. December 2018 13:01

Did you specify the new port in your my.ini and your config.inc.php too?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9799
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Login to phpmyadmin not working with Xampp

Postby Alexander92 » 12. December 2018 13:17

I didn't change it in the config.inc.php because there was no port setting given like 3306 so I thought it's not necessary to change a setting in this file.
I did change the port in the my.ini (exept in the comments, not to mention)
How can I set the new port in the config.inc.php?
Alexander92
 
Posts: 3
Joined: 11. December 2018 11:15
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Login to phpmyadmin not working with Xampp

Postby Altrea » 12. December 2018 13:32

The phpmyadmin documentation is your friend
http://docs.phpmyadmin.net/en/latest/co ... rvers_port
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9799
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Login to phpmyadmin not working with Xampp

Postby Nobbie » 12. December 2018 14:02

Alexander92 wrote:I didn't change it in the config.inc.php because there was no port setting given like 3306 so I thought it's not necessary to change a setting in this file.


So my clue was right, your phpmyadmin is connecting to another MySQL/MariaDB installation. Of course you have to change the port in phpmyadmin as well, otherwise it connects to 3306 and on 3306 already runs another MySQL server.
Nobbie
 
Posts: 11149
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 128 guests