Error when opening phpMyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error when opening phpMyadmin

Postby yashika5 » 02. June 2018 14:36

06:22:23 [main] Initializing Control Panel
06:22:23 [main] Windows Version: Pro 64-bit
06:22:23 [main] XAMPP Version: 5.6.28
06:22:23 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
06:22:23 [main] Running with Administrator rights - good!
06:22:23 [main] XAMPP Installation Directory: "c:\intel\new folder\new folder\"
06:22:23 [main] WARNING: Your install directory contains spaces. This may break programs/scripts
06:22:23 [main] Checking for prerequisites
06:22:24 [main] All prerequisites found
06:22:24 [main] Initializing Modules
06:22:24 [Apache] XAMPP Apache is already running on port 80
06:22:24 [Apache] XAMPP Apache is already running on port 443
06:22:24 [mysql] XAMPP MySQL is already running on port 3307
06:22:24 [main] Enabling autostart for module "Apache"
06:22:24 [main] Enabling autostart for module "MySQL"
06:22:24 [main] Starting Check-Timer
06:22:24 [main] Control Panel Ready
06:22:24 [Apache] Autostart aborted: Apache is already running
06:22:24 [mysql] Autostart aborted: MySQL is already running
06:28:14 [Apache] Attempting to stop Apache (PID: 880)
06:28:14 [Apache] Attempting to stop Apache (PID: 984)
06:28:15 [Apache] Status change detected: stopped
06:28:16 [Apache] Attempting to start Apache app...
06:28:16 [Apache] Status change detected: running
06:28:18 [mysql] Attempting to stop MySQL app...
06:28:18 [mysql] Status change detected: stopped
06:28:21 [mysql] Attempting to start MySQL app...
06:28:21 [mysql] Status change detected: running
06:31:30 [mysql] Attempting to stop MySQL app...
06:31:31 [mysql] Status change detected: stopped
06:31:33 [mysql] Attempting to start MySQL app...
06:31:33 [mysql] Status change detected: running
06:31:47 [Apache] Attempting to stop Apache (PID: 16660)
06:31:47 [Apache] Attempting to stop Apache (PID: 4680)
06:31:47 [Apache] Status change detected: stopped
06:31:48 [Apache] Attempting to start Apache app...
06:31:48 [Apache] Status change detected: running
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Altrea » 03. June 2018 01:54

Did you tell phpmyadmin which new port you set for your MariaDB server?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10380
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 07:54

port 3307
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Altrea » 03. June 2018 10:09

I have already seen this.
How did you change the port so that phpmyadmin uses the new port too to connect to MariaDB?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10380
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 10:13

"Failed to set session cookie. Maybe you are using http instead of https to access phpMyadmin,"

this error occurs,

I have changed port 3306 through 3307 in " my.ini ".
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 10:15

02:15:26 [main] Initializing Control Panel
02:15:26 [main] Windows Version: Pro 64-bit
02:15:26 [main] XAMPP Version: 7.2.5
02:15:26 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
02:15:26 [main] Running with Administrator rights - good!
02:15:26 [main] XAMPP Installation Directory: "f:\xampp\"
02:15:26 [main] Checking for prerequisites
02:15:26 [main] All prerequisites found
02:15:26 [main] Initializing Modules
02:15:26 [Apache] XAMPP Apache is already running on port 80
02:15:26 [Apache] XAMPP Apache is already running on port 443
02:15:26 [mysql] XAMPP MySQL is already running on port 3307
02:15:26 [main] Enabling autostart for module "Apache"
02:15:26 [main] Enabling autostart for module "MySQL"
02:15:26 [main] Starting Check-Timer
02:15:26 [main] Control Panel Ready
02:15:26 [Apache] Autostart aborted: Apache is already running
02:15:26 [mysql] Autostart aborted: MySQL is already running
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Nobbie » 03. June 2018 10:16

yashika5 wrote:"Failed to set session cookie. Maybe you are using http instead of https to access phpMyadmin,"

this error occurs,

I have changed port 3306 through 3307 in " my.ini ".


You have to tell this to phpmyadmin as well in config.inc.php
Nobbie
 
Posts: 11711
Joined: 09. March 2008 13:04

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 11:56

i have already done this.
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Altrea » 03. June 2018 12:33

Please clear all Browser cookies and try again.
If this does not work please show us your complete config.inc.php
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10380
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 13:00

<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'password';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = false;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
$cfg['Servers'][$i]['relation'] = 'pma__relation';
$cfg['Servers'][$i]['table_info'] = 'pma__table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma__column_info';
$cfg['Servers'][$i]['history'] = 'pma__history';
$cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma__tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
$cfg['Servers'][$i]['recent'] = 'pma__recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
$cfg['Servers'][$i]['users'] = 'pma__users';
$cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
$cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
$cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';
$cfg['Servers'][$i]['central_columns'] = 'pma__central_columns';
$cfg['Servers'][$i]['designer_settings'] = 'pma__designer_settings';
$cfg['Servers'][$i]['export_templates'] = 'pma__export_templates';
$cfg['Servers'][$i]['favorite'] = 'pma__favorite';

/*
* End of servers configuration
*/

?>
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Nobbie » 03. June 2018 13:50

yashika5 wrote:i have already done this.


You did not change anything, what do you mean by "i have already done this"? What have you done?
Nobbie
 
Posts: 11711
Joined: 09. March 2008 13:04

Re: Error when opening phpMyadmin

Postby yashika5 » 03. June 2018 14:02

I'm saying about changing port , but now please tell me what to do with above code..
yashika5
 
Posts: 7
Joined: 02. June 2018 10:19
XAMPP version: 5.6.28
Operating System: Windows

Re: Error when opening phpMyadmin

Postby Nobbie » 03. June 2018 20:59

Apply port 3307 to config.inc.php - and that is such a simple and obvious change, i want you to find it out yourself.
Nobbie
 
Posts: 11711
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests