Apache redirect issue

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache redirect issue

Postby mikebyrne » 28. February 2017 18:27

I am currently trying to get apache and Owncloud working on the same Pi

At present, Owncloud is using port 80, but I'm trying to get my webpage to show on port 8079 (if possible)

My var/www has 2 folders "Owncloud" and "Html"

/etc/apache2/sites-enabled/000-default.conf

Code: Select all
    VirtualHost *:8079>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
    </VirtualHost>


/etc/apache2/ports.conf

Code: Select all
    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default.conf

    #Listen 80
    Listen 8079

    <IfModule ssl_module>
            Listen 443
    </IfModule>

    <IfModule mod_gnutls.c>
            Listen 443
    </IfModule>

    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet


Any help would be great!!!!
mikebyrne
 
Posts: 7
Joined: 12. November 2007 21:45

Re: Apache redirect issue

Postby Nobbie » 28. February 2017 21:17

mikebyrne wrote:I am currently trying to get apache and Owncloud working on the same Pi


And you have a Xampp package for your PI?? As you can see, this is the Xampp for Linux Forum. Do you have Xampp installed?
Nobbie
 
Posts: 9617
Joined: 09. March 2008 13:04

Re: Apache redirect issue

Postby mikebyrne » 28. February 2017 21:45

No, just apache.

Could you direct me to the correct area
mikebyrne
 
Posts: 7
Joined: 12. November 2007 21:45

Re: Apache redirect issue

Postby Nobbie » 28. February 2017 23:01

As you dont apply your distribution, i cannot recommend anything. Find a forum of your distribution and ask there. The Xampp forum is definately the wrong place.
Nobbie
 
Posts: 9617
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests