Apache not starting. Another web server already runnung

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache not starting. Another web server already runnung

Postby Janno » 19. January 2014 11:56

I installed XAMPP-Linux, usig the instructions given on Apache Friends (www.apachefriends.org/en/xampp-linux.html)
Got the warning: No D-Bus Deamon running.
But installing XAMPP went on, and finished succesfull (so it looked).

When I go to http://localhost I get the message "It works! This is the default web page for this server. The web server software is running
but no content has been added yet".

So I opened a terminal, and typed in sudo /opt/lampp/lampp start. Got back:
Starting Xampp for linux 1.8.2-3...
XAMPP: Starting Apache ...fail
XAMPP: Another web server is already running.
XAMPP: Starting MySQL...ok
XAMPP: Starting ProFTPD...ok

Well, almost OK. How to solve the problem?
Janno
 
Posts: 28
Joined: 28. March 2009 16:57
XAMPP Version: 1.8.3-3
Operating System: Vista

Re: Apache not starting. Another web server already runnung

Postby bxg » 24. January 2014 05:16

Looks like no one has responded to you yet. Wish I could help but I'm having the exact same problem, (but without the D-Bus Daemon message.) Maybe this post will give the topic a bump.

I had the same messages about apache start failed, and another web server already running. I went so far as to remove apache2 and tomcat7 from my ubuntu machine. Then when I ps -ef | grep apache (or tomcat) I get no running processes other than my grep. So now I issue /opt/lampp/lampp start and everything shows up as OK, including apache. But when I try http://localhost I get the same "It works" webpage as before. Even if apache2 left index pages on my machine after I removed it, I thought xampp installs completely in it's own directory structure so none of the xampp apps should be looking anywhere else for needed files. Is this not correct.

I don't know apache well enough to know if there are config files that need to be altered in order to get this straightened out, but I'm hoping someone here does. At this point, I only know enough about apache to be dangerous.... it's why I downloaded xampp in the first place!

Thanks for reading.
bxg
 
Posts: 1
Joined: 24. January 2014 03:46
XAMPP Version: 5.5.19
Operating System: ubuntu 13

Re: Apache not starting. Another web server already runnung

Postby Janno » 27. January 2014 16:32

Well, it looks that no solution can be found. I Will remove the Linux-version (from my laptop), stick with XAMPP for Windows (on my desktop). Which is running OK.
Janno
 
Posts: 28
Joined: 28. March 2009 16:57
XAMPP Version: 1.8.3-3
Operating System: Vista

Re: Apache not starting. Another web server already runnung

Postby Janno » 27. January 2014 23:48

Tried again: downloaded Xampp for Linux 32 bit, installation went well.

However, when using my browser (Firefox), using http://localhost, I got the message that it was no possible to connect.
Checking the servers it showd that Apache was not started, This was caused by the fact that, so I was told, that another
server already was running.

How to fix this?
Janno
 
Posts: 28
Joined: 28. March 2009 16:57
XAMPP Version: 1.8.3-3
Operating System: Vista

Re: Apache not starting. Another web server already runnung

Postby newvista » 11. February 2014 23:18

I too have this same problem. I am using an Acer netbook running Xubuntu 13.10.

I don't know how to "check the servers" but I'd love to find out.

Cheers,
Lorne
newvista
 
Posts: 1
Joined: 11. February 2014 19:46
XAMPP Version: 5.5.19
Operating System: xubuntu x86 32bit

Re: Apache not starting. Another web server already runnung

Postby Iosyf » 24. December 2014 18:38

After a few hours of stressful googling over my homework for my Webdesign class I found this helpfull:

sudo /etc/init.d/apache2 stop

GLHF
Iosyf
 
Posts: 1
Joined: 24. December 2014 18:35
XAMPP Version: 5.6.3
Operating System: Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests