XAMPP doesn't compile code

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP doesn't compile code

Postby mikziom » 31. October 2013 13:18

Hi

I have a little problem or even big one. After instalation when I enter on adress: localhost/xampp everything working fine, but when i try to go on localhost/mateusz-martyna XAMPP doesn't compile code after line where is object variable.

System: Windows 7 Ultimate SP1
XAMPP: 1.8.0

It is picture how it looks in webbrowser:
Image

And here is begin of the code (only couple of line but after 7 line it is a simple text for webbrowser, exactly where is $AKME->):
Code: Select all
require_once('includes/config.php');
require_once('blocks.php');
/**********************************************************************/
if (ANTYHACK == 'ZX28Ph') {
   if (empty($_GET['op']))
  {
      $AKME -> set_main(true);
      $smarty -> assign('AKME_glowna',true);


Apache error log:
[Thu Oct 31 12:43:00.567461 2013] [ssl:warn] [pid 5844:tid 428] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Oct 31 12:43:00.873466 2013] [mpm_winnt:notice] [pid 5844:tid 428] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Thu Oct 31 12:43:00.873466 2013] [mpm_winnt:notice] [pid 5844:tid 428] AH00456: Server built: Aug 18 2012 12:41:37
[Thu Oct 31 12:43:00.873466 2013] [core:notice] [pid 5844:tid 428] AH00094: Command line: 'd:\\xampp\\apache\\bin\\httpd.exe -d D:/xampp/apache'
[Thu Oct 31 12:43:00.893466 2013] [mpm_winnt:notice] [pid 5844:tid 428] AH00418: Parent: Created child process 5964
[Thu Oct 31 12:43:02.131476 2013] [ssl:warn] [pid 5964:tid 440] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Oct 31 12:43:02.241476 2013] [mpm_winnt:notice] [pid 5964:tid 440] AH00354: Child: Starting 150 worker threads.


What can I do to fix this problem??

I tried to instal any other version of XAMPP sience 1.7.9
Sorry if i doubled post with this problem but I couldn't find this anywhere, or maybe I don't know how to call it properly english.
mikziom
 
Posts: 1
Joined: 31. October 2013 12:49
XAMPP Version: 1.8.2-3
Operating System: Windows 7 Ultimate SP1

Re: XAMPP doesn't compile code

Postby Altrea » 31. October 2013 13:49

Hi,

does your php block start with <? or <?php?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6495
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests