Apache Error! Won't start!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Error! Won't start!

Postby camaflicks » 08. July 2013 20:08

When I start the XAMPP control panel v3.2.1, I try to start Apache and all I get is an error. Here is the first one:

12:59:21 PM [Apache] Error: Apache shutdown unexpectedly.
12:59:21 PM [Apache] This may be due to a blocked port, missing dependencies,
12:59:21 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:59:21 PM [Apache] Press the Logs button to view error logs and check
12:59:21 PM [Apache] the Windows Event Viewer for more clues
12:59:21 PM [Apache] If you need more help, copy and post this
12:59:21 PM [Apache] entire log window on the forums

And this one (the one it told me to post)

[Mon Jul 08 12:52:31.845413 2013] [ssl:warn] [pid 4316:tid 252] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jul 08 12:52:32.900473 2013] [ssl:warn] [pid 4316:tid 252] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jul 08 12:52:33.653516 2013] [mpm_winnt:notice] [pid 4316:tid 252] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Jul 08 12:52:33.653516 2013] [mpm_winnt:notice] [pid 4316:tid 252] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Jul 08 12:52:33.653516 2013] [core:notice] [pid 4316:tid 252] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jul 08 12:52:33.673518 2013] [mpm_winnt:notice] [pid 4316:tid 252] AH00418: Parent: Created child process 1244
[Mon Jul 08 12:52:35.174603 2013] [ssl:warn] [pid 1244:tid 264] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jul 08 12:52:36.133658 2013] [ssl:warn] [pid 1244:tid 264] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jul 08 12:52:36.520680 2013] [mpm_winnt:notice] [pid 1244:tid 264] AH00354: Child: Starting 150 worker threads.

Please help! How can I fix this? I had my apache set to listen to port 80 first and I got this error then I set is to listen to port 443 and I got this error. I have skype but I shut it down before I installed XAMPP
camaflicks
 
Posts: 2
Joined: 08. July 2013 19:59
Location: Colorado Springs, CO, USA
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Error! Won't start!

Postby hackattack142 » 08. July 2013 22:10

Hello,

Could you post the entire control panel log window and not just the snippet?

Also, do you get any specific error messages if you run Apache_start.bat in the main XAMPP directory?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Error! Won't start!

Postby camaflicks » 08. July 2013 22:14

I fixed it. Dont wory
camaflicks
 
Posts: 2
Joined: 08. July 2013 19:59
Location: Colorado Springs, CO, USA
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Error! Won't start!

Postby Lamont » 27. July 2013 03:16

Dear camaflicks, I am having the same error message and I haven't been able to get a street from anyone how to fix it.
Could you kindly let me know how you fixed your problem with XAMPP?

It used to be that XAMPP would run "right out of the box" with no adjustments for me. I don't know what it has begun to have problems.

Thanks for kind assistance, Lamont
'
Lamont
 
Posts: 1
Joined: 24. July 2013 19:54
Location: San Mateo, CA
XAMPP Version: 5.6.3
Operating System: Windows XP

Re: Apache Error! Won't start!

Postby Altrea » 27. July 2013 05:54

What is the response of starting \xampp\apache_start.bat in your Windows command line?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6829
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Apache Error! Won't start!

Postby Leel24 » 14. August 2013 07:12

apache was running a while ago until netbeans started. Now it refuse to start ,
Error: Apache shutdown unexpectedly.
10:58:05 AM [Apache] This may be due to a blocked port, missing dependencies,
10:58:05 AM [Apache] improper privileges, a crash, or a shutdown by another method.
10:58:05 AM [Apache] Press the Logs button to view error logs and check
10:58:05 AM [Apache] the Windows Event Viewer for more clues
10:58:05 AM [Apache] If you need more help, copy and post this
10:58:05 AM [Apache] entire log window on the forums

i checked the ports and non of pid using 80 or 443. No error reports available and when initiate apache_start.bat it display the below...

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
httpd.exe: Syntax error on line 514 of C:/xampp/apache/conf/httpd.conf: Syntax e
rror on line 17 of C:/xampp/apache/conf/extra/httpd-xampp.conf: Cannot load C:/x
ampp/php/php5ts.dll into server: The specified module could not be found.

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

Please give a solution !
Leel24
 
Posts: 1
Joined: 14. August 2013 06:34
XAMPP Version: 5.5.19
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: Altrea, persiatis and 37 guests