Apache Problems - Error (005ABEFE) [solved?]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Problems - Error (005ABEFE) [solved?]

Postby Lilinka » 23. October 2012 20:17

I am presently attempting to install Apache to get it running on the server. However, I am running into numerous problems along the way. The first sign that there was trouble was thus:

Code: Select all
3:10:46 PM  [Apache]    Installing service...
3:10:52 PM  [Apache]    Apache Service detected with wrong path
3:10:52 PM  [Apache]    Change XAMPP Apache settings or
3:10:52 PM  [Apache]    Uninstall/disable the other service manually first
3:10:52 PM  [Apache]    Found Path: ERROR: Not Able To Open Service Manager
3:10:52 PM  [Apache]    Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice
3:10:52 PM  [Apache]    Successful!


I have no idea how to change the XAMPP Apache settings to manually reconfigure the service, so I attempted to run Apache anyway, in the vain hope that it might work. When I did, I got the following error:

Code: Select all
3:13:04 PM [EXCEPTION]    System Error. Code: 5. Access is denied
3:13:04 PM [EXCEPTION]    Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042
3:13:04 PM [EXCEPTION]    Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042


At which point Windows forcibly closes the program and gives an error window saying that the program forced an EAccessViolation error at 001ABEFE.

I did a cursory search of the forums to try and find the source of the error but was unable to. Any help would be appreciated, thanks.

Edit: After a third reboot, starting the control panel first before starting Chrome to browse for help seems to have fixed the problem. I'm not quite sure how Chrome threw a wrench in things, but it did.
Lilinka
 
Posts: 1
Joined: 23. October 2012 20:06
XAMPP Version: 5.6.3
Operating System: Windows 7x64

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 25. October 2012 04:16

Those messages suggest to me that you might not be running the control panel with Admin privileges?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 29. April 2013 21:27

I'm also having this problem...

Tried doing everything that's been advised from:

> Uninstalling Skype
> Changing Skype port settings
> Changing Xampp ports
> Running Xammp as administrator

Nothing seems to work, does anyone have a set of instructions that can resolve this issue please?
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 30. April 2013 00:15

Hello,

1. What version of the control panel are you using? (you can get the latest from my signature)
2. What is causing the issue (starting a module, installing a service, etc..)?
3. Could you post the entire XAMPP control panel log window contents
4. Are you getting the exact same message (including the access denied) or are you just getting an access violation?
5. Did you run as Admin by right-clicking the control panel executable and 'Run as administrator'?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 30. April 2013 19:09

1. What version of the control panel are you using? (you can get the latest from my signature)
Xampp Control Panel v3.1.0 3.1.0

2. What is causing the issue (starting a module, installing a service, etc..)?
When trying to start Apache

3. Could you post the entire XAMPP control panel log window content
19:09:24 [main] Windows Version: Windows 7 Professional SP1 64-bit
19:09:24 [main] XAMPP Version: 1.8.1
19:09:24 [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
19:09:24 [main] You are not running with administrator rights! This will work for
19:09:24 [main] most application stuff but whenever you do something with services
19:09:24 [main] there will be a security dialogue or things will break! So think
19:09:24 [main] about running this application with administrator rights!
19:09:24 [main] XAMPP Installation Directory: "c:\xampp\"
19:09:24 [main] Checking for prerequisites
19:09:24 [main] All prerequisites found
19:09:24 [main] Initializing Modules
19:09:24 [Apache] Apache Service detected with wrong path
19:09:24 [Apache] Change XAMPP Apache settings or
19:09:24 [Apache] Uninstall/disable the other service manually first
19:09:24 [Apache] Found Path: ERROR: Not Able To Open Service Manager
19:09:24 [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice
19:09:24 [mysql] MySQL Service detected with wrong path
19:09:24 [mysql] Change XAMPP MySQL settings or
19:09:24 [mysql] Uninstall/disable the other service manually first
19:09:24 [mysql] Found Path: ERROR: Not Able To Open Service Manager
19:09:24 [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
19:09:24 [main] Starting Check-Timer
19:09:24 [main] Control Panel Ready

4. Are you getting the exact same message (including the access denied) or are you just getting an access violation?
Seems to be the same message: Exception EAccessViolation in module xampp-control.exe at 001ABEFE. Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042,

5. Did you run as Admin by right-clicking the control panel executable and 'Run as administrator'?
Yes, same thing happened
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby oreggiom266 » 30. April 2013 19:29

Having the same problem. When I try to change the port I want it to listen to, it gives me that same error message and crashed the program:

Code: Select all
3:13:04 PM [EXCEPTION]    System Error. Code: 5. Access is denied
3:13:04 PM [EXCEPTION]    Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042
3:13:04 PM [EXCEPTION]    Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042
oreggiom266
 
Posts: 2
Joined: 30. April 2013 19:18
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 30. April 2013 23:43

19:09:24 [main] You are not running with administrator rights! This will work for
19:09:24 [main] most application stuff but whenever you do something with services
19:09:24 [main] there will be a security dialogue or things will break! So think
19:09:24 [main] about running this application with administrator rights!
19:09:24 [Apache] Found Path: ERROR: Not Able To Open Service Manager

These indicate you are not running with Admin privileges.

You could try getting the latest Control Panel version (3.2.0) from the link in my signature. It has a lot of internal changes that reduce requested privileges.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 01. May 2013 21:23

I followed your signature and installed the latest version of Xampp and the control panel to start Apache but it just said the following:

20:21:50 [main] Initializing Control Panel
20:21:50 [main] Windows Version: Windows 7 Professional SP1 64-bit
20:21:50 [main] XAMPP Version: 1.8.1
20:21:50 [main] Control Panel Version: 3.2.0 [ Compiled: March 24th 2013 ]
20:21:50 [main] You are not running with administrator rights! This will work for
20:21:50 [main] most application stuff but whenever you do something with services
20:21:50 [main] there will be a security dialogue or things will break! So think
20:21:50 [main] about running this application with administrator rights!
20:21:50 [main] XAMPP Installation Directory: "c:\xampp\"
20:21:50 [main] Checking for prerequisites
20:21:50 [main] All prerequisites found
20:21:50 [main] Initializing Modules
20:21:50 [Apache] Apache Service detected with wrong path
20:21:50 [Apache] Change XAMPP Apache and Control Panel settings or
20:21:50 [Apache] Uninstall/disable the other service manually first
20:21:50 [Apache] Found Path: "E:\xampp\apache\bin\httpd.exe" -k runservice
20:21:50 [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice
20:21:50 [mysql] XAMPP MySQL Service is already running on port 3306
20:21:50 [Tomcat] Problem detected!
20:21:50 [Tomcat] Port 8080 in use by "C:\xampp\apache\bin\httpd.exe"!
20:21:50 [Tomcat] Tomcat WILL NOT start without the configured ports free!
20:21:50 [Tomcat] You need to uninstall/disable/reconfigure the blocking application
20:21:50 [Tomcat] or reconfigure Tomcat and the Control Panel to listen on a different port
20:21:50 [main] Enabling autostart for module "Apache"
20:21:50 [main] Starting Check-Timer
20:21:50 [main] Control Panel Ready
20:21:50 [Apache] Autostart active: starting...
20:21:50 [Apache] Attempting to start Apache service...

I left it for over 30mins but nothing happened.....
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 01. May 2013 22:03

20:21:50 [Apache] Apache Service detected with wrong path
20:21:50 [Apache] Change XAMPP Apache and Control Panel settings or
20:21:50 [Apache] Uninstall/disable the other service manually first
20:21:50 [Apache] Found Path: "E:\xampp\apache\bin\httpd.exe" -k runservice
20:21:50 [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice

You need to fix this. The control panel, by default, uses and looks for a service called "Apache2.4". What this error message is saying is that a service with that name is already installed but it does not belong to the current XAMPP you are trying to run.

If the Apache at "E:\xampp\apache\bin\httpd.exe" does not exist anymore, you can uninstall this service as follows (requires admin privileges):
1. Open a command prompt (Start > Run > cmd)
2. run "sc delete Apache2.4"

If you want to keep that service, you can do the following:
1. Open the Control Panel config (in the upper right)
2. Go to "Service and Port Settings"
3. Change the Service Name for Apache to something else
4. Save

20:21:50 [Tomcat] Problem detected!
20:21:50 [Tomcat] Port 8080 in use by "C:\xampp\apache\bin\httpd.exe"!

If you change the port that Apache is listening on, you need to change that in the Control Panel as well as follows:
1. Open the Control Panel Config (in upper right)
2. Go to "Service and Port Settings"
3. Update the ports
4. Save
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 03. May 2013 21:03

Thanks for your continued help, I followed your advice to uninstall the serve and got the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\user>sc delete Apache2.4
[SC] OpenService FAILED 5:

Access is denied.
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 04. May 2013 00:13

You need to run your command prompt with Admin privileges: http://technet.microsoft.com/en-us/library/cc947813(v=ws.10).aspx
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 06. May 2013 13:26

Managed to get it going, but /localhost/ doesn't load anything

13:24:48 [main] Initializing Control Panel
13:24:48 [main] Windows Version: Windows 7 Professional SP1 64-bit
13:24:48 [main] XAMPP Version: 1.8.1
13:24:48 [main] Control Panel Version: 3.2.0 [ Compiled: March 24th 2013 ]
13:24:48 [main] You are not running with administrator rights! This will work for
13:24:48 [main] most application stuff but whenever you do something with services
13:24:48 [main] there will be a security dialogue or things will break! So think
13:24:48 [main] about running this application with administrator rights!
13:24:48 [main] XAMPP Installation Directory: "c:\xampp\"
13:24:48 [main] Checking for prerequisites
13:24:48 [main] All prerequisites found
13:24:48 [main] Initializing Modules
13:24:48 [mysql] XAMPP MySQL Service is already running on port 3306
13:24:48 [main] Enabling autostart for module "Apache"
13:24:48 [main] Starting Check-Timer
13:24:48 [main] Control Panel Ready
13:24:49 [Apache] Autostart active: starting...
13:24:49 [Apache] Attempting to start Apache app...
13:24:49 [Apache] Status change detected: running
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby hackattack142 » 06. May 2013 21:45

Do you get to the XAMPP page if you go to http://localhost ?

Did you change the port XAMPP/Apache listens on?
If you did (lets say you changed it to 8080) then you have to access your pages like this: http://localhost:8080
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Problems - Error (005ABEFE) [solved?]

Postby ForbiddenChunk » 10. May 2013 09:48

Yep that got it working!

Thanks for all your help with it :-)
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests