Window 8 - LocalHost - XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 01:11

I am so frustrated, if there is anyone in Los Angeles I will drive to you and meet you at a Starbuck's ( and spring for a latte or lunch somewhere) if you can get my Windows 8 running with XAMPP and my LocalHost and security issues going properly.

I've got Windows 8 PRO on my laptop. Just installed latest XAMPP & with latest control panel.
I launched control panel and started Apache & mySQL.
I edited my HOSTS file and now I have these lines:

------------
# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
# ::1 localhost
-------------------

If I try to go to http://localhost/xampp/index.php OR http://localhost/xampp/xampp.php OR even http://localhost/xampp/ it cannot find any of those. Any help would be appreciated
--------------------------
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP

Postby hackattack142 » 29. November 2012 01:27

Could you post the entire Control Panel log window in here after you start the control panel and start Apache and MySQL
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 01:43

OK

4:39:06 PM [main] Windows Version: 32-bit
4:39:06 PM [main] XAMPP Version: 1.8.1
4:39:06 PM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
4:39:06 PM [main] You are not running with administrator rights! This will work for
4:39:06 PM [main] most application stuff but whenever you do something with services
4:39:06 PM [main] there will be a security dialogue or things will break! So think
4:39:06 PM [main] about running this application with administrator rights!

4:39:06 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:39:07 PM [main] Checking for prerequisites
4:39:07 PM [main] All prerequisites found
4:39:07 PM [main] Initializing Modules
4:39:07 PM [mysql] MySQL Service detected with wrong path
4:39:07 PM [mysql] Change XAMPP MySQL settings or
4:39:07 PM [mysql] Uninstall/disable the other service manually first
4:39:07 PM [mysql] Found Path: ERROR: Not Able To Open Service Manager
4:39:07 PM [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
4:39:07 PM [main] Starting Check-Timer
4:39:07 PM [main] Control Panel Ready
4:41:04 PM [Apache] Attempting to start Apache app...
4:41:04 PM [Apache] Status change detected: running
4:41:13 PM [mysql] Attempting to start MySQL service...
4:41:24 PM [mysql] Status change detected: running

-------------

I couldn't help noticing the Administrator thing. I have had this issue since installing Windows 8. I am the only user on the machine and I have full admin rights, so I am not sure if this is related.
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP

Postby hackattack142 » 29. November 2012 01:51

If you have UAC enabled, you can right-click and Run as Admin (I assume that did not change in Win 8 )

What happens if you just type http://localhost

Are you running anything like Windows Firewall that might be disrupting it?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 05:37

if I just do http://localhost I get a the Teat Page for Apache install. It starts with text:

"If you can see this, it means that the installation of the Apache web server software on this system was successful. You may now add content to this directory and replace this page."
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP

Postby hackattack142 » 29. November 2012 05:47

Ah, it looks like Win 8 might favor IPv6 now.

If you open your HOSTS file and uncomment that second line "::1 localhost", this is the IPv6 localhost.

See if that solves your problem
Last edited by hackattack142 on 29. November 2012 05:56, edited 1 time in total.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 05:54

But I did notice that in the directory xampp\htdocs there is a file index.php, when I try to open that file in a browser I get a message saying something is wrong with my XAMPP installtion. The text of the file is:

---------------------------------------
<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(


---------------

I am going to uninstall and reinstall
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 05:57

I think I made a mistake. I tried installing Apache and MySQL standalone, I don';t think the process worked right for either of them.

Then I installed XAMPP over those and that may be the conflict. Now I need to uninstall EVERTYTHING and start again.
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP

Postby hackattack142 » 29. November 2012 05:57

I just edited my last comment. See if that helps as well as removing the standalone ones.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Window 8 - LocalHost - XAMPP

Postby waynehazle » 29. November 2012 07:47

EUREKA!!!
I uninstalled everything and re-installed and now when I go to: http://localhost/xampp/index.php

I get the XAMPP control panel :D
waynehazle
 
Posts: 7
Joined: 28. November 2012 04:11
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Window 8 - LocalHost - XAMPP & UAC

Postby iskeen » 24. April 2013 16:31

Important note about User Account Control in Windows 8. THERE IS AN IMPORTANT CHANGE IN UAC FOR WINDOWS 8!

In Windows 8, you can make UAC quiescent, but you cannot turn it off from the UAC user control window. Apache will not install properly with UAC quiescent. In order to turn off UAC, I had to download a little ap called TweakUAC. It is free and it does the job. When I tried to turn on UAC after installation of Apache, neither product liked it. Even quiescent, UAC kills Apache and when UAC is not on, you can't get any of the new, splashy features that they advertise as "the big deal" with windows 8.

So, for windows 8 installation, you need to know how to turn of UAC from the inside or get TweakUAC until that command gets bundled into the Apache installation distribution or UAC and Apache learn how to play in the sandbox together. As of now, Microsoft's attitude is "old west" -- the only good Indian is a dead Indian.
"Art is the indispensible medium for the communication of a moral ideal."
--Ayn Rand
User avatar
iskeen
 
Posts: 10
Joined: 10. December 2009 07:47
Location: NYC
XAMPP Version: 5.6.3
Operating System: Windows Vista, Win 8 (2 pcs)

Re: Window 8 - LocalHost - XAMPP

Postby xfl » 01. February 2015 23:39

Window 8.1 LocalHost - XAMPP & UAC

I successfully loaded the latest XAMPP stack to my Windows 8.1 machine after receiving the same warnings shown below.
The UAC warning appears to have been related to Windows "assuming" the install was going to happen in the Windows software directory and not the usual c:\xampp directory.

I ignored the warning and made sure to install in the default C:\XAMPP directory. The installation was successful, however upon starting the XAMPP control panel I received warnings about the Apache and MySQL ports being blocked.

The PC is running McAfee security, so I went to
McAfee -> Firewall -> Ports & System Services, and placed a checkmark for HTTPS port 443 and HTTP port 80 to open them.

Restarted XAMPP control panel and everything works fine. No UAC issues...

Hope that helps. :-)
xfl
 
Posts: 1
Joined: 27. January 2013 23:30
XAMPP Version: 5.5.19
Operating System: WinXP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests